linux-next.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* Please add PTR_RET tree.
@ 2013-07-15  4:37 Rusty Russell
  2013-07-15  7:38 ` Stephen Rothwell
  0 siblings, 1 reply; 4+ messages in thread
From: Rusty Russell @ 2013-07-15  4:37 UTC (permalink / raw)
  To: Stephen Rothwell
  Cc: linux-next, lkml, Julia Lawall, Michael S. Tsirkin,
	Sebastian Hesselbarth, Dan Magenheimer

Temporary branch for PTR_RET -> PTR_ERR_OR_ZERO and associated cleanups.

        git://git.kernel.org/pub/scm/linux/kernel/git/rusty/linux.git PTR_RET

Log appended.  Contributors and people who didn't already ack CC'd.

Cheers,
Rusty.

commit 6e8b8726ad503214ba66e34aed69aff41de33489
Author: Rusty Russell <rusty@rustcorp.com.au>
Date:   Mon Jul 15 11:19:32 2013 +0930

    PTR_RET is now PTR_ERR_OR_ZERO
    
    True, it's often used in return statements, but after much bikeshedding
    it's probably better to have an explicit name.
    
    (I tried just putting the IS_ERR check inside PTR_ERR itself and gcc
    usually generated no more code.  But that clashes current expectations
    of how PTR_ERR behaves, so having a separate function is better).
    
    Suggested-by: Julia Lawall <julia.lawall@lip6.fr>
    Suggested-by: "Michael S. Tsirkin" <mst@redhat.com>
    Cc: Julia Lawall <julia.lawall@lip6.fr>
    Cc: "Michael S. Tsirkin" <mst@redhat.com>
    Signed-off-by: Rusty Russell <rusty@rustcorp.com.au>

commit 8c6ffba0eddc8c110dbf444f51354ce42069abfc
Author: Rusty Russell <rusty@rustcorp.com.au>
Date:   Mon Jul 15 11:20:32 2013 +0930

    PTR_RET is now PTR_ERR_OR_ZERO(): Replace most.
    
    Sweep of the simple cases.
    
    Cc: netdev@vger.kernel.org
    Cc: linuxppc-dev@lists.ozlabs.org
    Cc: linux-arm-kernel@lists.infradead.org
    Cc: Julia Lawall <julia.lawall@lip6.fr>
    Signed-off-by: Rusty Russell <rusty@rustcorp.com.au>
    Acked-by: David S. Miller <davem@davemloft.net>
    Acked-by: Benjamin Herrenschmidt <benh@kernel.crashing.org>

commit 228b82211b47b597fa75dff2ac146b40eaaddf18
Author: Rusty Russell <rusty@rustcorp.com.au>
Date:   Mon Jul 15 11:21:32 2013 +0930

    s390: Replace weird use of PTR_RET.
    
    Saves repeating "(void __force *)__uptr" but it's less clear.  Using
    the output of PTR_RET() to determine the error rather than just
    testing IS_ERR() is odd.
    
    For example, I *assume* __gptr_to_uptr() never returns NULL?  Because
    the __ret would be 0 for the old code.  The new version is clearer, IMHO:
    it would try to get_user() on that address.
    
    If you hate this variant, I can just s/PTR_RET/PTR_ERR_OR_ZERO/ instead.
    
    Cc: Christian Borntraeger <borntraeger@de.ibm.com>
    Cc: Martin Schwidefsky <schwidefsky@de.ibm.com>
    Signed-off-by: Rusty Russell <rusty@rustcorp.com.au>
    Acked-by: Heiko Carstens <heiko.carstens@de.ibm.com>

commit 5d7e438629413586ab78779751caa6e713c2234c
Author: Rusty Russell <rusty@rustcorp.com.au>
Date:   Mon Jul 15 11:22:32 2013 +0930

    acpi: Replace weird use of PTR_RET.
    
    This functions is really weird.  It sets rc to -ENOMEM, then overrides
    it.  It was converted to PTR_RET in a1458187 when it should have
    simply been rewritten.
    
    This version makes it more explicit, with a single IS_ERR() test.
    
    Cc: Alexandru Gheorghiu <gheorghiuandru@gmail.com>
    Signed-off-by: Rusty Russell <rusty@rustcorp.com.au>
    Acked-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>

commit 5795c6ac7c77dc2363c41948cf828916c17cf78f
Author: Rusty Russell <rusty@rustcorp.com.au>
Date:   Mon Jul 15 11:23:32 2013 +0930

    pinctrl: don't use PTR_RET().
    
    We've already tested that it's an error.
    
    Cc: Sebastian Hesselbarth <sebastian.hesselbarth@gmail.com>
    Signed-off-by: Rusty Russell <rusty@rustcorp.com.au>

commit 60d676c007964576e83d791fc0908af8d133519f
Author: Rusty Russell <rusty@rustcorp.com.au>
Date:   Mon Jul 15 11:24:08 2013 +0930

    remoteproc: don't use PTR_RET().
    
    We've already tested that it's an error.
    
    Cc: Robert Tivy <rtivy@ti.com>
    Signed-off-by: Rusty Russell <rusty@rustcorp.com.au>
    Acked-by: Ohad Ben-Cohen <ohad@wizery.com>

commit 8a1d41cfeaf59a07acc7b1b3620ad6aa5cf47dc2
Author: Rusty Russell <rusty@rustcorp.com.au>
Date:   Mon Jul 15 11:24:08 2013 +0930

    staging/zcache: don't use PTR_RET().
    
    We've already tested that it's an error.
    
    Cc: Dan Magenheimer <dan.magenheimer@oracle.com>
    Signed-off-by: Rusty Russell <rusty@rustcorp.com.au>

commit 6b4f2b56a48c8ea9775bd2b29681725d4474367a
Author: Rusty Russell <rusty@rustcorp.com.au>
Date:   Mon Jul 15 11:24:08 2013 +0930

    mm/oom_kill: remove weird use of ERR_PTR()/PTR_ERR().
    
    The normal expectation for ERR_PTR() is to put a negative errno into a
    pointer.  oom_kill puts the magic -1 in the result (and has since
    pre-git), which is probably clearer with an explicit cast.
    
    Cc: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Rusty Russell <rusty@rustcorp.com.au>

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Please add PTR_RET tree.
  2013-07-15  4:37 Please add PTR_RET tree Rusty Russell
@ 2013-07-15  7:38 ` Stephen Rothwell
  2013-09-17  0:50   ` Rusty Russell
  0 siblings, 1 reply; 4+ messages in thread
From: Stephen Rothwell @ 2013-07-15  7:38 UTC (permalink / raw)
  To: Rusty Russell
  Cc: linux-next, lkml, Julia Lawall, Michael S. Tsirkin,
	Sebastian Hesselbarth, Dan Magenheimer

[-- Attachment #1: Type: text/plain, Size: 1900 bytes --]

Hi Rusty,

On Mon, 15 Jul 2013 14:07:03 +0930 Rusty Russell <rusty@rustcorp.com.au> wrote:
>
> Temporary branch for PTR_RET -> PTR_ERR_OR_ZERO and associated cleanups.
> 
>         git://git.kernel.org/pub/scm/linux/kernel/git/rusty/linux.git PTR_RET
> 
> Log appended.  Contributors and people who didn't already ack CC'd.

Added from tomorrow.

Thanks for adding your subsystem tree as a participant of linux-next.  As
you may know, this is not a judgment of your code.  The purpose of
linux-next is for integration testing and to lower the impact of
conflicts between subsystems in the next merge window. 

You will need to ensure that the patches/commits in your tree/series have
been:
     * submitted under GPL v2 (or later) and include the Contributor's
	Signed-off-by,
     * posted to the relevant mailing list,
     * reviewed by you (or another maintainer of your subsystem tree),
     * successfully unit tested, and 
     * destined for the current or next Linux merge window.

Basically, this should be just what you would send to Linus (or ask him
to fetch).  It is allowed to be rebased if you deem it necessary.

-- 
Cheers,
Stephen Rothwell 
sfr@canb.auug.org.au

Legal Stuff:
By participating in linux-next, your subsystem tree contributions are
public and will be included in the linux-next trees.  You may be sent
e-mail messages indicating errors or other issues when the
patches/commits from your subsystem tree are merged and tested in
linux-next.  These messages may also be cross-posted to the linux-next
mailing list, the linux-kernel mailing list, etc.  The linux-next tree
project and IBM (my employer) make no warranties regarding the linux-next
project, the testing procedures, the results, the e-mails, etc.  If you
don't agree to these ground rules, let me know and I'll remove your tree
from participation in linux-next.

[-- Attachment #2: Type: application/pgp-signature, Size: 836 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Please add PTR_RET tree.
  2013-07-15  7:38 ` Stephen Rothwell
@ 2013-09-17  0:50   ` Rusty Russell
  2013-09-17  5:08     ` Stephen Rothwell
  0 siblings, 1 reply; 4+ messages in thread
From: Rusty Russell @ 2013-09-17  0:50 UTC (permalink / raw)
  To: Stephen Rothwell
  Cc: linux-next, lkml, Julia Lawall, Michael S. Tsirkin,
	Sebastian Hesselbarth, Dan Magenheimer

Stephen Rothwell <sfr@canb.auug.org.au> writes:
> Hi Rusty,
>
> On Mon, 15 Jul 2013 14:07:03 +0930 Rusty Russell <rusty@rustcorp.com.au> wrote:
>>
>> Temporary branch for PTR_RET -> PTR_ERR_OR_ZERO and associated cleanups.
>> 
>>         git://git.kernel.org/pub/scm/linux/kernel/git/rusty/linux.git PTR_RET
>> 
>> Log appended.  Contributors and people who didn't already ack CC'd.
>
> Added from tomorrow.

Please remove PTR_RET tree, it's merged.

Cheers,
Rusty.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Please add PTR_RET tree.
  2013-09-17  0:50   ` Rusty Russell
@ 2013-09-17  5:08     ` Stephen Rothwell
  0 siblings, 0 replies; 4+ messages in thread
From: Stephen Rothwell @ 2013-09-17  5:08 UTC (permalink / raw)
  To: Rusty Russell
  Cc: linux-next, lkml, Julia Lawall, Michael S. Tsirkin,
	Sebastian Hesselbarth, Dan Magenheimer

[-- Attachment #1: Type: text/plain, Size: 250 bytes --]

Hi Rusty,

On Tue, 17 Sep 2013 10:20:55 +0930 Rusty Russell <rusty@rustcorp.com.au> wrote:
>
> Please remove PTR_RET tree, it's merged.

OK, thanks for letting me know.

-- 
Cheers,
Stephen Rothwell                    sfr@canb.auug.org.au

[-- Attachment #2: Type: application/pgp-signature, Size: 836 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2013-09-17  5:08 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-07-15  4:37 Please add PTR_RET tree Rusty Russell
2013-07-15  7:38 ` Stephen Rothwell
2013-09-17  0:50   ` Rusty Russell
2013-09-17  5:08     ` Stephen Rothwell

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).