linux-nvme.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-07-02 08:27:59 to 2020-07-16 00:27:53 UTC [more...]

[PATCH 1/2] nvme-tpc: don't use sendpage for pages not taking reference counter
 2020-07-16  0:27 UTC  (5+ messages)
` [PATCH 2/2] bcache: allocate meta data pages as compound pages

[PATCH v3 0/2] Export max open zones and max active zones to sysfs
 2020-07-15 20:26 UTC  (7+ messages)
` [PATCH v3 1/2] block: add max_open_zones to blk-sysfs
` [PATCH v3 2/2] block: add max_active_zones "

[PATCH] nvme-fc: set max_segments to lldd max value
 2020-07-15  9:04 UTC  (2+ messages)

[PATCH V3 00/10] nvme: use xarray for ns tracking
 2020-07-15  7:11 UTC  (22+ messages)
` [PATCH V3 01/10] xarray: add __xa_load() version
` [PATCH V3 02/10] nvme-core: use xarray for ctrl ns tracking
` [PATCH V3 03/10] nvme: centralize queue action nvme_kill_queues()
` [PATCH V3 04/10] nvme: centralize queue action nvme_unfreeze()
` [PATCH V3 05/10] nvme: centralize queue action nvme_wait_freeze()
` [PATCH V3 06/10] nvme: centralize queue action nvme_start_freeze()
` [PATCH V3 07/10] nvme: centralize queue action nvme_stop_queues()
` [PATCH V3 08/10] nvme: centralize queue action nvme_start_queues()
` [PATCH V3 09/10] nvme: centralize queue action nvme_sync_queues()
` [PATCH V3 10/10] nvmet: use xarray for ctrl ns storing

[linux-nvme:nvme-5.8] BUILD SUCCESS b5d26bf0ba8719e34fd9e627cf2d955db2d8c099
 2020-07-15  4:02 UTC 

[linux-nvme:nvme-5.9] BUILD SUCCESS 375a227e31c04360750cc0f2968975472a03c731
 2020-07-15  3:08 UTC 

[PATCH V2 0/2] nvme: fix iod size calculation in nvme_probe()
 2020-07-14 16:44 UTC  (10+ messages)
` [PATCH V2 1/2] nvme-core: replace ctrl page size with a macro
` [PATCH V2 2/2] nvme-pci: use max of PRP or SGL for iod size

[PATCH] nvme: Namepace identification descriptor list is optional
 2020-07-14 15:21 UTC  (3+ messages)

[PATCH 0/2] NVMe/RDMA CQ pool patches for 5.9
 2020-07-14 11:18 UTC  (4+ messages)
` [PATCH 1/2] nvme-rdma: use new shared CQ mechanism
` [PATCH 2/2] nvmet-rdma: "

[PATCH] nvme: Remove redundant validation in nvme_start_ctrl()
 2020-07-14 11:17 UTC  (5+ messages)

[PATCH] nvme: remove an unnecessary condition
 2020-07-14 11:17 UTC  (2+ messages)

[PATCH v2 for-5.8-rc 0/6] address deadlocks in high stress ns scanning and ana updates
 2020-07-14 11:12 UTC  (8+ messages)
` [PATCH v2 for-5.8-rc 1/6] nvme: fix possible deadlock when I/O is blocked

[PATCH v2 rfc 0/3] resolve controller delete hang due to ongoing mpath I/O
 2020-07-14 11:06 UTC  (7+ messages)
` [PATCH v2 rfc 1/3] nvme: split nvme_remove_namespaces
` [PATCH v2 rfc 2/3] nvme: document nvme controller states
` [PATCH v2 rfc 3/3] nvme-core: fix deadlock in disconnect during scan_work and/or ana_work

[PATCH v7] nvme-fabrics: reject I/O to offline device
 2020-07-14 11:04 UTC  (5+ messages)

[RFC PATCH 09/35] nvme-pci: Change PCIBIOS_SUCCESSFUL to 0
 2020-07-13 18:24 UTC  (4+ messages)
` [RFC PATCH 10/35] nvme-pci: Tidy Success/Failure checks

[PATCH v2] nvme-tcp: don't use sendpage for pages not taking reference counter
 2020-07-13 12:44 UTC 

[PATCH V2 0/2] nvme: Add support for ACPI StorageD3Enable property
 2020-07-13 11:12 UTC  (7+ messages)
` [PATCH v4] drivers/nvme: "
  ` [PATCH V5] "

[PATCH V3 0/2] nvme: fix iod size calculation in nvme_probe()
 2020-07-11 20:34 UTC  (3+ messages)
` [PATCH V3 1/2] nvme-core: replace ctrl page size with a macro
` [PATCH V3 2/2] nvme-pci: use max of PRP or SGL for iod size

[GIT PULL] first round of nvme updates for 5.9
 2020-07-10 14:02 UTC  (2+ messages)

[PATCH] nvme: Namepace identification descriptor list is optional
 2020-07-10  8:22 UTC  (2+ messages)

[PATCH 0/4] nvme: fix iod size calculation in nvme_probe()
 2020-07-08 23:28 UTC  (9+ messages)
` [PATCH 1/4] nvme-core: use macro for ctrl page size default value
` [PATCH 2/4] nvme-pci: don't use ctrl page size value in probe
` [PATCH 3/4] nvme-pci: use max of PRP or SGL for iod size
` [PATCH 4/4] nvme-core: fix checkpatch warnings

[PATCH] nvme: remove ns->disk checks
 2020-07-08 17:12 UTC  (3+ messages)

[PATCH] nvme-pci: use standard block status symbolic names to check return value
 2020-07-08  6:17 UTC  (3+ messages)

[PATCH 0/5] Some cleanups for NVMe-pci driver
 2020-07-08  6:05 UTC  (19+ messages)
` [PATCH 1/5] nvme-pci: Fix some comments issues
` [PATCH 2/5] nvme-pci: Add a blank line after declarations
` [PATCH 3/5] nvme-pci: Remove redundant segment validation
` [PATCH 4/5] nvme-pci: Use the consistent return type of nvme_pci_iod_alloc_size()
` [PATCH 5/5] nvme-pci: Use standard block status macro

[RFC PATCH 0/5] nvme: reduce repetitive calls in fast path
 2020-07-07 18:10 UTC  (8+ messages)
` [RFC PATCH 1/5] nvme-pci: reduce blk_rq_nr_phys_segments calls
` [RFC PATCH 2/5 COMPILE TESTED] nvme-rdma: "
` [RFC PATCH 3/5 COMPILE TESTED] nvme-tcp: "
` [RFC PATCH 4/5 COMPILE TESTED] nvme-fc: "
` [RFC PATCH 5/5] nvme-loop: "

[PATCH 0/2] Zone Descriptor Extension for Zoned Block Devices
 2020-07-07 16:03 UTC  (7+ messages)
` [PATCH 2/2] block: add BLKSETDESCZONE ioctl "

[PATCH RFC] nvme-pci: remove the unsed code in alloc_size
 2020-07-07 15:53 UTC  (3+ messages)

[linux-nvme:nvme-5.9 34/40] drivers/nvme/host/core.c:3567:1: sparse: sparse: symbol 'dev_attr_ctrl_loss_tmo' was not declared. Should it be
 2020-07-07 10:55 UTC  (3+ messages)
` [RFC PATCH linux-nvme] nvme: dev_attr_ctrl_loss_tmo can be static

[PATCH] nvme: expose reconnect_delay and ctrl_loss_tmo via sysfs
 2020-07-07  8:51 UTC  (2+ messages)

[PATCH] nvme: document quirked Intel models
 2020-07-07  8:48 UTC  (2+ messages)

[PATCH] nvme-tcp: remove dead code in map data
 2020-07-06 19:46 UTC 

[PATCH] nvme: associate stripe size quirk with D4512
 2020-07-03 20:16 UTC  (8+ messages)

[PATCH v2 0/2] Export max open zones and max active zones to sysfs
 2020-07-03 14:15 UTC  (10+ messages)
` [PATCH v2 1/2] block: add max_open_zones to blk-sysfs
` [PATCH v2 2/2] block: add max_active_zones "

[V2 PATCH 0/4] ZNS: Extra features for current patche
 2020-07-03  8:35 UTC  (16+ messages)
` [PATCH 1/4] block: Add zone flags to queue zone prop
` [PATCH 2/4] block: add support for zone offline transition
` [PATCH 3/4] nvme: Add consistency check for zone count

[PATCH 0/2] Export max open zones and max active zones to sysfs
 2020-07-03  4:56 UTC  (9+ messages)
` [PATCH 1/2] block: add max_open_zones to blk-sysfs
` [PATCH 2/2] block: add max_active_zones "

rename ->make_request_fn and move it to the block_device_operations v2
 2020-07-02 18:22 UTC  (8+ messages)
` [PATCH 09/20] bcache: stop setting ->queuedata
` [PATCH 16/20] block: move ->make_request_fn to struct block_device_operations
` [PATCH 17/20] block: rename generic_make_request to submit_bio_noacct

[GIT PULL] nvme fixes for 5.8
 2020-07-02 18:11 UTC  (2+ messages)

rename ->make_request_fn and move it to the block_device_operations
 2020-07-02 15:52 UTC  (6+ messages)
` [PATCH 18/20] block: refator submit_bio_noacct

[PATCH v6] nvme-fabrics: reject I/O to offline device
 2020-07-02 14:48 UTC  (2+ messages)

[PATCH V4] nvme-fabrics: reject I/O to offline device
 2020-07-02 14:35 UTC  (4+ messages)

[PATCH v3 0/4] ZNS: Extra features for current patches
 2020-07-02 10:18 UTC  (9+ messages)
` [PATCH v3 1/4] block: Add zone flags to queue zone prop
` [PATCH v3 2/4] block: add support for zone offline transition
` [PATCH v3 3/4] nvme: Add consistency check for zone count
` [PATCH v3 4/4] block: add attributes to zone report


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).