linux-pci.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [RFC PATCH v1 1/6] PCI: change PCI device management logic to better follow device model
@ 2012-06-04  5:16 Jiang Liu
  2012-06-04  5:16 ` [RFC PATCH v1 2/6] PCI: split PCI bus device registration into two stages Jiang Liu
                   ` (6 more replies)
  0 siblings, 7 replies; 8+ messages in thread
From: Jiang Liu @ 2012-06-04  5:16 UTC (permalink / raw)
  To: Bjorn Helgaas, Yinghai Lu, Kenji Kaneshige
  Cc: Jiang Liu, Taku Izumi, Don Dutile, Greg KH, Yijing Wang,
	Keping Chen, linux-pci, linux-kernel

From: Jiang Liu <liuj97@gmail.com>

According to device model documentation, the way to add/remove device
object should be symmetric.

/**
 * device_del - delete device from system.
 * @dev: device.
 *
 * This is the first part of the device unregistration
 * sequence. This removes the device from the lists we control
 * from here, has it removed from the other driver model
 * subsystems it was added to in device_add(), and removes it
 * from the kobject hierarchy.
 *
 * NOTE: this should be called manually _iff_ device_add() was
 * also called manually.
 */

The rule here is to either use
1) device_register()/device_unregister()
or
2) device_initialize()/device_add()/device_del()/put_device().

So change PCI core to follow the rule and get rid of the redundant
pci_dev_get()/pci_dev_put() pair.

Signed-off-by: Jiang Liu <liuj97@gmail.com>
---
 drivers/pci/probe.c  |    1 -
 drivers/pci/remove.c |    4 ++--
 2 files changed, 2 insertions(+), 3 deletions(-)

diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
index 0840409..dacca26 100644
--- a/drivers/pci/probe.c
+++ b/drivers/pci/probe.c
@@ -1294,7 +1294,6 @@ void pci_device_add(struct pci_dev *dev, struct pci_bus *bus)
 {
 	device_initialize(&dev->dev);
 	dev->dev.release = pci_release_dev;
-	pci_dev_get(dev);
 
 	dev->dev.dma_mask = &dev->dma_mask;
 	dev->dev.dma_parms = &dev->dma_parms;
diff --git a/drivers/pci/remove.c b/drivers/pci/remove.c
index 04a4861..6c07bc5 100644
--- a/drivers/pci/remove.c
+++ b/drivers/pci/remove.c
@@ -22,7 +22,7 @@ static void pci_stop_dev(struct pci_dev *dev)
 	if (dev->is_added) {
 		pci_proc_detach_device(dev);
 		pci_remove_sysfs_dev_files(dev);
-		device_unregister(&dev->dev);
+		device_del(&dev->dev);
 		dev->is_added = 0;
 	}
 
@@ -40,7 +40,7 @@ static void pci_destroy_dev(struct pci_dev *dev)
 	up_write(&pci_bus_sem);
 
 	pci_free_resources(dev);
-	pci_dev_put(dev);
+	put_device(&dev->dev);
 }
 
 /**
-- 
1.7.1



^ permalink raw reply related	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2012-08-15 20:21 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-06-04  5:16 [RFC PATCH v1 1/6] PCI: change PCI device management logic to better follow device model Jiang Liu
2012-06-04  5:16 ` [RFC PATCH v1 2/6] PCI: split PCI bus device registration into two stages Jiang Liu
2012-06-04  5:16 ` [RFC PATCH v1 3/6] PCI, ACPI: correctly update binding info when PCI hotplug event happens Jiang Liu
2012-06-04  5:17 ` [RFC PATCH v1 4/6] PCI, ACPI: update PCI slot information " Jiang Liu
2012-06-04  5:17 ` [RFC PATCH v1 5/6] PCI, ACPI: update ACPI hotplug " Jiang Liu
2012-06-04  5:17 ` [RFC PATCH v1 6/6] PCI: update AER configuration " Jiang Liu
2012-06-14  9:18 ` [RFC PATCH v1 1/6] PCI: change PCI device management logic to better follow device model Taku Izumi
2012-08-15 20:21 ` Bjorn Helgaas

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).