linux-perf-users.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2021-12-23 07:48:17 to 2022-01-06 20:34:14 UTC [more...]

[PATCH 00/20] perf: fix several memory leaks reported by ASan on perf-test
 2022-01-06 20:34 UTC  (7+ messages)
` [PATCH 01/20] perf nsinfo: fix refcounting

[PATCH bpf-next 0/2] perf: stop using deprecated bpf APIs
 2022-01-06 20:25 UTC  (11+ messages)
` [PATCH bpf-next 2/2] perf: stop using deprecated bpf__object_next() API

[PATCH bpf-next 0/5] libbpf 1.0: deprecate bpf_map__def() API
 2022-01-06 20:24 UTC  (8+ messages)
` [PATCH bpf-next 1/5] samples/bpf: stop using "
` [PATCH bpf-next 2/5] bpftool: "
` [PATCH bpf-next 3/5] perf: "
` [PATCH bpf-next 4/5] selftests/bpf: "
` [PATCH bpf-next 5/5] libbpf: deprecate "

[PATCH] perf build: Lower the priority of tools/lib includes
 2022-01-06 20:24 UTC  (4+ messages)

[PATCH V2 1/2] tools/perf: Include global and local variants for p_stage_cyc sort key
 2022-01-06 20:22 UTC  (5+ messages)

[PATCH v2 1/2] perf vendor events: For the Arm Neoverse N2
 2022-01-06 18:24 UTC  (11+ messages)
` [RFC PATCH 0/1] topdown with metrics
  ` [RFC PATCH 1/1] perf arm64: Implement --topdown "

[PATCH v3 1/4] perf: Enable libtracefs dynamic linking
 2022-01-06  7:01 UTC  (9+ messages)
` [PATCH v3 4/4] libtraceevent: Increase libtraceevent logging when verbose
    ` [was: libtraceevent: Increase libtraceevent logging when verbose]

[PATCH] powerpc/perf: fix ppc64 perf probe add events failed
 2022-01-06  1:56 UTC  (4+ messages)

[PATCH v13 0/5] arm64 userspace counter support
 2022-01-05 11:25 UTC  (5+ messages)
` [PATCH v13 3/5] arm64: perf: Add userspace counter access disable switch

[PATCH v4 00/48] Refactor perf cpumap
 2022-01-05  6:13 UTC  (49+ messages)
` [PATCH v4 01/48] libperf: Add comments to perf_cpu_map
` [PATCH v4 02/48] perf stat: Add aggr creators that are passed a cpu
` [PATCH v4 03/48] perf stat: Correct aggregation CPU map
` [PATCH v4 04/48] perf stat: Switch aggregation to use for_each loop
` [PATCH v4 05/48] perf stat: Switch to cpu version of cpu_map__get
` [PATCH v4 06/48] perf cpumap: Switch cpu_map__build_map to cpu function
` [PATCH v4 07/48] perf cpumap: Remove map+index get_socket
` [PATCH v4 08/48] perf cpumap: Remove map+index get_die
` [PATCH v4 09/48] perf cpumap: Remove map+index get_core
` [PATCH v4 10/48] perf cpumap: Remove map+index get_node
` [PATCH v4 11/48] perf cpumap: Add comments to aggr_cpu_id
` [PATCH v4 12/48] perf cpumap: Remove unused cpu_map__socket
` [PATCH v4 13/48] perf cpumap: Simplify equal function name
` [PATCH v4 14/48] perf cpumap: Rename empty functions
` [PATCH v4 15/48] perf cpumap: Document cpu__get_node and remove redundant function
` [PATCH v4 16/48] perf cpumap: Remove map from function names that don't use a map
` [PATCH v4 17/48] perf cpumap: Remove cpu_map__cpu, use libperf function
` [PATCH v4 18/48] perf cpumap: Refactor cpu_map__build_map
` [PATCH v4 19/48] perf cpumap: Rename cpu_map__get_X_aggr_by_cpu functions
` [PATCH v4 20/48] perf cpumap: Move 'has' function to libperf
` [PATCH v4 21/48] perf cpumap: Add some comments to cpu_aggr_map
` [PATCH v4 22/48] perf cpumap: Trim the cpu_aggr_map
` [PATCH v4 23/48] perf stat: Fix memory leak in check_per_pkg
` [PATCH v4 24/48] perf cpumap: Add CPU to aggr_cpu_id
` [PATCH v4 25/48] perf stat-display: Avoid use of core for CPU
` [PATCH v4 26/48] perf evsel: Derive CPUs and threads in alloc_counts
` [PATCH v4 27/48] libperf: Switch cpu to more accurate cpu_map_idx
` [PATCH v4 28/48] libperf: Use cpu not index for evsel mmap
` [PATCH v4 29/48] perf counts: Switch name cpu to cpu_map_idx
` [PATCH v4 30/48] perf stat: Rename aggr_data cpu to imply it's an index
` [PATCH v4 31/48] perf stat: Use perf_cpu_map__for_each_cpu
` [PATCH v4 32/48] perf script: Use for each cpu to aid readability
` [PATCH v4 33/48] libperf: Allow NULL in perf_cpu_map__idx
` [PATCH v4 34/48] perf evlist: Refactor evlist__for_each_cpu
` [PATCH v4 35/48] perf evsel: Pass cpu not cpu map index to synthesize
` [PATCH v4 36/48] perf stat: Correct variable name for read counter
` [PATCH v4 37/48] perf evsel: Rename CPU around get_group_fd
` [PATCH v4 38/48] perf evsel: Reduce scope of evsel__ignore_missing_thread
` [PATCH v4 39/48] perf evsel: Rename variable cpu to index
` [PATCH v4 40/48] perf test: Use perf_cpu_map__for_each_cpu
` [PATCH v4 41/48] perf stat: Correct check_per_pkg cpu
` [PATCH v4 42/48] perf stat: Swap variable name cpu to index
` [PATCH v4 43/48] libperf: Sync evsel documentation
` [PATCH v4 44/48] perf bpf: Rename cpu to cpu_map_idx
` [PATCH v4 45/48] perf c2c: Use more intention revealing iterator
` [PATCH v4 46/48] perf script: Fix flipped index and cpu
` [PATCH v4 47/48] perf stat: Correct first_shadow_cpu to return index
` [PATCH v4 48/48] perf cpumap: Give CPUs their own type

[PATCH v3 00/48] Refactor perf cpumap
 2022-01-04 17:08 UTC  (57+ messages)
` [PATCH v3 01/48] libperf: Add comments to perf_cpu_map
` [PATCH v3] perf evlist: Remove group option
` [PATCH v3 02/48] perf stat: Add aggr creators that are passed a cpu
` [PATCH v3 03/48] perf stat: Correct aggregation CPU map
` [PATCH v3 04/48] perf stat: Switch aggregation to use for_each loop
` [PATCH v3 05/48] perf stat: Switch to cpu version of cpu_map__get
` [PATCH v3 06/48] perf cpumap: Switch cpu_map__build_map to cpu function
` [PATCH v3 07/48] perf cpumap: Remove map+index get_socket
` [PATCH v3 08/48] perf cpumap: Remove map+index get_die
` [PATCH v3 09/48] perf cpumap: Remove map+index get_core
` [PATCH v3 10/48] perf cpumap: Remove map+index get_node
` [PATCH v3 11/48] perf cpumap: Add comments to aggr_cpu_id
` [PATCH v3 12/48] perf cpumap: Remove unused cpu_map__socket
` [PATCH v3 13/48] perf cpumap: Simplify equal function name
` [PATCH v3 14/48] perf cpumap: Rename empty functions
` [PATCH v3 15/48] perf cpumap: Document cpu__get_node and remove redundant function
` [PATCH v3 16/48] perf cpumap: Remove map from function names that don't use a map
` [PATCH v3 17/48] perf cpumap: Remove cpu_map__cpu, use libperf function
` [PATCH v3 18/48] perf cpumap: Refactor cpu_map__build_map
` [PATCH v3 19/48] perf cpumap: Rename cpu_map__get_X_aggr_by_cpu functions
` [PATCH v3 20/48] perf cpumap: Move 'has' function to libperf
` [PATCH v3 21/48] perf cpumap: Add some comments to cpu_aggr_map
` [PATCH v3 22/48] perf cpumap: Trim the cpu_aggr_map
` [PATCH v3 23/48] perf stat: Fix memory leak in check_per_pkg
` [PATCH v3 24/48] perf cpumap: Add CPU to aggr_cpu_id
` [PATCH v3 25/48] perf stat-display: Avoid use of core for CPU
` [PATCH v3 26/48] perf evsel: Derive CPUs and threads in alloc_counts
` [PATCH v3 27/48] libperf: Switch cpu to more accurate cpu_map_idx
` [PATCH v3 28/48] libperf: Use cpu not index for evsel mmap
` [PATCH v3 29/48] perf counts: Switch name cpu to cpu_map_idx
` [PATCH v3 30/48] perf stat: Rename aggr_data cpu to imply it's an index
` [PATCH v3 31/48] perf stat: Use perf_cpu_map__for_each_cpu
` [PATCH v3 32/48] perf script: Use for each cpu to aid readability
` [PATCH v3 33/48] libperf: Allow NULL in perf_cpu_map__idx
` [PATCH v3 34/48] perf evlist: Refactor evlist__for_each_cpu
` [PATCH v3 35/48] perf evsel: Pass cpu not cpu map index to synthesize
` [PATCH v3 36/48] perf stat: Correct variable name for read counter
` [PATCH v3 37/48] perf evsel: Rename CPU around get_group_fd
` [PATCH v3 38/48] perf evsel: Reduce scope of evsel__ignore_missing_thread
` [PATCH v3 39/48] perf evsel: Rename variable cpu to index
` [PATCH v3 40/48] perf test: Use perf_cpu_map__for_each_cpu
` [PATCH v3 41/48] perf stat: Correct check_per_pkg cpu
` [PATCH v3 42/48] perf stat: Swap variable name cpu to index
` [PATCH v3 43/48] libperf: Sync evsel documentation
` [PATCH v3 44/48] perf bpf: Rename cpu to cpu_map_idx
` [PATCH v3 45/48] perf c2c: Use more intention revealing iterator
` [PATCH v3 46/48] perf script: Fix flipped index and cpu
` [PATCH v3 47/48] perf stat: Correct first_shadow_cpu to return index
` [PATCH v3 48/48] perf cpumap: Give CPUs their own type

[PATCH v2 1/1] Add field checking tests for perf stat JSON output
 2022-01-03 14:53 UTC  (3+ messages)

[PATCH] perf: fix typos of "its" and "reponse"
 2022-01-03  1:01 UTC  (5+ messages)
` JSON typos "

[GIT PULL] perf tools fixes for v5.16: 5th batch
 2022-01-02 22:26 UTC  (2+ messages)

[PATCH v2] perf pmu: Fix alias events list
 2022-01-02 14:34 UTC  (3+ messages)

[PATCH 0/2] perf tools: Fix mis-matching of perf sub-commands
 2021-12-31  6:30 UTC  (3+ messages)
` [PATCH 1/2] perf string: Add strcmp_prefix()
` [PATCH 2/2] perf tools: Enhance the matching of sub-commands

[PATCH v2 00/48] Refactor perf cpumap
 2021-12-30 16:10 UTC  (35+ messages)
` [PATCH v2 20/48] perf cpumap: Move 'has' function to libperf
` [PATCH v2 22/48] perf cpumap: Trim the cpu_aggr_map
` [PATCH v2 24/48] perf cpumap: Add CPU to aggr_cpu_id
` [PATCH v2 25/48] perf stat-display: Avoid use of core for CPU
` [PATCH v2 26/48] perf evsel: Derive CPUs and threads in alloc_counts
` [PATCH v2 29/48] perf counts: Switch name cpu to cpu_map_idx
` [PATCH v2 30/48] perf stat: Rename aggr_data cpu to imply it's an index
` [PATCH v2 31/48] perf stat: Use perf_cpu_map__for_each_cpu
` [PATCH v2 32/48] perf script: Use for each cpu to aid readability
` [PATCH v2 33/48] libperf: Allow NULL in perf_cpu_map__idx
` [PATCH v2 34/48] perf evlist: Refactor evlist__for_each_cpu
` [PATCH v2 35/48] perf evsel: Pass cpu not cpu map index to synthesize
` [PATCH v2 36/48] perf stat: Correct variable name for read counter
` [PATCH v2 37/48] perf evsel: Rename CPU around get_group_fd
` [PATCH v2 38/48] perf evsel: Reduce scope of evsel__ignore_missing_thread
` [PATCH v2 39/48] perf evsel: Rename variable cpu to index
` [PATCH v2 40/48] perf test: Use perf_cpu_map__for_each_cpu
` [PATCH v2 41/48] perf stat: Correct check_per_pkg cpu
` [PATCH v2 42/48] perf stat: Swap variable name cpu to index
` [PATCH v2 43/48] libperf: Sync evsel documentation
` [PATCH v2 44/48] perf bpf: Rename cpu to cpu_map_idx
` [PATCH v2 45/48] perf c2c: Use more intention revealing iterator
` [PATCH v2 46/48] perf script: Fix flipped index and cpu
` [PATCH v2 47/48] perf stat: Correct first_shadow_cpu to return index
` [PATCH v2 48/48] perf cpumap: Give CPUs their own type

[PATCH] arc: perf: Move static structs to where they're really used
 2021-12-29  3:47 UTC  (2+ messages)

[PATCH] ARC: perf: Remove redundant initialization of variable idx
 2021-12-29  3:43 UTC  (2+ messages)

[PATCH] perf bpf: Fix a typo in bpf_counter_cgroup.c
 2021-12-28 18:25 UTC  (2+ messages)

[PATCH v1] perf synthetic-events: Return error if procfs isn't mounted for PID namespaces
 2021-12-24 12:43 UTC  (2+ messages)

[PATCH v3] perf test: Make metric testing more robust
 2021-12-24  8:49 UTC  (2+ messages)

[PATCH] perf: Fix perf-record manual typo
 2021-12-24  2:03 UTC  (3+ messages)

[PATCH v3] perf evlist: Remove group option
 2021-12-23 19:28 UTC 

[PATCH v2 1/2] perf test: Enable system wide for metricgroups test
 2021-12-23 18:39 UTC  (2+ messages)
` [PATCH v2 2/2] perf evsel: Improve error message for uncore events


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).