linux-pm.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] power: supply: oplc_battery: Use fallthrough pseudo-keyword
@ 2021-05-07 12:47 Wei Ming Chen
  2021-06-04 11:54 ` Sebastian Reichel
  0 siblings, 1 reply; 3+ messages in thread
From: Wei Ming Chen @ 2021-05-07 12:47 UTC (permalink / raw)
  To: linux-kernel; +Cc: sre, linux-pm, Wei Ming Chen

Add pseudo-keyword macro fallthrough[1]

[1] https://www.kernel.org/doc/html/latest/process/deprecated.html?highlight=fallthrough#implicit-switch-case-fall-through

Signed-off-by: Wei Ming Chen <jj251510319013@gmail.com>
---
 drivers/power/supply/olpc_battery.c | 1 +
 1 file changed, 1 insertion(+)

diff --git a/drivers/power/supply/olpc_battery.c b/drivers/power/supply/olpc_battery.c
index e0476ec06601..743b7f1cf9ea 100644
--- a/drivers/power/supply/olpc_battery.c
+++ b/drivers/power/supply/olpc_battery.c
@@ -238,6 +238,7 @@ static int olpc_bat_get_charge_full_design(union power_supply_propval *val)
 	case POWER_SUPPLY_TECHNOLOGY_LiFe:
 		switch (mfr) {
 		case 1: /* Gold Peak, fall through */
+			fallthrough;
 		case 2: /* BYD */
 			val->intval = 2800000;
 			break;
-- 
2.25.1


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] power: supply: oplc_battery: Use fallthrough pseudo-keyword
  2021-05-07 12:47 [PATCH] power: supply: oplc_battery: Use fallthrough pseudo-keyword Wei Ming Chen
@ 2021-06-04 11:54 ` Sebastian Reichel
  2021-06-04 12:14   ` Gustavo A. R. Silva
  0 siblings, 1 reply; 3+ messages in thread
From: Sebastian Reichel @ 2021-06-04 11:54 UTC (permalink / raw)
  To: Wei Ming Chen; +Cc: linux-kernel, linux-pm, Kees Cook, Gustavo A. R. Silva

[-- Attachment #1: Type: text/plain, Size: 1439 bytes --]

[+cc Kees and Gustavo]

Hi,

On Fri, May 07, 2021 at 08:47:24PM +0800, Wei Ming Chen wrote:
> Add pseudo-keyword macro fallthrough[1]
> 
> [1] https://www.kernel.org/doc/html/latest/process/deprecated.html?highlight=fallthrough#implicit-switch-case-fall-through
> 
> Signed-off-by: Wei Ming Chen <jj251510319013@gmail.com>
> ---

I suppose completely empty case branch is also ok and just not
documented? I mean it does not hurt much in this case, but quite
a few power-supply drivers have something like this and it would
IMHO reduce readability to add fallthrough; to all of them.

property_is_writable(dev, prop) {
    switch (prop) {
        case A:
        case C:
        case E:
            return true;
        default:
            return false;
    }
}

Thanks,

-- Sebastian

>  drivers/power/supply/olpc_battery.c | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/drivers/power/supply/olpc_battery.c b/drivers/power/supply/olpc_battery.c
> index e0476ec06601..743b7f1cf9ea 100644
> --- a/drivers/power/supply/olpc_battery.c
> +++ b/drivers/power/supply/olpc_battery.c
> @@ -238,6 +238,7 @@ static int olpc_bat_get_charge_full_design(union power_supply_propval *val)
>  	case POWER_SUPPLY_TECHNOLOGY_LiFe:
>  		switch (mfr) {
>  		case 1: /* Gold Peak, fall through */
> +			fallthrough;
>  		case 2: /* BYD */
>  			val->intval = 2800000;
>  			break;
> -- 
> 2.25.1
> 

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] power: supply: oplc_battery: Use fallthrough pseudo-keyword
  2021-06-04 11:54 ` Sebastian Reichel
@ 2021-06-04 12:14   ` Gustavo A. R. Silva
  0 siblings, 0 replies; 3+ messages in thread
From: Gustavo A. R. Silva @ 2021-06-04 12:14 UTC (permalink / raw)
  To: Sebastian Reichel, Wei Ming Chen; +Cc: linux-kernel, linux-pm, Kees Cook



On 6/4/21 06:54, Sebastian Reichel wrote:
> [+cc Kees and Gustavo]
> 
> Hi,
> 
> On Fri, May 07, 2021 at 08:47:24PM +0800, Wei Ming Chen wrote:
>> Add pseudo-keyword macro fallthrough[1]
>>
>> [1] https://www.kernel.org/doc/html/latest/process/deprecated.html?highlight=fallthrough#implicit-switch-case-fall-through
>>
>> Signed-off-by: Wei Ming Chen <jj251510319013@gmail.com>
>> ---
> 
> I suppose completely empty case branch is also ok and just not
> documented? I mean it does not hurt much in this case, but quite

Exactly; it's not documented because it doesn't need to be marked
with fallthrough; :)

Not sure what was the motivation for this patch.

--
Gustavo

> a few power-supply drivers have something like this and it would
> IMHO reduce readability to add fallthrough; to all of them.
> 
> property_is_writable(dev, prop) {
>     switch (prop) {
>         case A:
>         case C:
>         case E:
>             return true;
>         default:
>             return false;
>     }
> }
> 
> Thanks,
> 
> -- Sebastian
> 
>>  drivers/power/supply/olpc_battery.c | 1 +
>>  1 file changed, 1 insertion(+)
>>
>> diff --git a/drivers/power/supply/olpc_battery.c b/drivers/power/supply/olpc_battery.c
>> index e0476ec06601..743b7f1cf9ea 100644
>> --- a/drivers/power/supply/olpc_battery.c
>> +++ b/drivers/power/supply/olpc_battery.c
>> @@ -238,6 +238,7 @@ static int olpc_bat_get_charge_full_design(union power_supply_propval *val)
>>  	case POWER_SUPPLY_TECHNOLOGY_LiFe:
>>  		switch (mfr) {
>>  		case 1: /* Gold Peak, fall through */
>> +			fallthrough;
>>  		case 2: /* BYD */
>>  			val->intval = 2800000;
>>  			break;
>> -- 
>> 2.25.1
>>

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-06-04 12:34 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-07 12:47 [PATCH] power: supply: oplc_battery: Use fallthrough pseudo-keyword Wei Ming Chen
2021-06-04 11:54 ` Sebastian Reichel
2021-06-04 12:14   ` Gustavo A. R. Silva

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).