linux-riscv.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-09-09 03:14:52 to 2020-09-18 12:08:58 UTC [more...]

vmalloc faulting on RISC-V
 2020-09-18 12:08 UTC  (4+ messages)

[V2] riscv: fix pfn_to_virt err in do_page_fault()
 2020-09-18  8:55 UTC 

[PATCH v2 00/13] gpio: add common dtschema
 2020-09-18  7:52 UTC  (20+ messages)
` [PATCH v2 01/13] dt-bindings: gpio: add common schema for GPIO controllers
` [PATCH v2 02/13] dt-bindings: gpio: include common schema in "
` [PATCH v2 03/13] dt-bindings: gpio: pl061: add missing properties and include common schema
` [PATCH v2 04/13] dt-bindings: gpio: fsl-imx-gpio: add i.MX ARMv6 and ARMv7 compatibles
` [PATCH v2 05/13] dt-bindings: gpio: fsl-imx-gpio: add gpio-line-names
` [PATCH v2 06/13] dt-bindings: gpio: gpio-vf610: fix iMX 7ULP compatible matching
` [PATCH v2 07/13] dt-bindings: media: include common schema in GPIO controllers
` [PATCH v2 08/13] dt-bindings: mfd: "
` [PATCH v2 09/13] dt-bindings: pinctrl: "
` [PATCH v2 10/13] ASoC: dt-bindings: zl38060: "
` [PATCH v2 11/13] arm64: dts: imx8mq-librem5: correct GPIO hog property
` [PATCH v2 12/13] arm64: dts: imx8mq-librem5: align GPIO hog names with dtschema
` [PATCH v2 13/13] ARM: dts: imx: "

[PATCH v2] RISC-V: Remove any memblock representing unusable memory area
 2020-09-17 23:40 UTC 

[PATCH v8 0/7] Add UEFI support for RISC-V
 2020-09-17 22:37 UTC  (8+ messages)
` [PATCH v8 1/7] RISC-V: Move DT mapping outof fixmap
` [PATCH v8 2/7] RISC-V: Add early ioremap support
` [PATCH v8 3/7] RISC-V: Implement late mapping page table allocation functions
` [PATCH v8 4/7] RISC-V: Add PE/COFF header for EFI stub
` [PATCH v8 5/7] RISC-V: Add EFI stub support
` [PATCH v8 6/7] RISC-V: Add EFI runtime services
` [PATCH v8 7/7] RISC-V: Add page table dump support for uefi

[PATCH] riscv: fix pfn_to_virt err in do_page_fault()
 2020-09-17 15:25 UTC  (3+ messages)

[PATCH 0/8] mm: cleanup usage of <asm/pgalloc.h>
 2020-06-27 14:34 UTC  (2+ messages)
` [PATCH 1/8] mm: remove unneeded includes "

[PATCH v2 3/3] riscv: Add cache information in AUX vector
 2020-08-28  4:45 UTC  (2+ messages)

[PATCH V4 2/4] mm/debug_vm_pgtable: Add tests validating advanced arch page table helpers
 2020-07-09  6:11 UTC  (2+ messages)
` [mm/debug_vm_pgtable] a97a171093: BUG:unable_to_handle_page_fault_for_address

[PATCH v2 2/2] riscv: Add jump-label implementation
 2020-07-13 22:05 UTC  (2+ messages)

[PATCH 1/2] riscv: Support irq_work via self IPIs
 2020-06-23 16:19 UTC 

[PATCH] cpuidle: add riscv cpuidle driver
 2020-09-16  1:27 UTC  (8+ messages)
  ` 回复:[PATCH] "

[PATCH 1/3] module: Rename module_alloc() to text_alloc() and move to kernel proper
 2020-07-13 19:49 UTC  (2+ messages)

syzkaller on risc-v
 2020-06-30 13:36 UTC  (4+ messages)

[PATCH v2 0/3] kprobes: Remove MODULE dependency
 2020-07-16 16:49 UTC  (3+ messages)
` [PATCH v2 1/3] module: Rename module_alloc() to text_alloc() and move to kernel proper

[PATCH v5 0/5] mm: introduce memfd_secret system call to create "secret" memory areas
 2020-09-17 13:27 UTC  (12+ messages)
` [PATCH v5 1/5] mm: add definition of PMD_PAGE_ORDER
` [PATCH v5 2/5] mmap: make mlock_future_check() global
` [PATCH v5 3/5] mm: introduce memfd_secret system call to create "secret" memory areas
` [PATCH v5 4/5] arch, mm: wire up memfd_secret system call were relevant
` [PATCH v5 5/5] mm: secretmem: use PMD-size pages to amortize direct map fragmentation

[PATCH v2 2/3] soc: sifive: Add SiFive specific Cadence DDR controller driver
 2020-09-17  9:56 UTC  (6+ messages)

[PATCH 0/8] gpio: add common dtschema
 2020-09-17  7:26 UTC  (14+ messages)
` [PATCH 1/8] dt-bindings: gpio: add common schema for GPIO controllers
` [PATCH 2/8] dt-bindings: gpio: include common schema in "
` [PATCH 3/8] dt-bindings: gpio: pl061: add missing properties and include common schema
` [PATCH 4/8] dt-bindings: gpio: fsl-imx-gpio: add i.MX ARMv6 and ARMv7 compatibles
` [PATCH 5/8] dt-bindings: gpio: fsl-imx-gpio: add gpio-line-names
` [PATCH 6/8] arm64: dts: imx8mq-librem5: correct GPIO hog property
` [PATCH 7/8] arm64: dts: imx8mq-librem5: align GPIO hog names with dtschema
` [PATCH 8/8] ARM: dts: imx: "

[PATCH v5 0/5] mm: introduce memfd_secret system call to create "secret" memory areas
 2020-09-16 19:08 UTC  (3+ messages)

[PATCH] riscv: Fix Kendryte K210 device tree
 2020-09-16 11:34 UTC  (6+ messages)

[PATCH v2] riscv: Fix Kendryte K210 device tree
 2020-09-16  7:59 UTC 

[PATCH] riscv: Fix compilation warning
 2020-09-16  4:59 UTC  (8+ messages)

[PATCH v1 0/3] convert sifive's prci, plic and pwm bindings to yaml
 2020-09-15 16:08 UTC  (6+ messages)
` [PATCH v1 1/3] dt-bindings: fu540: prci: convert PRCI bindings to json-schema
` [PATCH v1 2/3] dt-bindings: riscv: convert plic "
` [PATCH v1 3/3] dt-bindings: riscv: convert pwm "

[PATCH v2 0/3] SiFive DDR controller and EDAC support
 2020-09-15 15:24 UTC  (4+ messages)
` [PATCH v2 1/3] dt-bindings: riscv: Add DT documentation for DDR Controller in SiFive SoCs

[RESEND PATCH v2 0/1] convert l2 cache dt bindings to YAML format
 2020-09-15 15:17 UTC  (4+ messages)
` [RESEND PATCH v2 1/1] dt-bindings: riscv: sifive-l2-cache: convert bindings to json-schema

[PATCH] RISC-V: Resurrect the MMIO timer implementation for M-mode systems
 2020-09-15 12:56 UTC  (13+ messages)

[RFC/RFT PATCH v2 0/5] Unify NUMA implementation between ARM64 & RISC-V
 2020-09-15  8:27 UTC  (13+ messages)
` [RFC/RFT PATCH v2 1/5] numa: Move numa implementation to common code
` [RFC/RFT PATCH v2 2/5] arm64, numa: Change the numa init function name to be generic
` [RFC/RFT PATCH v2 3/5] riscv: Separate memory init from paging init
` [RFC/RFT PATCH v2 4/5] riscv: Add support pte_protnone and pmd_protnone if CONFIG_NUMA_BALANCING
` [RFC/RFT PATCH v2 5/5] riscv: Add numa support for riscv64 platform

[PATCH] riscv: Add sfence.vma after page table changed
 2020-09-15  3:58 UTC  (3+ messages)

[PATCH] RISC-V: Fix duplicate included thread_info.h
 2020-09-15  3:00 UTC  (2+ messages)

[PATCH v7 0/9] Add UEFI support for RISC-V
 2020-09-14 18:32 UTC  (7+ messages)
` [PATCH v7 5/9] RISC-V: Add PE/COFF header for EFI stub

[PATCH] RISC-V: Consider sparse memory while removing unusable memory
 2020-09-14 17:53 UTC  (6+ messages)

[PATCH V2 0/3] riscv: Enable LOCKDEP
 2020-09-14 10:38 UTC  (5+ messages)
` [PATCH V2 1/3] riscv: Fixup static_obj() fail

[PATCH v3 3/3] openrisc: Fix issue with get_user for 64-bit values
 2020-09-12  8:40 UTC  (3+ messages)

[PATCH v4 00/13] mm/debug_vm_pgtable fixes
 2020-09-11  5:21 UTC  (13+ messages)
    ` [PATCH v4 13/13] mm/debug_vm_pgtable: Avoid none pte in pte_clear_test

[PATCH] kbuild: preprocess module linker script
 2020-09-10 19:45 UTC  (2+ messages)

[RFC PATCH v7 00/21] riscv: Add vector ISA support
 2020-09-10  8:12 UTC  (22+ messages)
` [RFC PATCH v7 01/21] riscv: Separate patch for cflags and aflags
` [RFC PATCH v7 02/21] riscv: Rename __switch_to_aux -> fpu
` [RFC PATCH v7 03/21] riscv: Extending cpufeature.c to detect V-extension
` [RFC PATCH v7 04/21] riscv: Add new csr defines related to vector extension
` [RFC PATCH v7 05/21] riscv: Add vector feature to compile
` [RFC PATCH v7 06/21] riscv: Add has_vector/riscv_vsize to save vector features
` [RFC PATCH v7 07/21] riscv: Reset vector register
` [RFC PATCH v7 08/21] riscv: Add vector struct and assembler definitions
` [RFC PATCH v7 09/21] riscv: Add task switch support for vector
` [RFC PATCH v7 10/21] "
` [RFC PATCH v7 11/21] riscv: Add ptrace vector support
` [RFC PATCH v7 12/21] riscv: Add sigcontext save/restore for vector
` [RFC PATCH v7 13/21] riscv: signal: Report signal frame size to userspace via auxv
` [RFC PATCH v7 14/21] riscv: Add support for kernel mode vector
` [RFC PATCH v7 15/21] riscv: Use CSR_STATUS to replace sstatus in vector.S
` [RFC PATCH v7 16/21] riscv: Add vector extension XOR implementation
` [RFC PATCH v7 17/21] riscv: Initialize vector registers with proper vsetvli then it can work normally
` [RFC PATCH v7 18/21] riscv: Optimize vector registers initialization
` [RFC PATCH v7 19/21] riscv: Fix an illegal instruction exception when accessing vlenb without enable vector first
` [RFC PATCH v7 20/21] riscv: Allocate space for vector registers in start_thread()
` [RFC PATCH v7 21/21] riscv: Optimize task switch codes of vector

[PATCH -next] riscv/mm/fault: Fix old style declaration warning
 2020-09-10  3:49 UTC 

remove set_fs for riscv v2
 2020-09-09 20:38 UTC  (4+ messages)

[PATCH -next] riscv/mm/fault: fix old-style-declaration warning
 2020-09-09 12:00 UTC  (2+ messages)

[PATCH 7/8] riscv: implement __get_kernel_nofault and __put_user_nofault
 2020-09-09  4:59 UTC  (2+ messages)

[PATCH 8/8] riscv: remove address space overrides using set_fs()
 2020-09-09  4:59 UTC  (2+ messages)

[PATCH 5/8] riscv: use memcpy based uaccess for nommu again
 2020-09-09  4:59 UTC  (2+ messages)

[PATCH 6/8] riscv: refactor __get_user and __put_user
 2020-09-09  4:59 UTC  (2+ messages)

[PATCH v2] kbuild: preprocess module linker script
 2020-09-09  4:27 UTC  (2+ messages)

[PATCH for-next] riscv/mm/fault: Fix inline placement in vmalloc_fault() declaration
 2020-09-09  3:14 UTC  (2+ messages)

[PATCH for-next] riscv/mm/fault: Set FAULT_FLAG_INSTRUCTION flag in do_page_fault()
 2020-09-09  3:14 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).