linux-riscv.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: Peter Zijlstra <peterz@infradead.org>
To: Guo Ren <guoren@kernel.org>
Cc: "Christoph Müllner" <christophm30@gmail.com>,
	"Palmer Dabbelt" <palmer@dabbelt.com>,
	"Anup Patel" <anup@brainfault.org>,
	linux-riscv <linux-riscv@lists.infradead.org>,
	"Linux Kernel Mailing List" <linux-kernel@vger.kernel.org>,
	"Guo Ren" <guoren@linux.alibaba.com>,
	"Catalin Marinas" <catalin.marinas@arm.com>,
	"Will Deacon" <will.deacon@arm.com>,
	"Arnd Bergmann" <arnd@arndb.de>,
	"Jonas Bonn" <jonas@southpole.se>,
	"Stefan Kristiansson" <stefan.kristiansson@saunalahti.fi>,
	"Stafford Horne" <shorne@gmail.com>
Subject: Re: [RFC][PATCH] locking: Generic ticket-lock
Date: Wed, 14 Apr 2021 14:55:57 +0200	[thread overview]
Message-ID: <YHbmXXvuG442ZDfN@hirez.programming.kicks-ass.net> (raw)
In-Reply-To: <CAJF2gTRsQQ=RunxK6R9MfK70dULt=RJOXXGCOT9oDPEsBgvKtQ@mail.gmail.com>

On Wed, Apr 14, 2021 at 08:39:33PM +0800, Guo Ren wrote:

> I've tested it on csky SMP*4 hw (860) & riscv SMP*4 hw (c910) and it's okay.

W00t :-)

> Hope you can keep
> typedef struct {
>         union {
>                 atomic_t lock;
>                 struct __raw_tickets {
> #ifdef __BIG_ENDIAN
>                         u16 next;
>                         u16 owner;
> #else
>                         u16 owner;
>                         u16 next;
> #endif
>                 } tickets;
>         };
> } arch_spinlock_t;
> 
> Using owner & next is much more readable.

That almost doubles the line-count of the thing ;-)


> > + * It further assumes atomic_*_release() + atomic_*_acquire() is RCpc and hence
> > + * uses atomic_fetch_add() which is SC to create an RCsc lock.

This ^^^ then vvv

> > +static __always_inline void ticket_lock(arch_spinlock_t *lock)
> > +{
> > +       u32 val = atomic_fetch_add(1<<16, lock); /* SC, gives us RCsc */
> atomic_fetch_add_acquire ?

Then we must rely on the arch to implement RCsc atomics. And I for one
can never tell wth Risc-V actually does.

> > +static __always_inline int ticket_is_locked(arch_spinlock_t *lock)
> > +{
> > +       u32 val = atomic_read(lock);
> > +
> > +       return ((val >> 16) != (val & 0xffff));
> I perfer:
> return !arch_spin_value_unlocked(READ_ONCE(*lock));
> > +}

> > +}
> > +
> > +static __always_inline int ticket_value_unlocked(arch_spinlock_t lock)
> > +{
> > +       return !ticket_is_locked(&lock);
> Are you sure to let ticket_is_locked->atomic_read(lock) again, the
> lock has contained all information?
> 
> return lock.tickets.owner == lock.tickets.next;

Yeah, I wrote then the wrong way around. Couldn't be bothered to go back
when I figured it out.

> > +
> > +static __always_inline int ticket_is_contended(arch_spinlock_t *lock)
> > +{
> > +       u32 val = atomic_read(lock);
> > +
> > +       return (s16)((val >> 16) - (val & 0xffff)) > 1;
> How big-endian ?

How not? Endian-ness only matters when you go poke at sub-words, which
the above does not. Only ticket_unlock() does and cares about that.


_______________________________________________
linux-riscv mailing list
linux-riscv@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-riscv

  reply	other threads:[~2021-04-14 12:56 UTC|newest]

Thread overview: 46+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-03-24 10:14 [PATCH] riscv: locks: introduce ticket-based spinlock implementation guoren
2021-03-24 11:09 ` Peter Zijlstra
2021-03-24 12:10   ` Guo Ren
     [not found] ` <CAM4kBBK7_s9U2vJbq68yC8WdDEfPQTaCOvn1xds3Si5B-Wpw+A@mail.gmail.com>
2021-03-24 12:23   ` Peter Zijlstra
2021-03-24 12:24   ` Guo Ren
2021-03-24 12:31     ` Peter Zijlstra
2021-03-24 12:28 ` Anup Patel
2021-03-24 12:37   ` Peter Zijlstra
2021-03-24 12:53     ` Anup Patel
2021-04-11 21:11       ` Palmer Dabbelt
2021-04-12 13:32         ` Christoph Müllner
2021-04-12 14:51           ` Peter Zijlstra
2021-04-12 21:21             ` Christoph Müllner
2021-04-12 17:33           ` Palmer Dabbelt
2021-04-12 21:54             ` Christoph Müllner
2021-04-13  8:03               ` Peter Zijlstra
2021-04-13  8:17                 ` Peter Zijlstra
2021-04-14  2:26                   ` Guo Ren
2021-04-14  7:08                     ` Peter Zijlstra
2021-04-14  9:05                       ` Peter Zijlstra
2021-04-14 10:16                         ` [RFC][PATCH] locking: Generic ticket-lock Peter Zijlstra
2021-04-14 12:39                           ` Guo Ren
2021-04-14 12:55                             ` Peter Zijlstra [this message]
2021-04-14 13:08                               ` Peter Zijlstra
2021-04-14 15:59                               ` David Laight
2021-04-14 12:45                           ` Peter Zijlstra
2021-04-14 21:02                             ` Stafford Horne
2021-04-14 20:47                           ` Stafford Horne
2021-04-15  8:09                             ` Peter Zijlstra
2021-04-15  9:02                               ` Catalin Marinas
2021-04-15  9:22                                 ` Will Deacon
2021-04-15  9:24                                 ` Peter Zijlstra
2021-04-19 17:35                           ` Will Deacon
2021-04-23  6:44                           ` Palmer Dabbelt
2021-04-13  9:22                 ` [PATCH] riscv: locks: introduce ticket-based spinlock implementation Christoph Müllner
2021-04-13  9:30                   ` Catalin Marinas
2021-04-13  9:55                     ` Christoph Müllner
2021-04-14  0:23                     ` Guo Ren
2021-04-14  9:17                       ` Catalin Marinas
2021-04-13  9:35                   ` Peter Zijlstra
2021-04-13 10:25                     ` Christoph Müllner
2021-04-13 10:45                       ` Catalin Marinas
2021-04-13 10:54                         ` David Laight
2021-04-14  5:54                           ` Guo Ren
2021-04-13 11:04                         ` Christoph Müllner
2021-04-13 13:19                       ` Guo Ren

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YHbmXXvuG442ZDfN@hirez.programming.kicks-ass.net \
    --to=peterz@infradead.org \
    --cc=anup@brainfault.org \
    --cc=arnd@arndb.de \
    --cc=catalin.marinas@arm.com \
    --cc=christophm30@gmail.com \
    --cc=guoren@kernel.org \
    --cc=guoren@linux.alibaba.com \
    --cc=jonas@southpole.se \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-riscv@lists.infradead.org \
    --cc=palmer@dabbelt.com \
    --cc=shorne@gmail.com \
    --cc=stefan.kristiansson@saunalahti.fi \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).