linux-rtc.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v3 00/14] rtc: rx8010: use regmap instead of i2c smbus API
@ 2020-09-14 15:45 Bartosz Golaszewski
  2020-09-14 15:45 ` [PATCH v3 01/14] rtc: rx8010: don't modify the global rtc ops Bartosz Golaszewski
                   ` (14 more replies)
  0 siblings, 15 replies; 18+ messages in thread
From: Bartosz Golaszewski @ 2020-09-14 15:45 UTC (permalink / raw)
  To: Alessandro Zummo, Alexandre Belloni
  Cc: linux-rtc, linux-kernel, Bartosz Golaszewski

From: Bartosz Golaszewski <bgolaszewski@baylibre.com>

This series gets bigger and bigger but I noticed a problem with this
driver that looks like stable material so I fixed it as the first patch
in the series to make backporting easy.

Other than that, there are new refactoring patches and I removed the
unnecessary error messages.

--

I want to use this driver on a platform where the i2c controller doesn't
speak SMBUS. This series converts the driver to i2c regmap which can
figure out the correct protocol to use.

The actual conversion happens in patch 13. The rest are bugfixes and
refactoring.

v1 -> v2:
- s/parentheses/brackets/g
- add a patch switching the driver to using the preferred RTC API
- rework the patch removing magic values
- use range_max and range_min instead of manual range checks
- add a patch adding a helper variable in probe() for client->dev
- add a patch using sizeof(*rx8010) instead of sizeof(struct rx8010_data)

v2 -> v3:
- remove unnecessary error messages when registering the RTC device
- add a patch switching to using the preferred probe_new callback in
  the I2C driver
- add a patch fixing an issue where the global rtc operations struct
  is modified depending on the presence of the interrupt
- add a patch removing a stray newline

Bartosz Golaszewski (14):
  rtc: rx8010: don't modify the global rtc ops
  rtc: rx8010: remove a stray newline
  rtc: rx8010: remove unnecessary brackets
  rtc: rx8010: consolidate local variables of the same type
  rtc: rx8010: use tabs instead of spaces for code formatting
  rtc: rx8010: rename ret to err in rx8010_set_time()
  rtc: rx8010: don't use magic values for time buffer length
  rtc: rx8010: drop unnecessary initialization
  rtc: rx8010: use a helper variable for client->dev in probe()
  rtc: rx8010: prefer sizeof(*val) over sizeof(struct type_of_val)
  rtc: rx8010: switch to using the preferred RTC API
  rtc: rx8010: switch to using the preferred i2c API
  rtc: rx8010: convert to using regmap
  rtc: rx8010: use range checking provided by core RTC code

 drivers/rtc/rtc-rx8010.c | 332 +++++++++++++++++----------------------
 1 file changed, 143 insertions(+), 189 deletions(-)

-- 
2.26.1


^ permalink raw reply	[flat|nested] 18+ messages in thread

end of thread, other threads:[~2020-09-17 19:42 UTC | newest]

Thread overview: 18+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-09-14 15:45 [PATCH v3 00/14] rtc: rx8010: use regmap instead of i2c smbus API Bartosz Golaszewski
2020-09-14 15:45 ` [PATCH v3 01/14] rtc: rx8010: don't modify the global rtc ops Bartosz Golaszewski
2020-09-17 15:53   ` Sasha Levin
2020-09-17 16:16     ` Bartosz Golaszewski
2020-09-14 15:45 ` [PATCH v3 02/14] rtc: rx8010: remove a stray newline Bartosz Golaszewski
2020-09-14 15:45 ` [PATCH v3 03/14] rtc: rx8010: remove unnecessary brackets Bartosz Golaszewski
2020-09-14 15:45 ` [PATCH v3 04/14] rtc: rx8010: consolidate local variables of the same type Bartosz Golaszewski
2020-09-14 15:45 ` [PATCH v3 05/14] rtc: rx8010: use tabs instead of spaces for code formatting Bartosz Golaszewski
2020-09-14 15:45 ` [PATCH v3 06/14] rtc: rx8010: rename ret to err in rx8010_set_time() Bartosz Golaszewski
2020-09-14 15:45 ` [PATCH v3 07/14] rtc: rx8010: don't use magic values for time buffer length Bartosz Golaszewski
2020-09-14 15:45 ` [PATCH v3 08/14] rtc: rx8010: drop unnecessary initialization Bartosz Golaszewski
2020-09-14 15:45 ` [PATCH v3 09/14] rtc: rx8010: use a helper variable for client->dev in probe() Bartosz Golaszewski
2020-09-14 15:45 ` [PATCH v3 10/14] rtc: rx8010: prefer sizeof(*val) over sizeof(struct type_of_val) Bartosz Golaszewski
2020-09-14 15:45 ` [PATCH v3 11/14] rtc: rx8010: switch to using the preferred RTC API Bartosz Golaszewski
2020-09-14 15:45 ` [PATCH v3 12/14] rtc: rx8010: switch to using the preferred i2c API Bartosz Golaszewski
2020-09-14 15:46 ` [PATCH v3 13/14] rtc: rx8010: convert to using regmap Bartosz Golaszewski
2020-09-14 15:46 ` [PATCH v3 14/14] rtc: rx8010: use range checking provided by core RTC code Bartosz Golaszewski
2020-09-15  9:20 ` [PATCH v3 00/14] rtc: rx8010: use regmap instead of i2c smbus API Alexandre Belloni

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).