linux-scsi.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 0/4] ufs: core: Always read the descriptors with max length
@ 2022-11-02 14:29 Arthur Simchaev
  2022-11-02 14:29 ` [PATCH v2 1/4] ufs: core: Remove redundant wb check Arthur Simchaev
                   ` (3 more replies)
  0 siblings, 4 replies; 10+ messages in thread
From: Arthur Simchaev @ 2022-11-02 14:29 UTC (permalink / raw)
  To: martin.petersen; +Cc: beanhuo, linux-scsi, linux-kernel, Arthur Simchaev

v1--v2:
  Fix argument warning in ufshpb.c

Read any descriptor with a maximum size of QUERY_DESC_MAX_SIZE.
According to the spec the device rerurns the actual size.
Thus can improve code readability and save CPU cycles.
While at it, cleanup few leftovers around the descriptor size parameter.

Suggested-by: Bean Huo <beanhuo@micron.com>

Arthur Simchaev (4):
  ufs:core: Remove redundant wb check
  ufs:core: Remove redundant desc_size variable from hba
  ufs: core: Remove len parameter from ufshcd_set_active_icc_lvl
  ufs: core: Remove ufshcd_map_desc_id_to_length function

 drivers/ufs/core/ufs_bsg.c     |   7 +--
 drivers/ufs/core/ufshcd-priv.h |   3 --
 drivers/ufs/core/ufshcd.c      | 100 ++++++++++-------------------------------
 drivers/ufs/core/ufshpb.c      |   5 +--
 include/ufs/ufshcd.h           |   1 -
 5 files changed, 26 insertions(+), 90 deletions(-)

-- 
2.7.4


^ permalink raw reply	[flat|nested] 10+ messages in thread
* [PATCH v2 0/4] ufs: core: Always read the descriptors with max length
@ 2022-11-21 15:46 Arthur Simchaev
  0 siblings, 0 replies; 10+ messages in thread
From: Arthur Simchaev @ 2022-11-21 15:46 UTC (permalink / raw)
  To: martin.petersen; +Cc: beanhuo, linux-scsi, linux-kernel, Arthur Simchaev

v2--v3:
  Based on Bean's comments:
  1)Use kzalloc instead of kmalloc in ufshcd_set_active_icc_lvl - patch 2/4
  2)Delete  UFS_RPMB_UNIT definition - patch 2/4
  3)Delete len description - patch 3/4

v1--v2:
  Fix argument warning in ufshpb.c

Read any descriptor with a maximum size of QUERY_DESC_MAX_SIZE.
According to the spec the device rerurns the actual size.
Thus can improve code readability and save CPU cycles.
While at it, cleanup few leftovers around the descriptor size parameter.

Suggested-by: Bean Huo <beanhuo@micron.com>

Arthur Simchaev (4):
  ufs:core: Remove redundant wb check
  ufs:core: Remove redundant desc_size variable from hba
  ufs: core: Remove len parameter from ufshcd_set_active_icc_lvl
  ufs: core: Remove ufshcd_map_desc_id_to_length function

 drivers/ufs/core/ufs_bsg.c     |   7 +--
 drivers/ufs/core/ufshcd-priv.h |   3 --
 drivers/ufs/core/ufshcd.c      | 100 ++++++++++-------------------------------
 drivers/ufs/core/ufshpb.c      |   5 +--
 include/ufs/ufshcd.h           |   1 -
 5 files changed, 26 insertions(+), 90 deletions(-)

-- 
2.7.4


^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2022-11-21 15:46 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-11-02 14:29 [PATCH v2 0/4] ufs: core: Always read the descriptors with max length Arthur Simchaev
2022-11-02 14:29 ` [PATCH v2 1/4] ufs: core: Remove redundant wb check Arthur Simchaev
2022-11-02 14:29 ` [PATCH v2 2/4] ufs: core: Remove redundant desc_size variable from hba Arthur Simchaev
2022-11-11 15:45   ` Bean Huo
2022-11-13 13:33     ` Arthur Simchaev
2022-11-02 14:29 ` [PATCH v2 3/4] ufs: core: Remove len parameter from ufshcd_set_active_icc_lvl Arthur Simchaev
2022-11-14 12:19   ` Bean Huo
2022-11-15 12:49     ` Arthur Simchaev
2022-11-02 14:29 ` [PATCH v2 4/4] ufs: core: Remove ufshcd_map_desc_id_to_length function Arthur Simchaev
2022-11-21 15:46 [PATCH v2 0/4] ufs: core: Always read the descriptors with max length Arthur Simchaev

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).