linux-trace-devel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/3] libtraceevent
@ 2023-03-24 20:01 Steven Rostedt
  2023-03-24 20:01 ` [PATCH 1/3] libtraceevent: Fix double free in parsing sizeof() Steven Rostedt
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Steven Rostedt @ 2023-03-24 20:01 UTC (permalink / raw)
  To: linux-trace-devel; +Cc: Steven Rostedt (Google)

From: "Steven Rostedt (Google)" <rostedt@goodmis.org>

Google's fuzz testing found a double free in process_sizeof(). That was an
easy fix, but the reason the bug happened was because of that silly "ok"
variable called "ok", which is meaningless for what it is used for.

Also, remove the unneeded test of !ok at the end of the if/else block.

Steven Rostedt (Google) (3):
  libtraceevent: Fix double free in parsing sizeof()
  libtraceevent: No need for testing ok in else if (!ok) in process_sizeof()
  libtraceevent: Rename "ok" to "end" in process_sizeof()

 src/event-parse.c | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)

-- 
2.39.1


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2023-03-24 20:01 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-03-24 20:01 [PATCH 0/3] libtraceevent Steven Rostedt
2023-03-24 20:01 ` [PATCH 1/3] libtraceevent: Fix double free in parsing sizeof() Steven Rostedt
2023-03-24 20:01 ` [PATCH 2/3] libtraceevent: No need for testing ok in else if (!ok) in process_sizeof() Steven Rostedt
2023-03-24 20:01 ` [PATCH 3/3] libtraceevent: Rename "ok" to "end" " Steven Rostedt

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).