linux-trace-devel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 00/34] Fix kernelshark issues introduced by the migration to Qt6
@ 2024-01-14 17:16 Benjamin ROBIN
  2024-01-14 17:16 ` [PATCH 01/34] kernelshark: Fix modelReset() signaling, rename update to updateGeom Benjamin ROBIN
                   ` (34 more replies)
  0 siblings, 35 replies; 55+ messages in thread
From: Benjamin ROBIN @ 2024-01-14 17:16 UTC (permalink / raw)
  To: y.karadz; +Cc: linux-trace-devel, Benjamin ROBIN

There were 3 majors issues:
 - A segfault when loading a trace file (patch 0001)
 - The trace table height was very small (patch 0032)
 - The trace table columns width were reducing when clicking
   Marker A or B (patch 0032)

Also fix most of the warnings reported by Clang-Tidy and Clazy, and by
gcc with -Wextra.


Benjamin ROBIN (34):
  kernelshark: Fix modelReset() signaling, rename update to updateGeom
  kernelshark: Add .gitignore
  kernelshark: Remove function param when not used, whenever possible
  kernelshark: Do not create a temporary container for looping over QMap
  kernelshark: Prevent potential detach of QMap container
  kernelshark: Fix used after free of QByteArray raw data
  kernelshark: Fix potential memory leak in KsGLWidget
  kernelshark: Use lambda parameter instead of captured local variable
  kernelshark: Keep overridden method protected instead of public
  kernelshark: Use sliced() or first() instead of mid/right/left()
  kernelshark: Prevent potential divide by zero in Shape::center()
  kernelshark: Fix potential access to uninitialized variable
  kernelshark: Remove unused locals variables
  kernelshark: Fix range-loop-reference Clazy warning
  kernelshark: Fix moving a temp object prevents copy elision warning
  kernelshark: Add receiver object to connect() call
  kernelshark: Return by reference the list of header in KsModels
  kernelshark: Fix detaching-temporary Clazy warning
  kernelshark: Fix qfileinfo-exists Clazy warning
  kernelshark: Fix potential memory leaks in libkshark-configio
  kernelshark: Fix potential access to uninitialized variable
  kernelshark: Fix potential double free of histo->map, histo->bin_count
  kernelshark: Fix 'const' type qualifier on return type has no effect
  kernelshark: Fix potential memory leaks in libkshark-tepdata
  kernelshark: Fix typo in comment of KsGLWidget::resizeGL()
  kernelshark: Remove unused KsDataWidget::wipPtr() and broken function
  kernelshark: In KsTimeOffsetDialog() constructor use parent param
  kernelshark: Fixed loop counter incremented suspiciously twice
  kernelshark: Fix tepdata_dump_entry() for event_id = KS_EVENT_OVERFLOW
  kernelshark: Use static_cast instead of C cast in KsMainWindow
  kernelshark: Fix comparison of integers of different signs warnings
  kernelshark: Fix KsTableView columns width, and KsTraceViewer size
  kernelshark: Allow to reduce a bit more the graph height
  kernelshark: Cleanup of KsDualMarker methods

 .gitignore                     | 15 ++++++
 examples/configio.c            |  3 +-
 examples/datafilter.c          | 15 +++---
 examples/datahisto.c           |  2 +-
 src/KsAdvFilteringDialog.cpp   | 24 ++++------
 src/KsAdvFilteringDialog.hpp   |  2 +-
 src/KsDualMarker.hpp           | 10 +---
 src/KsGLWidget.cpp             | 48 +++++++++----------
 src/KsGLWidget.hpp             | 43 ++++++++---------
 src/KsMainWindow.cpp           |  8 ++--
 src/KsModels.hpp               | 11 +++--
 src/KsPlotTools.cpp            | 14 +++---
 src/KsPlotTools.hpp            |  2 +-
 src/KsSession.cpp              |  4 +-
 src/KsTraceGraph.cpp           |  7 ++-
 src/KsTraceViewer.cpp          | 71 ++++++++--------------------
 src/KsTraceViewer.hpp          | 11 +++--
 src/KsUtils.cpp                |  9 ++--
 src/KsUtils.hpp                |  4 +-
 src/KsWidgetsLib.cpp           |  2 +-
 src/KsWidgetsLib.hpp           | 15 ++----
 src/libkshark-collection.c     | 14 +++---
 src/libkshark-configio.c       | 84 +++++++++++++++++++---------------
 src/libkshark-hash.c           |  5 +-
 src/libkshark-model.c          | 19 ++++----
 src/libkshark-tepdata.c        | 31 ++++++++-----
 src/libkshark.c                | 17 +++----
 src/libkshark.h                | 20 ++++----
 src/plugins/KVMComboDialog.cpp |  7 +--
 src/plugins/sched_events.c     |  2 +-
 tests/test-input.c             |  4 +-
 tests/test-input_ctrl.c        |  4 +-
 32 files changed, 257 insertions(+), 270 deletions(-)
 create mode 100644 .gitignore

--
2.43.0


^ permalink raw reply	[flat|nested] 55+ messages in thread

end of thread, other threads:[~2024-03-03 20:44 UTC | newest]

Thread overview: 55+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-01-14 17:16 [PATCH 00/34] Fix kernelshark issues introduced by the migration to Qt6 Benjamin ROBIN
2024-01-14 17:16 ` [PATCH 01/34] kernelshark: Fix modelReset() signaling, rename update to updateGeom Benjamin ROBIN
2024-01-14 17:16 ` [PATCH 02/34] kernelshark: Add .gitignore Benjamin ROBIN
2024-01-14 17:16 ` [PATCH 03/34] kernelshark: Remove function param when not used, whenever possible Benjamin ROBIN
2024-01-14 17:16 ` [PATCH 04/34] kernelshark: Do not create a temporary container for looping over QMap Benjamin ROBIN
2024-01-21 17:16   ` Yordan Karadzhov
2024-01-28 21:30     ` Benjamin ROBIN
2024-02-04 18:34       ` Yordan Karadzhov
2024-02-04 18:59         ` Benjamin ROBIN
2024-01-14 17:16 ` [PATCH 05/34] kernelshark: Prevent potential detach of QMap container Benjamin ROBIN
2024-01-21 17:17   ` Yordan Karadzhov
2024-01-28 19:38     ` [PATCH v2 " Benjamin ROBIN
2024-01-14 17:16 ` [PATCH 06/34] kernelshark: Fix used after free of QByteArray raw data Benjamin ROBIN
2024-01-14 17:16 ` [PATCH 07/34] kernelshark: Fix potential memory leak in KsGLWidget Benjamin ROBIN
2024-01-14 17:16 ` [PATCH 08/34] kernelshark: Use lambda parameter instead of captured local variable Benjamin ROBIN
2024-01-14 17:16 ` [PATCH 09/34] kernelshark: Keep overridden method protected instead of public Benjamin ROBIN
2024-01-14 17:16 ` [PATCH 10/34] kernelshark: Use sliced() or first() instead of mid/right/left() Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 11/34] kernelshark: Prevent potential divide by zero in Shape::center() Benjamin ROBIN
2024-01-21 19:49   ` Yordan Karadzhov
2024-01-28 19:26     ` [PATCH v2 " Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 12/34] kernelshark: Fix potential access to uninitialized variable Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 13/34] kernelshark: Remove unused locals variables Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 14/34] kernelshark: Fix range-loop-reference Clazy warning Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 15/34] kernelshark: Fix moving a temp object prevents copy elision warning Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 16/34] kernelshark: Add receiver object to connect() call Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 17/34] kernelshark: Return by reference the list of header in KsModels Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 18/34] kernelshark: Fix detaching-temporary Clazy warning Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 19/34] kernelshark: Fix qfileinfo-exists " Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 20/34] kernelshark: Fix potential memory leaks in libkshark-configio Benjamin ROBIN
2024-01-21 18:41   ` Yordan Karadzhov
2024-01-28 19:25     ` [PATCH v2 " Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 21/34] kernelshark: Fix potential access to uninitialized variable Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 22/34] kernelshark: Fix potential double free of histo->map, histo->bin_count Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 23/34] kernelshark: Fix 'const' type qualifier on return type has no effect Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 24/34] kernelshark: Fix potential memory leaks in libkshark-tepdata Benjamin ROBIN
2024-01-21 18:50   ` Yordan Karadzhov
2024-01-28 19:24     ` [PATCH v2 " Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 25/34] kernelshark: Fix typo in comment of KsGLWidget::resizeGL() Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 26/34] kernelshark: Remove unused KsDataWidget::wipPtr() and broken function Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 27/34] kernelshark: In KsTimeOffsetDialog() constructor use parent param Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 28/34] kernelshark: Fixed loop counter incremented suspiciously twice Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 29/34] kernelshark: Fix tepdata_dump_entry() for event_id = KS_EVENT_OVERFLOW Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 30/34] kernelshark: Use static_cast instead of C cast in KsMainWindow Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 31/34] kernelshark: Fix comparison of integers of different signs warnings Benjamin ROBIN
2024-01-21 19:09   ` Yordan Karadzhov
2024-01-14 17:17 ` [PATCH 32/34] kernelshark: Fix KsTableView columns width, and KsTraceViewer size Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 33/34] kernelshark: Allow to reduce a bit more the graph height Benjamin ROBIN
2024-01-21 19:37   ` Yordan Karadzhov
2024-01-28 18:59     ` [PATCH v2 " Benjamin ROBIN
2024-01-14 17:17 ` [PATCH 34/34] kernelshark: Cleanup of KsDualMarker methods Benjamin ROBIN
2024-01-21 17:08 ` [PATCH 00/34] Fix kernelshark issues introduced by the migration to Qt6 Yordan Karadzhov
2024-03-03  9:56   ` Benjamin ROBIN
2024-03-03 15:47     ` Yordan Karadzhov
2024-03-03 17:07       ` Sudip Mukherjee
2024-03-03 20:43         ` Sudip Mukherjee

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).