linux-usb.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v7 1/3] USB: Also check for ->match
@ 2020-08-04 11:38 Bastien Nocera
  2020-08-04 11:38 ` [PATCH v7 2/3] USB: Better name for __check_usb_generic() Bastien Nocera
                   ` (2 more replies)
  0 siblings, 3 replies; 6+ messages in thread
From: Bastien Nocera @ 2020-08-04 11:38 UTC (permalink / raw)
  To: linux-usb; +Cc: Greg Kroah-Hartman, Alan Stern, Bastien Nocera

We only ever used the ID table matching before, but we should probably
also support an open-coded match function.

Fixes: 88b7381a939de ("USB: Select better matching USB drivers when available")
Signed-off-by: Bastien Nocera <hadess@hadess.net>
Acked-by: Alan Stern <stern@rowland.harvard.edu>
---
Changes since v2:
- Added Alan's ack

Changes since v1:
- Fixed typo in commit message

 drivers/usb/core/generic.c | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/drivers/usb/core/generic.c b/drivers/usb/core/generic.c
index b6f2d4b44754..2b2f1ab6e36a 100644
--- a/drivers/usb/core/generic.c
+++ b/drivers/usb/core/generic.c
@@ -205,8 +205,9 @@ static int __check_usb_generic(struct device_driver *drv, void *data)
 	udrv = to_usb_device_driver(drv);
 	if (udrv == &usb_generic_driver)
 		return 0;
-
-	return usb_device_match_id(udev, udrv->id_table) != NULL;
+	if (usb_device_match_id(udev, udrv->id_table) != NULL)
+		return 1;
+	return (udrv->match && udrv->match(udev));
 }
 
 static bool usb_generic_driver_match(struct usb_device *udev)
-- 
2.26.2


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH v7 2/3] USB: Better name for __check_usb_generic()
  2020-08-04 11:38 [PATCH v7 1/3] USB: Also check for ->match Bastien Nocera
@ 2020-08-04 11:38 ` Bastien Nocera
  2020-08-04 11:38 ` [PATCH v7 3/3] USB: Fix device driver race Bastien Nocera
  2020-08-18  9:00 ` [PATCH v7 1/3] USB: Also check for ->match Greg Kroah-Hartman
  2 siblings, 0 replies; 6+ messages in thread
From: Bastien Nocera @ 2020-08-04 11:38 UTC (permalink / raw)
  To: linux-usb; +Cc: Greg Kroah-Hartman, Alan Stern, Bastien Nocera

__check_usb_generic() doesn't explain very well what the
function actually does: It checks to see whether the driver is
non-generic and matches the device.

Change it to check_for_non_generic_match()

Signed-off-by: Bastien Nocera <hadess@hadess.net>
---
First version based on Alan's comment:
https://marc.info/?l=linux-usb&m=159568870400795&w=2

 drivers/usb/core/generic.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/usb/core/generic.c b/drivers/usb/core/generic.c
index 2b2f1ab6e36a..22c887f5c497 100644
--- a/drivers/usb/core/generic.c
+++ b/drivers/usb/core/generic.c
@@ -195,7 +195,7 @@ int usb_choose_configuration(struct usb_device *udev)
 }
 EXPORT_SYMBOL_GPL(usb_choose_configuration);
 
-static int __check_usb_generic(struct device_driver *drv, void *data)
+static int __check_for_non_generic_match(struct device_driver *drv, void *data)
 {
 	struct usb_device *udev = data;
 	struct usb_device_driver *udrv;
@@ -219,7 +219,7 @@ static bool usb_generic_driver_match(struct usb_device *udev)
 	 * If any other driver wants the device, leave the device to this other
 	 * driver.
 	 */
-	if (bus_for_each_drv(&usb_bus_type, NULL, udev, __check_usb_generic))
+	if (bus_for_each_drv(&usb_bus_type, NULL, udev, __check_for_non_generic_match))
 		return false;
 
 	return true;
-- 
2.26.2


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH v7 3/3] USB: Fix device driver race
  2020-08-04 11:38 [PATCH v7 1/3] USB: Also check for ->match Bastien Nocera
  2020-08-04 11:38 ` [PATCH v7 2/3] USB: Better name for __check_usb_generic() Bastien Nocera
@ 2020-08-04 11:38 ` Bastien Nocera
  2020-08-18  9:00 ` [PATCH v7 1/3] USB: Also check for ->match Greg Kroah-Hartman
  2 siblings, 0 replies; 6+ messages in thread
From: Bastien Nocera @ 2020-08-04 11:38 UTC (permalink / raw)
  To: linux-usb; +Cc: Greg Kroah-Hartman, Alan Stern, Bastien Nocera

When a new device with a specialised device driver is plugged in, the
new driver will be modprobe()'d but the driver core will attach the
"generic" driver to the device.

After that, nothing will trigger a reprobe when the modprobe()'d device
driver has finished initialising, as the device has the "generic"
driver attached to it.

Trigger a reprobe ourselves when new specialised drivers get registered.

Fixes: 88b7381a939d ("USB: Select better matching USB drivers when available")
Signed-off-by: Bastien Nocera <hadess@hadess.net>
Acked-by: Alan Stern <stern@rowland.harvard.edu>
---
Changes since v6:
- Added Alan's ack

Changes since v5:
- Throw error when device_reprobe() fails

Changes since v4:
- Add commit subject to "fixes" section
- Clarify conditional that checks for generic driver
- Remove check duplicated inside the loop

Changes since v3:
- Only reprobe devices that could use the new driver
- Many code fixes

Changes since v2:
- Fix formatting

Changes since v1:
- Simplified after Alan Stern's comments and some clarifications from
Benjamin Tissoires.


 drivers/usb/core/driver.c | 40 +++++++++++++++++++++++++++++++++++++--
 1 file changed, 38 insertions(+), 2 deletions(-)

diff --git a/drivers/usb/core/driver.c b/drivers/usb/core/driver.c
index f81606c6a35b..7e73e989645b 100644
--- a/drivers/usb/core/driver.c
+++ b/drivers/usb/core/driver.c
@@ -905,6 +905,35 @@ static int usb_uevent(struct device *dev, struct kobj_uevent_env *env)
 	return 0;
 }
 
+static bool is_dev_usb_generic_driver(struct device *dev)
+{
+	struct usb_device_driver *udd = dev->driver ?
+		to_usb_device_driver(dev->driver) : NULL;
+
+	return udd == &usb_generic_driver;
+}
+
+static int __usb_bus_reprobe_drivers(struct device *dev, void *data)
+{
+	struct usb_device_driver *new_udriver = data;
+	struct usb_device *udev;
+	int ret;
+
+	if (!is_dev_usb_generic_driver(dev))
+		return 0;
+
+	udev = to_usb_device(dev);
+	if (usb_device_match_id(udev, new_udriver->id_table) == NULL &&
+	    (!new_udriver->match || new_udriver->match(udev) != 0))
+		return 0;
+
+	ret = device_reprobe(dev);
+	if (ret && ret != -EPROBE_DEFER)
+		dev_err(dev, "Failed to reprobe device (error %d)\n", ret);
+
+	return 0;
+}
+
 /**
  * usb_register_device_driver - register a USB device (not interface) driver
  * @new_udriver: USB operations for the device driver
@@ -934,13 +963,20 @@ int usb_register_device_driver(struct usb_device_driver *new_udriver,
 
 	retval = driver_register(&new_udriver->drvwrap.driver);
 
-	if (!retval)
+	if (!retval) {
 		pr_info("%s: registered new device driver %s\n",
 			usbcore_name, new_udriver->name);
-	else
+		/*
+		 * Check whether any device could be better served with
+		 * this new driver
+		 */
+		bus_for_each_dev(&usb_bus_type, NULL, new_udriver,
+				 __usb_bus_reprobe_drivers);
+	} else {
 		printk(KERN_ERR "%s: error %d registering device "
 			"	driver %s\n",
 			usbcore_name, retval, new_udriver->name);
+	}
 
 	return retval;
 }
-- 
2.26.2


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH v7 1/3] USB: Also check for ->match
  2020-08-04 11:38 [PATCH v7 1/3] USB: Also check for ->match Bastien Nocera
  2020-08-04 11:38 ` [PATCH v7 2/3] USB: Better name for __check_usb_generic() Bastien Nocera
  2020-08-04 11:38 ` [PATCH v7 3/3] USB: Fix device driver race Bastien Nocera
@ 2020-08-18  9:00 ` Greg Kroah-Hartman
  2020-08-18  9:42   ` Bastien Nocera
  2 siblings, 1 reply; 6+ messages in thread
From: Greg Kroah-Hartman @ 2020-08-18  9:00 UTC (permalink / raw)
  To: Bastien Nocera; +Cc: linux-usb, Alan Stern

On Tue, Aug 04, 2020 at 01:38:32PM +0200, Bastien Nocera wrote:
> We only ever used the ID table matching before, but we should probably
> also support an open-coded match function.
> 
> Fixes: 88b7381a939de ("USB: Select better matching USB drivers when available")
> Signed-off-by: Bastien Nocera <hadess@hadess.net>
> Acked-by: Alan Stern <stern@rowland.harvard.edu>

The subject line does not make sense, what is "also"?  Who is doing
this?

Coming back to this after a week I have no idea what is going on, so
that's a sign that it needs to be reworded :(

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH v7 1/3] USB: Also check for ->match
  2020-08-18  9:00 ` [PATCH v7 1/3] USB: Also check for ->match Greg Kroah-Hartman
@ 2020-08-18  9:42   ` Bastien Nocera
  2020-08-18  9:51     ` Greg Kroah-Hartman
  0 siblings, 1 reply; 6+ messages in thread
From: Bastien Nocera @ 2020-08-18  9:42 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: linux-usb, Alan Stern

On Tue, 2020-08-18 at 11:00 +0200, Greg Kroah-Hartman wrote:
> On Tue, Aug 04, 2020 at 01:38:32PM +0200, Bastien Nocera wrote:
> > We only ever used the ID table matching before, but we should
> > probably
> > also support an open-coded match function.
> > 
> > Fixes: 88b7381a939de ("USB: Select better matching USB drivers when
> > available")
> > Signed-off-by: Bastien Nocera <hadess@hadess.net>
> > Acked-by: Alan Stern <stern@rowland.harvard.edu>
> 
> The subject line does not make sense, what is "also"?  Who is doing
> this?
> 
> Coming back to this after a week I have no idea what is going on, so
> that's a sign that it needs to be reworded :(

It's actually been 2 weeks. Were there any other changes you wanted
made in this patchset, or is that going to be it?


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH v7 1/3] USB: Also check for ->match
  2020-08-18  9:42   ` Bastien Nocera
@ 2020-08-18  9:51     ` Greg Kroah-Hartman
  0 siblings, 0 replies; 6+ messages in thread
From: Greg Kroah-Hartman @ 2020-08-18  9:51 UTC (permalink / raw)
  To: Bastien Nocera; +Cc: linux-usb, Alan Stern

On Tue, Aug 18, 2020 at 11:42:23AM +0200, Bastien Nocera wrote:
> On Tue, 2020-08-18 at 11:00 +0200, Greg Kroah-Hartman wrote:
> > On Tue, Aug 04, 2020 at 01:38:32PM +0200, Bastien Nocera wrote:
> > > We only ever used the ID table matching before, but we should
> > > probably
> > > also support an open-coded match function.
> > > 
> > > Fixes: 88b7381a939de ("USB: Select better matching USB drivers when
> > > available")
> > > Signed-off-by: Bastien Nocera <hadess@hadess.net>
> > > Acked-by: Alan Stern <stern@rowland.harvard.edu>
> > 
> > The subject line does not make sense, what is "also"?  Who is doing
> > this?
> > 
> > Coming back to this after a week I have no idea what is going on, so
> > that's a sign that it needs to be reworded :(
> 
> It's actually been 2 weeks. Were there any other changes you wanted
> made in this patchset, or is that going to be it?

I think that's it.

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2020-08-18  9:50 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-08-04 11:38 [PATCH v7 1/3] USB: Also check for ->match Bastien Nocera
2020-08-04 11:38 ` [PATCH v7 2/3] USB: Better name for __check_usb_generic() Bastien Nocera
2020-08-04 11:38 ` [PATCH v7 3/3] USB: Fix device driver race Bastien Nocera
2020-08-18  9:00 ` [PATCH v7 1/3] USB: Also check for ->match Greg Kroah-Hartman
2020-08-18  9:42   ` Bastien Nocera
2020-08-18  9:51     ` Greg Kroah-Hartman

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).