linux-wireless.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 00/24] ath9k: hw initiazliation cleanup
@ 2009-08-03 19:24 Luis R. Rodriguez
  2009-08-03 19:24 ` [PATCH 01/24] ath9k: remove usage of AR_SREV_*() wrapper to detect supported hw Luis R. Rodriguez
                   ` (22 more replies)
  0 siblings, 23 replies; 25+ messages in thread
From: Luis R. Rodriguez @ 2009-08-03 19:24 UTC (permalink / raw)
  To: linville; +Cc: linux-wireless, ath9k-devel, Luis R. Rodriguez

This series consists of a few hardware initialization cleanups
and small fixups. This goal was to make hardware initialization
easier to read but also make it easier to add support for new
hardware. The small fixups just came along the way.

Luis R. Rodriguez (24):
  ath9k: remove usage of AR_SREV_*() wrapper to detect supported hw
  ath9k: use a switch for revising supported hw mac revisions
  ath9k: propagate hw initialization errors
  ath9k: move memory allocation of ath_hw to ath_init()
  ath9k: move devid cache setting to ath_init()
  ath9k: move cache setting of softc ah prior to attach
  ath9k: call hw initializer directly
  ath9k: pass only one argument to hw attach
  ath9k: move hw macrevision checker to helper
  ath9k: rename ath9k_hw_newstate() to ath9k_hw_init_defaults()
  ath9k: rename  ath9k_hw_set_defaults() to ath9k_hw_init_config()
  ath9k: remove debug message for no memoery on ath_init()
  ath9k: break up hw initialization into a few more helpers
  ath9k: describe hw initialization better
  ath9k: distinguish between device initialization and ath_softc init
  ath9k: remove !NULL check before kfree()
  ath9k: use helper macro to kfree and nullify on ath9k_hw_rfdetach()
  ath9k: rename ath9k_hw_rfdetach() to ath9k_hw_rf_free()
  ath9k: rename ath9k_hw_ani_detach() to ath9k_hw_ani_disable()
  ath9k: set ah to null after freeing
  ath9k: set sc->sc_ah to NULL after freeing it
  ath9k: call ath9k_hw_detach() once upon hw init failure
  ath9k: remove dangling error check on keycache reset on hw init
  ath9k: remove spurious check for channel on keycache reset

 drivers/net/wireless/ath/ath9k/ahb.c    |    2 +-
 drivers/net/wireless/ath/ath9k/ani.c    |    6 +-
 drivers/net/wireless/ath/ath9k/ani.h    |    4 +-
 drivers/net/wireless/ath/ath9k/ath9k.h  |    2 +-
 drivers/net/wireless/ath/ath9k/eeprom.c |    2 +-
 drivers/net/wireless/ath/ath9k/eeprom.h |    2 +-
 drivers/net/wireless/ath/ath9k/hw.c     |  259 +++++++++++++++----------------
 drivers/net/wireless/ath/ath9k/hw.h     |    6 +-
 drivers/net/wireless/ath/ath9k/main.c   |   59 +++++---
 drivers/net/wireless/ath/ath9k/pci.c    |    2 +-
 drivers/net/wireless/ath/ath9k/phy.c    |   53 ++-----
 11 files changed, 195 insertions(+), 202 deletions(-)


^ permalink raw reply	[flat|nested] 25+ messages in thread
* [PATCH 10/24] ath9k: rename ath9k_hw_newstate() to ath9k_hw_init_defaults()
@ 2009-08-03 19:48 Luis R. Rodriguez
  0 siblings, 0 replies; 25+ messages in thread
From: Luis R. Rodriguez @ 2009-08-03 19:48 UTC (permalink / raw)
  To: linville; +Cc: linux-wireless, ath9k-devel, Luis R. Rodriguez

This reflects better what we are actually doing there.

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
---

Resend try #2

 drivers/net/wireless/ath/ath9k/hw.c |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/net/wireless/ath/ath9k/hw.c b/drivers/net/wireless/ath/ath9k/hw.c
index 4f3d7bf..6aee570 100644
--- a/drivers/net/wireless/ath/ath9k/hw.c
+++ b/drivers/net/wireless/ath/ath9k/hw.c
@@ -437,7 +437,7 @@ static void ath9k_hw_set_defaults(struct ath_hw *ah)
 		ah->config.serialize_regmode = SER_REG_MODE_AUTO;
 }
 
-static void ath9k_hw_newstate(struct ath_hw *ah)
+static void ath9k_hw_init_defaults(struct ath_hw *ah)
 {
 	ah->hw_version.magic = AR5416_MAGIC;
 	ah->regulatory.country_code = CTRY_DEFAULT;
@@ -654,7 +654,7 @@ int ath9k_hw_attach(struct ath_hw *ah)
 		goto bad;
 	}
 
-	ath9k_hw_newstate(ah);
+	ath9k_hw_init_defaults(ah);
 	ath9k_hw_set_defaults(ah);
 
 	if (!ath9k_hw_set_reset_reg(ah, ATH9K_RESET_POWER_ON)) {
-- 
1.6.3.3


^ permalink raw reply related	[flat|nested] 25+ messages in thread

end of thread, other threads:[~2009-08-03 19:48 UTC | newest]

Thread overview: 25+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-08-03 19:24 [PATCH 00/24] ath9k: hw initiazliation cleanup Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 01/24] ath9k: remove usage of AR_SREV_*() wrapper to detect supported hw Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 02/24] ath9k: use a switch for revising supported hw mac revisions Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 03/24] ath9k: propagate hw initialization errors Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 04/24] ath9k: move memory allocation of ath_hw to ath_init() Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 05/24] ath9k: move devid cache setting " Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 06/24] ath9k: move cache setting of softc ah prior to attach Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 07/24] ath9k: call hw initializer directly Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 09/24] ath9k: move hw macrevision checker to helper Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 10/24] ath9k: rename ath9k_hw_newstate() to ath9k_hw_init_defaults() Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 11/24] ath9k: rename ath9k_hw_set_defaults() to ath9k_hw_init_config() Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 12/24] ath9k: remove debug message for no memoery on ath_init() Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 13/24] ath9k: break up hw initialization into a few more helpers Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 14/24] ath9k: describe hw initialization better Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 15/24] ath9k: distinguish between device initialization and ath_softc init Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 16/24] ath9k: remove !NULL check before kfree() Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 17/24] ath9k: use helper macro to kfree and nullify on ath9k_hw_rfdetach() Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 18/24] ath9k: rename ath9k_hw_rfdetach() to ath9k_hw_rf_free() Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 19/24] ath9k: rename ath9k_hw_ani_detach() to ath9k_hw_ani_disable() Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 20/24] ath9k: set ah to null after freeing Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 21/24] ath9k: set sc->sc_ah to NULL after freeing it Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 22/24] ath9k: call ath9k_hw_detach() once upon hw init failure Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 23/24] ath9k: remove dangling error check on keycache reset on hw init Luis R. Rodriguez
2009-08-03 19:24 ` [PATCH 24/24] ath9k: remove spurious check for channel on keycache reset Luis R. Rodriguez
2009-08-03 19:48 [PATCH 10/24] ath9k: rename ath9k_hw_newstate() to ath9k_hw_init_defaults() Luis R. Rodriguez

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).