linux-wireless.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] mt76: move mt76_tx_queue_mcu in mt76-core module
       [not found] <cover.1549444343.git.lorenzo.bianconi@redhat.com>
@ 2019-02-06  9:15 ` Lorenzo Bianconi
  2019-02-06 14:49   ` Felix Fietkau
  0 siblings, 1 reply; 3+ messages in thread
From: Lorenzo Bianconi @ 2019-02-06  9:15 UTC (permalink / raw)
  To: nbd; +Cc: linux-wireless, sgruszka

Move mt76_tx_queue_mcu routine in dma.c and remove duplicated code.
mt76_tx_queue_mcu will be reused adding support for mt7603 driver

Signed-off-by: Lorenzo Bianconi <lorenzo.bianconi@redhat.com>
---
 drivers/net/wireless/mediatek/mt76/dma.c      | 24 +++++++++++
 drivers/net/wireless/mediatek/mt76/mt76.h     |  2 +
 .../net/wireless/mediatek/mt76/mt76x02_mcu.c  | 40 ++++---------------
 3 files changed, 34 insertions(+), 32 deletions(-)

diff --git a/drivers/net/wireless/mediatek/mt76/dma.c b/drivers/net/wireless/mediatek/mt76/dma.c
index a37b284168c6..a4fe1f4ac220 100644
--- a/drivers/net/wireless/mediatek/mt76/dma.c
+++ b/drivers/net/wireless/mediatek/mt76/dma.c
@@ -242,6 +242,30 @@ mt76_dma_kick_queue(struct mt76_dev *dev, struct mt76_queue *q)
 	iowrite32(q->head, &q->regs->cpu_idx);
 }
 
+int mt76_tx_queue_mcu(struct mt76_dev *dev, enum mt76_txq_id qid,
+		      struct sk_buff *skb, u32 tx_info)
+{
+	struct mt76_queue *q = &dev->q_tx[qid];
+	struct mt76_queue_buf buf;
+	dma_addr_t addr;
+
+	addr = dma_map_single(dev->dev, skb->data, skb->len,
+			      DMA_TO_DEVICE);
+	if (dma_mapping_error(dev->dev, addr))
+		return -ENOMEM;
+
+	buf.addr = addr;
+	buf.len = skb->len;
+
+	spin_lock_bh(&q->lock);
+	mt76_dma_add_buf(dev, q, &buf, 1, tx_info, skb, NULL);
+	mt76_dma_kick_queue(dev, q);
+	spin_unlock_bh(&q->lock);
+
+	return 0;
+}
+EXPORT_SYMBOL_GPL(mt76_tx_queue_mcu);
+
 int mt76_dma_tx_queue_skb(struct mt76_dev *dev, struct mt76_queue *q,
 			  struct sk_buff *skb, struct mt76_wcid *wcid,
 			  struct ieee80211_sta *sta)
diff --git a/drivers/net/wireless/mediatek/mt76/mt76.h b/drivers/net/wireless/mediatek/mt76/mt76.h
index 1bdac293b347..92aeecbb207d 100644
--- a/drivers/net/wireless/mediatek/mt76/mt76.h
+++ b/drivers/net/wireless/mediatek/mt76/mt76.h
@@ -761,6 +761,8 @@ mt76_mcu_msg_alloc(const void *data, int head_len,
 void mt76_mcu_rx_event(struct mt76_dev *dev, struct sk_buff *skb);
 struct sk_buff *mt76_mcu_get_response(struct mt76_dev *dev,
 				      unsigned long expires);
+int mt76_tx_queue_mcu(struct mt76_dev *dev, enum mt76_txq_id qid,
+		      struct sk_buff *skb, u32 tx_info);
 
 void mt76u_mcu_complete_urb(struct urb *urb);
 int mt76u_mcu_init_rx(struct mt76_dev *dev);
diff --git a/drivers/net/wireless/mediatek/mt76/mt76x02_mcu.c b/drivers/net/wireless/mediatek/mt76/mt76x02_mcu.c
index b44d128f6f93..2b65783deedd 100644
--- a/drivers/net/wireless/mediatek/mt76/mt76x02_mcu.c
+++ b/drivers/net/wireless/mediatek/mt76/mt76x02_mcu.c
@@ -21,43 +21,13 @@
 
 #include "mt76x02_mcu.h"
 
-static int
-mt76x02_tx_queue_mcu(struct mt76x02_dev *dev, enum mt76_txq_id qid,
-		     struct sk_buff *skb, int cmd, int seq)
-{
-	struct mt76_queue *q = &dev->mt76.q_tx[qid];
-	struct mt76_queue_buf buf;
-	dma_addr_t addr;
-	u32 tx_info;
-
-	tx_info = MT_MCU_MSG_TYPE_CMD |
-		  FIELD_PREP(MT_MCU_MSG_CMD_TYPE, cmd) |
-		  FIELD_PREP(MT_MCU_MSG_CMD_SEQ, seq) |
-		  FIELD_PREP(MT_MCU_MSG_PORT, CPU_TX_PORT) |
-		  FIELD_PREP(MT_MCU_MSG_LEN, skb->len);
-
-	addr = dma_map_single(dev->mt76.dev, skb->data, skb->len,
-			      DMA_TO_DEVICE);
-	if (dma_mapping_error(dev->mt76.dev, addr))
-		return -ENOMEM;
-
-	buf.addr = addr;
-	buf.len = skb->len;
-
-	spin_lock_bh(&q->lock);
-	mt76_queue_add_buf(dev, q, &buf, 1, tx_info, skb, NULL);
-	mt76_queue_kick(dev, q);
-	spin_unlock_bh(&q->lock);
-
-	return 0;
-}
-
 int mt76x02_mcu_msg_send(struct mt76_dev *mdev, int cmd, const void *data,
 			 int len, bool wait_resp)
 {
 	struct mt76x02_dev *dev = container_of(mdev, struct mt76x02_dev, mt76);
 	unsigned long expires = jiffies + HZ;
 	struct sk_buff *skb;
+	u32 tx_info;
 	int ret;
 	u8 seq;
 
@@ -71,7 +41,13 @@ int mt76x02_mcu_msg_send(struct mt76_dev *mdev, int cmd, const void *data,
 	if (!seq)
 		seq = ++mdev->mmio.mcu.msg_seq & 0xf;
 
-	ret = mt76x02_tx_queue_mcu(dev, MT_TXQ_MCU, skb, cmd, seq);
+	tx_info = MT_MCU_MSG_TYPE_CMD |
+		  FIELD_PREP(MT_MCU_MSG_CMD_TYPE, cmd) |
+		  FIELD_PREP(MT_MCU_MSG_CMD_SEQ, seq) |
+		  FIELD_PREP(MT_MCU_MSG_PORT, CPU_TX_PORT) |
+		  FIELD_PREP(MT_MCU_MSG_LEN, skb->len);
+
+	ret = mt76_tx_queue_mcu(&dev->mt76, MT_TXQ_MCU, skb, tx_info);
 	if (ret)
 		goto out;
 
-- 
2.20.1


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] mt76: move mt76_tx_queue_mcu in mt76-core module
  2019-02-06  9:15 ` [PATCH] mt76: move mt76_tx_queue_mcu in mt76-core module Lorenzo Bianconi
@ 2019-02-06 14:49   ` Felix Fietkau
  2019-02-06 14:59     ` Lorenzo Bianconi
  0 siblings, 1 reply; 3+ messages in thread
From: Felix Fietkau @ 2019-02-06 14:49 UTC (permalink / raw)
  To: Lorenzo Bianconi; +Cc: linux-wireless, sgruszka

On 2019-02-06 10:15, Lorenzo Bianconi wrote:
> Move mt76_tx_queue_mcu routine in dma.c and remove duplicated code.
> mt76_tx_queue_mcu will be reused adding support for mt7603 driver
> 
> Signed-off-by: Lorenzo Bianconi <lorenzo.bianconi@redhat.com>
I think we should rename this function, since it's going to be used for
more than just MCU commands.
Maybe mt76_dma_tx_queue_skb_raw (and add corresponding queue_op instead
of direct calls)?
While you're at it, maybe you could also remove mt76_queue_add_buf and
the corresponding queue op.

- Felix

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] mt76: move mt76_tx_queue_mcu in mt76-core module
  2019-02-06 14:49   ` Felix Fietkau
@ 2019-02-06 14:59     ` Lorenzo Bianconi
  0 siblings, 0 replies; 3+ messages in thread
From: Lorenzo Bianconi @ 2019-02-06 14:59 UTC (permalink / raw)
  To: Felix Fietkau; +Cc: linux-wireless, sgruszka

> On 2019-02-06 10:15, Lorenzo Bianconi wrote:
> > Move mt76_tx_queue_mcu routine in dma.c and remove duplicated code.
> > mt76_tx_queue_mcu will be reused adding support for mt7603 driver
> > 
> > Signed-off-by: Lorenzo Bianconi <lorenzo.bianconi@redhat.com>
> I think we should rename this function, since it's going to be used for
> more than just MCU commands.
> Maybe mt76_dma_tx_queue_skb_raw (and add corresponding queue_op instead
> of direct calls)?
> While you're at it, maybe you could also remove mt76_queue_add_buf and
> the corresponding queue op.

ack, will fix it in v2

Regards,
Lorenzo

> 
> - Felix

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2019-02-06 15:00 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <cover.1549444343.git.lorenzo.bianconi@redhat.com>
2019-02-06  9:15 ` [PATCH] mt76: move mt76_tx_queue_mcu in mt76-core module Lorenzo Bianconi
2019-02-06 14:49   ` Felix Fietkau
2019-02-06 14:59     ` Lorenzo Bianconi

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).