Linux-Wireless Archive on lore.kernel.org
 help / Atom feed
* Ath9k hang with pci passthrough
@ 2019-01-08 19:50 James Prestwood
  0 siblings, 0 replies; 1+ messages in thread
From: James Prestwood @ 2019-01-08 19:50 UTC (permalink / raw)
  To: linux-wireless

Hi,

This is a followup to my original PCI passthrough issue, which has been
resolved, though not as smoothly as I would like. Here is a brief
recap:

I am using PCI passthrough to a VM with an Ath9k wifi adapter. This was
causing my host machine to lock up/freeze when starting the VM. Adding
a line to drivers/pci/quirks.c resolve the issue. Here is the original
thread:

https://marc.info/?l=linux-wireless&m=154689580213002&w=2

By "resolved" I mean the host doesn't lock up, but I am still seeing
weird behavior. When starting the VM I see this:

qemu-system-x86_64: vfio-pci: Cannot read device rom at 0000:08:00.0
Device option ROM contents are probably invalid (check dmesg).
Skip option ROM probe with rombar=0, or load from file with romfile=
[    5.312843] irq 11: nobody cared (try booting with the "irqpoll"
option)
[    5.312843] handlers:
[    5.312843] [<0000000002e29ed0>] vp_interrupt
[    5.312843] [<00000000d9d80d45>] ath_isr
[    5.312843] Disabling IRQ #11

At this point it hangs for a minute or two, sometimes re-printing the
same "irq 11: nobody cared" message with a stack trace (sometimes up to
3 times). But eventually it boots into the VM and the adapter appears
to work as expected.

I have tried to get rid of the ROM contents print by adding "rombar=0",
which didn't seem to change anything. Similarly I tried "irqpoll" which
again didn't change the behavior (note both changes were on the guest
kernel boot, not host).

I don't see any such prints in my host kernel log during boot, so it
seems to be specific to PCI passthrough.

Since the adapter appears to work I could care less about these prints,
I am just hoping to resolve the 1-2min hang when booting the VM.

Thanks,
James




^ permalink raw reply	[flat|nested] 1+ messages in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-01-08 19:50 Ath9k hang with pci passthrough James Prestwood

Linux-Wireless Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/linux-wireless/0 linux-wireless/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 linux-wireless linux-wireless/ https://lore.kernel.org/linux-wireless \
		linux-wireless@vger.kernel.org linux-wireless@archiver.kernel.org
	public-inbox-index linux-wireless


Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernel.vger.linux-wireless


AGPL code for this site: git clone https://public-inbox.org/ public-inbox