linux-wireless.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2] ath5k: use swap() to make code cleaner
@ 2022-02-15  2:31 davidcomponentone
  2022-02-15  5:52 ` Jiri Slaby
  2022-02-15  7:25 ` Luis Chamberlain
  0 siblings, 2 replies; 3+ messages in thread
From: davidcomponentone @ 2022-02-15  2:31 UTC (permalink / raw)
  To: jirislaby
  Cc: davidcomponentone, mickflemm, mcgrof, kvalo, davem, kuba,
	linux-wireless, netdev, linux-kernel, Yang Guang, Zeal Robot

From: Yang Guang <yang.guang5@zte.com.cn>

Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.

Reported-by: Zeal Robot <zealci@zte.com.cn>
Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
Signed-off-by: David Yang <davidcomponentone@gmail.com>
---
Changes from v1->v2:
- Fix the typo "sort" to "swap"

---
 drivers/net/wireless/ath/ath5k/phy.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/net/wireless/ath/ath5k/phy.c b/drivers/net/wireless/ath/ath5k/phy.c
index 00f9e347d414..08dc12611f8d 100644
--- a/drivers/net/wireless/ath/ath5k/phy.c
+++ b/drivers/net/wireless/ath/ath5k/phy.c
@@ -1562,16 +1562,13 @@ static s16
 ath5k_hw_get_median_noise_floor(struct ath5k_hw *ah)
 {
 	s16 sort[ATH5K_NF_CAL_HIST_MAX];
-	s16 tmp;
 	int i, j;
 
 	memcpy(sort, ah->ah_nfcal_hist.nfval, sizeof(sort));
 	for (i = 0; i < ATH5K_NF_CAL_HIST_MAX - 1; i++) {
 		for (j = 1; j < ATH5K_NF_CAL_HIST_MAX - i; j++) {
 			if (sort[j] > sort[j - 1]) {
-				tmp = sort[j];
-				sort[j] = sort[j - 1];
-				sort[j - 1] = tmp;
+				swap(sort[j], sort[j - 1]);
 			}
 		}
 	}
-- 
2.30.2


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH v2] ath5k: use swap() to make code cleaner
  2022-02-15  2:31 [PATCH v2] ath5k: use swap() to make code cleaner davidcomponentone
@ 2022-02-15  5:52 ` Jiri Slaby
  2022-02-15  7:25 ` Luis Chamberlain
  1 sibling, 0 replies; 3+ messages in thread
From: Jiri Slaby @ 2022-02-15  5:52 UTC (permalink / raw)
  To: davidcomponentone
  Cc: mickflemm, mcgrof, kvalo, davem, kuba, linux-wireless, netdev,
	linux-kernel, Yang Guang, Zeal Robot

On 15. 02. 22, 3:31, davidcomponentone@gmail.com wrote:
> From: Yang Guang <yang.guang5@zte.com.cn>
> 
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.

Ah, v2 already. Why do people tend to send versions of patches in an 
hours interval? The comment from before few minutes on v1 still holds:
 > Why don't you include that file then?

And also I commented on this very same patch sent on Nov 4 2021 (you did 
it correctly on the first attempt back then) [1]:
 > Why not just use sort() instead of the double loop?

So you even skip reviewers' comments. Not good.

[1] 
https://lore.kernel.org/all/0c3acbd4-6ab2-5cc5-6293-54e30093cce2@kernel.org/

> Reported-by: Zeal Robot <zealci@zte.com.cn>

The mailbox does not seem to exist:
550 5.1.1 User unknown id=620B3CA9.000

So it's pointless to put it here to bother everyone with undeliverable 
e-mails.

> Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
> Signed-off-by: David Yang <davidcomponentone@gmail.com>
> ---
> Changes from v1->v2:
> - Fix the typo "sort" to "swap"
> 
> ---
>   drivers/net/wireless/ath/ath5k/phy.c | 5 +----
>   1 file changed, 1 insertion(+), 4 deletions(-)
> 
> diff --git a/drivers/net/wireless/ath/ath5k/phy.c b/drivers/net/wireless/ath/ath5k/phy.c
> index 00f9e347d414..08dc12611f8d 100644
> --- a/drivers/net/wireless/ath/ath5k/phy.c
> +++ b/drivers/net/wireless/ath/ath5k/phy.c
> @@ -1562,16 +1562,13 @@ static s16
>   ath5k_hw_get_median_noise_floor(struct ath5k_hw *ah)
>   {
>   	s16 sort[ATH5K_NF_CAL_HIST_MAX];
> -	s16 tmp;
>   	int i, j;
>   
>   	memcpy(sort, ah->ah_nfcal_hist.nfval, sizeof(sort));
>   	for (i = 0; i < ATH5K_NF_CAL_HIST_MAX - 1; i++) {
>   		for (j = 1; j < ATH5K_NF_CAL_HIST_MAX - i; j++) {
>   			if (sort[j] > sort[j - 1]) {
> -				tmp = sort[j];
> -				sort[j] = sort[j - 1];
> -				sort[j - 1] = tmp;
> +				swap(sort[j], sort[j - 1]);
>   			}
>   		}
>   	}

Curly braces not needed now.

regards,
-- 
js
suse labs

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH v2] ath5k: use swap() to make code cleaner
  2022-02-15  2:31 [PATCH v2] ath5k: use swap() to make code cleaner davidcomponentone
  2022-02-15  5:52 ` Jiri Slaby
@ 2022-02-15  7:25 ` Luis Chamberlain
  1 sibling, 0 replies; 3+ messages in thread
From: Luis Chamberlain @ 2022-02-15  7:25 UTC (permalink / raw)
  To: davidcomponentone
  Cc: jirislaby, mickflemm, kvalo, davem, kuba, linux-wireless, netdev,
	linux-kernel, Yang Guang, Zeal Robot

On Tue, Feb 15, 2022 at 10:31:34AM +0800, davidcomponentone@gmail.com wrote:
> From: Yang Guang <yang.guang5@zte.com.cn>
> 
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
> 
> Reported-by: Zeal Robot <zealci@zte.com.cn>
> Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
> Signed-off-by: David Yang <davidcomponentone@gmail.com>
> ---

Sorry I don't trust your code as you submitted an incorrect patch last
time. So unless we get a Tested-by that there is no regression I can't
say this is correct. Please fix Zeal Robot, or better yet, open source
it for peer review.

  Luis

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2022-02-15  7:25 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-02-15  2:31 [PATCH v2] ath5k: use swap() to make code cleaner davidcomponentone
2022-02-15  5:52 ` Jiri Slaby
2022-02-15  7:25 ` Luis Chamberlain

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).