linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Darrick J. Wong" <darrick.wong@oracle.com>
To: darrick.wong@oracle.com
Cc: Dave Chinner <david@fromorbit.com>, linux-xfs@vger.kernel.org
Subject: [PATCH 0/4] xfs: refactor extent validation for 5.11
Date: Sun, 06 Dec 2020 15:10:50 -0800	[thread overview]
Message-ID: <160729625074.1608297.13414859761208067117.stgit@magnolia> (raw)

Hi all,

While reviewing the "strengthen log intent validation" series, Brian
Foster suggested that we should refactor all the validation code that
checks physical extents into a common helper, so I've done that for both
data and rt volume mappings.  I also did the same for file ranges, since
those were kind of a mess of open-coded stuff.  Dave Chinner also asked
to rename xfs_fc -> xfs_fs so that's the last patch.

If you're going to start using this mess, you probably ought to just
pull from my git trees, which are linked below.

This is an extraordinary way to destroy everything.  Enjoy!
Comments and questions are, as always, welcome.

--D

kernel git tree:
https://git.kernel.org/cgit/linux/kernel/git/djwong/xfs-linux.git/log/?h=refactorings-5.11
---
 fs/xfs/libxfs/xfs_bmap.c   |   23 ++++------------
 fs/xfs/libxfs/xfs_types.c  |   64 ++++++++++++++++++++++++++++++++++++++++++++
 fs/xfs/libxfs/xfs_types.h  |    7 +++++
 fs/xfs/scrub/bmap.c        |   17 ++++--------
 fs/xfs/scrub/rtbitmap.c    |    4 +--
 fs/xfs/xfs_bmap_item.c     |   13 +--------
 fs/xfs/xfs_extfree_item.c  |   11 +-------
 fs/xfs/xfs_refcount_item.c |   11 +-------
 fs/xfs/xfs_rmap_item.c     |   13 +--------
 fs/xfs/xfs_super.c         |   26 +++++++++---------
 10 files changed, 103 insertions(+), 86 deletions(-)


             reply	other threads:[~2020-12-06 23:11 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-12-06 23:10 Darrick J. Wong [this message]
2020-12-06 23:10 ` [PATCH 1/4] xfs: refactor data device extent validation Darrick J. Wong
2020-12-06 23:49   ` Dave Chinner
2020-12-07 14:15   ` Christoph Hellwig
2020-12-07 17:46   ` Brian Foster
2020-12-06 23:11 ` [PATCH 2/4] xfs: refactor realtime volume " Darrick J. Wong
2020-12-06 23:51   ` Dave Chinner
2020-12-07 14:16   ` Christoph Hellwig
2020-12-07 17:46   ` Brian Foster
2020-12-06 23:11 ` [PATCH 3/4] xfs: refactor file range validation Darrick J. Wong
2020-12-06 23:56   ` Dave Chinner
2020-12-07 14:17   ` Christoph Hellwig
2020-12-07 17:46   ` Brian Foster
2020-12-06 23:11 ` [PATCH 4/4] xfs: rename xfs_fc_* back to xfs_fs_* Darrick J. Wong
2020-12-06 23:56   ` Dave Chinner
2020-12-07 14:17   ` Christoph Hellwig
2020-12-07 17:46   ` Brian Foster

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=160729625074.1608297.13414859761208067117.stgit@magnolia \
    --to=darrick.wong@oracle.com \
    --cc=david@fromorbit.com \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).