linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Darrick J. Wong" <darrick.wong@oracle.com>
To: Christoph Hellwig <hch@lst.de>
Cc: linux-xfs@vger.kernel.org,
	Allison Collins <allison.henderson@oracle.com>
Subject: Re: [PATCH 15/29] xfs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME
Date: Tue, 21 Jan 2020 10:20:51 -0800	[thread overview]
Message-ID: <20200121182051.GO8247@magnolia> (raw)
In-Reply-To: <20200114081051.297488-16-hch@lst.de>

On Tue, Jan 14, 2020 at 09:10:37AM +0100, Christoph Hellwig wrote:
> op_flags with the XFS_DA_OP_* flags is the usual place for in-kernel
> only flags, so move the notime flag there.

Whenever we're done removing the kernel-internal flags from
xfs_da_args.flags, I think it's worth amending the comments for @flags
and @op_flags noting that the first one is for argument flags from
userspace and the second one is for internal flags.

Otherwise this looks good,
Reviewed-by: Darrick J. Wong <darrick.wong@oracle.com>

--D

> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
>  fs/xfs/libxfs/xfs_attr.c  | 4 ++--
>  fs/xfs/libxfs/xfs_attr.h  | 8 +-------
>  fs/xfs/libxfs/xfs_types.h | 2 ++
>  fs/xfs/scrub/attr.c       | 2 +-
>  fs/xfs/xfs_ioctl.c        | 1 -
>  5 files changed, 6 insertions(+), 11 deletions(-)
> 
> diff --git a/fs/xfs/libxfs/xfs_attr.c b/fs/xfs/libxfs/xfs_attr.c
> index c362dbab1a6a..fce4fd4a3370 100644
> --- a/fs/xfs/libxfs/xfs_attr.c
> +++ b/fs/xfs/libxfs/xfs_attr.c
> @@ -186,7 +186,7 @@ xfs_attr_try_sf_addname(
>  	 * Commit the shortform mods, and we're done.
>  	 * NOTE: this is also the error path (EEXIST, etc).
>  	 */
> -	if (!error && (args->flags & ATTR_KERNOTIME) == 0)
> +	if (!error && !(args->op_flags & XFS_DA_OP_NOTIME))
>  		xfs_trans_ichgtime(args->trans, dp, XFS_ICHGTIME_CHG);
>  
>  	if (mp->m_flags & XFS_MOUNT_WSYNC)
> @@ -385,7 +385,7 @@ xfs_attr_set(
>  	if (mp->m_flags & XFS_MOUNT_WSYNC)
>  		xfs_trans_set_sync(args->trans);
>  
> -	if ((args->flags & ATTR_KERNOTIME) == 0)
> +	if (!(args->op_flags & XFS_DA_OP_NOTIME))
>  		xfs_trans_ichgtime(args->trans, dp, XFS_ICHGTIME_CHG);
>  
>  	/*
> diff --git a/fs/xfs/libxfs/xfs_attr.h b/fs/xfs/libxfs/xfs_attr.h
> index a6de050675c9..0f369399effd 100644
> --- a/fs/xfs/libxfs/xfs_attr.h
> +++ b/fs/xfs/libxfs/xfs_attr.h
> @@ -33,19 +33,13 @@ struct xfs_attr_list_context;
>  #define ATTR_CREATE	0x0010	/* pure create: fail if attr already exists */
>  #define ATTR_REPLACE	0x0020	/* pure set: fail if attr does not exist */
>  
> -#define ATTR_KERNOTIME	0x1000	/* [kernel] don't update inode timestamps */
> -
> -#define ATTR_KERNEL_FLAGS \
> -	(ATTR_KERNOTIME)
> -
>  #define XFS_ATTR_FLAGS \
>  	{ ATTR_DONTFOLLOW, 	"DONTFOLLOW" }, \
>  	{ ATTR_ROOT,		"ROOT" }, \
>  	{ ATTR_TRUST,		"TRUST" }, \
>  	{ ATTR_SECURE,		"SECURE" }, \
>  	{ ATTR_CREATE,		"CREATE" }, \
> -	{ ATTR_REPLACE,		"REPLACE" }, \
> -	{ ATTR_KERNOTIME,	"KERNOTIME" }
> +	{ ATTR_REPLACE,		"REPLACE" }
>  
>  /*
>   * The maximum size (into the kernel or returned from the kernel) of an
> diff --git a/fs/xfs/libxfs/xfs_types.h b/fs/xfs/libxfs/xfs_types.h
> index 3379ebc0c7c5..1594325d7742 100644
> --- a/fs/xfs/libxfs/xfs_types.h
> +++ b/fs/xfs/libxfs/xfs_types.h
> @@ -223,6 +223,7 @@ typedef struct xfs_da_args {
>  #define XFS_DA_OP_ADDNAME	0x0004	/* this is an add operation */
>  #define XFS_DA_OP_OKNOENT	0x0008	/* lookup/add op, ENOENT ok, else die */
>  #define XFS_DA_OP_CILOOKUP	0x0010	/* lookup to return CI name if found */
> +#define XFS_DA_OP_NOTIME	0x0020	/* don't update inode timestamps */
>  #define XFS_DA_OP_INCOMPLETE	0x0040	/* lookup INCOMPLETE attr keys */
>  
>  #define XFS_DA_OP_FLAGS \
> @@ -231,6 +232,7 @@ typedef struct xfs_da_args {
>  	{ XFS_DA_OP_ADDNAME,	"ADDNAME" }, \
>  	{ XFS_DA_OP_OKNOENT,	"OKNOENT" }, \
>  	{ XFS_DA_OP_CILOOKUP,	"CILOOKUP" }, \
> +	{ XFS_DA_OP_NOTIME,	"NOTIME" }, \
>  	{ XFS_DA_OP_INCOMPLETE,	"INCOMPLETE" }
>  
>  /*
> diff --git a/fs/xfs/scrub/attr.c b/fs/xfs/scrub/attr.c
> index f983c2b969e0..05537627211d 100644
> --- a/fs/xfs/scrub/attr.c
> +++ b/fs/xfs/scrub/attr.c
> @@ -147,7 +147,7 @@ xchk_xattr_listent(
>  		return;
>  	}
>  
> -	args.flags = ATTR_KERNOTIME;
> +	args.op_flags = XFS_DA_OP_NOTIME;
>  	if (flags & XFS_ATTR_ROOT)
>  		args.flags |= ATTR_ROOT;
>  	else if (flags & XFS_ATTR_SECURE)
> diff --git a/fs/xfs/xfs_ioctl.c b/fs/xfs/xfs_ioctl.c
> index 75b8fa7da1c9..9306cefa9e61 100644
> --- a/fs/xfs/xfs_ioctl.c
> +++ b/fs/xfs/xfs_ioctl.c
> @@ -434,7 +434,6 @@ xfs_ioc_attrmulti_one(
>  
>  	if ((flags & ATTR_ROOT) && (flags & ATTR_SECURE))
>  		return -EINVAL;
> -	flags &= ~ATTR_KERNEL_FLAGS;
>  
>  	name = strndup_user(uname, MAXNAMELEN);
>  	if (IS_ERR(name))
> -- 
> 2.24.1
> 

  reply	other threads:[~2020-01-21 18:22 UTC|newest]

Thread overview: 74+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-14  8:10 clean up the attr interface v2 Christoph Hellwig
2020-01-14  8:10 ` [PATCH 01/29] xfs: remove the ATTR_INCOMPLETE flag Christoph Hellwig
2020-01-17  0:59   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 02/29] xfs: merge xfs_attr_remove into xfs_attr_set Christoph Hellwig
2020-01-21 17:28   ` Darrick J. Wong
2020-01-25  4:17     ` Allison Collins
2020-01-25 23:22       ` Christoph Hellwig
2020-01-26 22:23         ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 03/29] xfs: merge xfs_attrmulti_attr_remove into xfs_attrmulti_attr_set Christoph Hellwig
2020-01-21 17:41   ` Darrick J. Wong
2020-01-23 22:33     ` Christoph Hellwig
2020-01-14  8:10 ` [PATCH 04/29] xfs: use strndup_user in XFS_IOC_ATTRMULTI_BY_HANDLE Christoph Hellwig
2020-01-21 17:45   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 05/29] xfs: factor out a helper for a single XFS_IOC_ATTRMULTI_BY_HANDLE op Christoph Hellwig
2020-01-21 17:54   ` Darrick J. Wong
2020-01-23 22:34     ` Christoph Hellwig
2020-01-14  8:10 ` [PATCH 06/29] xfs: remove the name == NULL check from xfs_attr_args_init Christoph Hellwig
2020-01-21 17:57   ` Darrick J. Wong
2020-01-23 22:35     ` Christoph Hellwig
2020-01-14  8:10 ` [PATCH 07/29] xfs: remove the MAXNAMELEN " Christoph Hellwig
2020-01-21 18:03   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 08/29] xfs: move struct xfs_da_args to xfs_types.h Christoph Hellwig
2020-01-21 18:48   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 09/29] xfs: turn xfs_da_args.value into a void pointer Christoph Hellwig
2020-01-21 18:07   ` Darrick J. Wong
2020-01-23 22:36     ` Christoph Hellwig
2020-01-14  8:10 ` [PATCH 10/29] xfs: pass an initialized xfs_da_args structure to xfs_attr_set Christoph Hellwig
2020-01-21 18:10   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 11/29] xfs: pass an initialized xfs_da_args to xfs_attr_get Christoph Hellwig
2020-01-21 18:12   ` Darrick J. Wong
2020-01-23 22:39     ` Christoph Hellwig
2020-01-14  8:10 ` [PATCH 12/29] xfs: remove the xfs_inode argument to xfs_attr_get_ilocked Christoph Hellwig
2020-01-21 18:13   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 13/29] xfs: remove ATTR_KERNOVAL Christoph Hellwig
2020-01-21 18:15   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 14/29] xfs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL Christoph Hellwig
2020-01-21 18:17   ` Darrick J. Wong
2020-01-23 22:40     ` Christoph Hellwig
2020-01-14  8:10 ` [PATCH 15/29] xfs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME Christoph Hellwig
2020-01-21 18:20   ` Darrick J. Wong [this message]
2020-01-14  8:10 ` [PATCH 16/29] xfs: factor out a xfs_attr_match helper Christoph Hellwig
2020-01-21 18:27   ` Darrick J. Wong
2020-01-23 22:41     ` Christoph Hellwig
2020-01-14  8:10 ` [PATCH 17/29] xfs: cleanup xfs_attr_list_context Christoph Hellwig
2020-01-21 18:30   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 18/29] xfs: remove the unused ATTR_ENTRY macro Christoph Hellwig
2020-01-21 18:33   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 19/29] xfs: replace ATTR_ENTBASESIZE with offsetoff Christoph Hellwig
2020-01-21 18:36   ` Darrick J. Wong
2020-01-23 22:43     ` Christoph Hellwig
2020-01-14  8:10 ` [PATCH 20/29] xfs: move the legacy xfs_attr_list to xfs_ioctl.c Christoph Hellwig
2020-01-21 18:41   ` Darrick J. Wong
2020-01-24 23:13     ` Christoph Hellwig
2020-01-14  8:10 ` [PATCH 21/29] xfs: rename xfs_attr_list_int to xfs_attr_list Christoph Hellwig
2020-01-21 18:42   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 22/29] xfs: lift common checks into xfs_ioc_attr_list Christoph Hellwig
2020-01-21 18:43   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 23/29] xfs: lift buffer allocation " Christoph Hellwig
2020-01-21 18:49   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 24/29] xfs: lift cursor copy in/out " Christoph Hellwig
2020-01-21 18:52   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 25/29] xfs: improve xfs_forget_acl Christoph Hellwig
2020-01-21 18:56   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 26/29] xfs: clean up the ATTR_REPLACE checks Christoph Hellwig
2020-01-21 18:57   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 27/29] xfs: clean up the attr flag confusion Christoph Hellwig
2020-01-21 19:44   ` Darrick J. Wong
2020-01-24 23:24     ` Christoph Hellwig
2020-01-25 23:10       ` Christoph Hellwig
2020-01-26 22:24         ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 28/29] xfs: remove XFS_DA_OP_INCOMPLETE Christoph Hellwig
2020-01-21 19:45   ` Darrick J. Wong
2020-01-14  8:10 ` [PATCH 29/29] xfs: embedded the attrlist cursor into struct xfs_attr_list_context Christoph Hellwig
2020-01-21 19:04   ` Darrick J. Wong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200121182051.GO8247@magnolia \
    --to=darrick.wong@oracle.com \
    --cc=allison.henderson@oracle.com \
    --cc=hch@lst.de \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).