linuxppc-dev.lists.ozlabs.org archive mirror
 help / color / mirror / Atom feed
From: Michael Ellerman <michael@ellerman.id.au>
To: Srinivas KANDAGATLA <srinivas.kandagatla@st.com>
Cc: kgene.kim@samsung.com, devicetree-discuss@lists.ozlabs.org,
	broonie@opensource.wolfsonmicro.com, robherring2@gmail.com,
	ben-linux@fluff.org, linuxppc-dev@lists.ozlabs.org
Subject: Re: [RESEND PATCH v3 2/5] dt/powerpc/powernv: Use of_get_child_by_name to get a named child.
Date: Tue, 18 Sep 2012 11:32:39 +1000	[thread overview]
Message-ID: <1347931959.7046.1.camel@concordia> (raw)
In-Reply-To: <1347883109-16714-1-git-send-email-srinivas.kandagatla@st.com>

On Mon, 2012-09-17 at 12:58 +0100, Srinivas KANDAGATLA wrote:
> From: Srinivas Kandagatla <srinivas.kandagatla@st.com>
> 
> As follow-up to "dt: introduce of_get_child_by_name to get child node by
> name." patch, This patch removes some of the code duplication in the
> driver by replacing it with of_get_child_by_name instead.
> 
> Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@st.com>
> ---
>  arch/powerpc/platforms/powernv/opal.c |    6 +++---
>  1 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/arch/powerpc/platforms/powernv/opal.c b/arch/powerpc/platforms/powernv/opal.c
> index aaa0dba..fc7ae70 100644
> --- a/arch/powerpc/platforms/powernv/opal.c
> +++ b/arch/powerpc/platforms/powernv/opal.c
> @@ -294,9 +294,9 @@ static int __init opal_init(void)
>  		consoles = of_node_get(opal_node);
>  
>  	/* Register serial ports */
> -	for_each_child_of_node(consoles, np) {
> -		if (strcmp(np->name, "serial"))
> -			continue;
> +	np = of_get_child_by_name(consoles, "serial");
> +	if (np) {
> +		of_node_put(np);
>  		of_platform_device_create(np, NULL, NULL);

You mustn't drop the reference until after you've finished with np, as
you have written it the node could be freed before you call
of_platform_device_create().

cheers

      reply	other threads:[~2012-09-18  1:32 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-09-17 11:58 [RESEND PATCH v3 2/5] dt/powerpc/powernv: Use of_get_child_by_name to get a named child Srinivas KANDAGATLA
2012-09-18  1:32 ` Michael Ellerman [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1347931959.7046.1.camel@concordia \
    --to=michael@ellerman.id.au \
    --cc=ben-linux@fluff.org \
    --cc=broonie@opensource.wolfsonmicro.com \
    --cc=devicetree-discuss@lists.ozlabs.org \
    --cc=kgene.kim@samsung.com \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=robherring2@gmail.com \
    --cc=srinivas.kandagatla@st.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).