linuxppc-dev.lists.ozlabs.org archive mirror
 help / color / mirror / Atom feed
From: Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com>
To: <monstr@monstr.eu>, <tglx@linutronix.de>, <jason@lakedaemon.net>,
	<marc.zyngier@arm.com>
Cc: <linux-kernel@vger.kernel.org>, <michal.simek@xilinx.com>,
	<linuxppc-dev@lists.ozlabs.org>, <mpe@ellerman.id.au>,
	<Zubair.Kakakhel@imgtec.com>
Subject: [Patch v7 4/7] irqchip: xilinx: Rename get_irq to xintc_get_irq
Date: Mon, 14 Nov 2016 12:13:48 +0000	[thread overview]
Message-ID: <20161114121351.10924-5-Zubair.Kakakhel@imgtec.com> (raw)
In-Reply-To: <20161114121351.10924-1-Zubair.Kakakhel@imgtec.com>

Now that the driver is generic and used by multiple archs,
get_irq is too generic.

Rename get_irq to xintc_get_irq to avoid any conflicts

Signed-off-by: Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com>

---
V6 -> V7
Rebase to v4.9-rc5

V5 -> V6
Removed __func__ in printk
Rebase to v4.9-rc3

V4 -> V5
Rebased to v4.9-rc1
Use __func__ in pr_err

V3 -> V4
New patch.
---
 arch/microblaze/include/asm/irq.h | 2 +-
 arch/microblaze/kernel/irq.c      | 4 ++--
 drivers/irqchip/irq-xilinx-intc.c | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/arch/microblaze/include/asm/irq.h b/arch/microblaze/include/asm/irq.h
index bab3b13..d785def 100644
--- a/arch/microblaze/include/asm/irq.h
+++ b/arch/microblaze/include/asm/irq.h
@@ -16,6 +16,6 @@ struct pt_regs;
 extern void do_IRQ(struct pt_regs *regs);
 
 /* should be defined in each interrupt controller driver */
-extern unsigned int get_irq(void);
+extern unsigned int xintc_get_irq(void);
 
 #endif /* _ASM_MICROBLAZE_IRQ_H */
diff --git a/arch/microblaze/kernel/irq.c b/arch/microblaze/kernel/irq.c
index 11e24de..903dad8 100644
--- a/arch/microblaze/kernel/irq.c
+++ b/arch/microblaze/kernel/irq.c
@@ -29,12 +29,12 @@ void __irq_entry do_IRQ(struct pt_regs *regs)
 	trace_hardirqs_off();
 
 	irq_enter();
-	irq = get_irq();
+	irq = xintc_get_irq();
 next_irq:
 	BUG_ON(!irq);
 	generic_handle_irq(irq);
 
-	irq = get_irq();
+	irq = xintc_get_irq();
 	if (irq != -1U) {
 		pr_debug("next irq: %d\n", irq);
 		++concurrent_irq;
diff --git a/drivers/irqchip/irq-xilinx-intc.c b/drivers/irqchip/irq-xilinx-intc.c
index 7331d8c..34ec609 100644
--- a/drivers/irqchip/irq-xilinx-intc.c
+++ b/drivers/irqchip/irq-xilinx-intc.c
@@ -101,7 +101,7 @@ static struct irq_chip intc_dev = {
 	.irq_mask_ack = intc_mask_ack,
 };
 
-unsigned int get_irq(void)
+unsigned int xintc_get_irq(void)
 {
 	unsigned int hwirq, irq = -1;
 
-- 
2.10.2

  parent reply	other threads:[~2016-11-14 12:14 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-11-14 12:13 [Patch v7 0/7] microblaze/PowerPC: Move irq-xilinx to irqchip Zubair Lutfullah Kakakhel
2016-11-14 12:13 ` [Patch v7 1/7] microblaze: irqchip: Move intc driver " Zubair Lutfullah Kakakhel
2016-11-15 12:22   ` Michal Simek
2016-11-14 12:13 ` [Patch v7 2/7] irqchip: xilinx: clean up print messages Zubair Lutfullah Kakakhel
2016-11-15 12:23   ` Michal Simek
2016-11-14 12:13 ` [Patch v7 3/7] irqchip: xilinx: restructure and use jump label api Zubair Lutfullah Kakakhel
2016-11-15 12:49   ` Michal Simek
2016-11-15 16:03     ` Zubair Lutfullah Kakakhel
2016-11-16  9:24       ` Michal Simek
2016-11-14 12:13 ` Zubair Lutfullah Kakakhel [this message]
2016-11-15 12:24   ` [Patch v7 4/7] irqchip: xilinx: Rename get_irq to xintc_get_irq Michal Simek
2016-11-14 12:13 ` [Patch v7 5/7] irqchip: xilinx: Add support for parent intc Zubair Lutfullah Kakakhel
2016-11-14 12:13 ` [Patch v7 6/7] irqchip: xilinx: Try to fall back if xlnx, kind-of-intr not provided Zubair Lutfullah Kakakhel
2016-11-15 12:26   ` [Patch v7 6/7] irqchip: xilinx: Try to fall back if xlnx,kind-of-intr " Michal Simek
2016-11-18 13:29   ` [Patch v7 6/7] irqchip: xilinx: Try to fall back if xlnx, kind-of-intr " Thomas Gleixner
2016-11-21 14:05     ` [Patch v7 6/7] irqchip: xilinx: Try to fall back if xlnx,kind-of-intr " Zubair Lutfullah Kakakhel
2016-11-21 14:17       ` Marc Zyngier
2016-11-21 14:36         ` Zubair Lutfullah Kakakhel
2016-11-21 15:48       ` [Patch v7 6/7] irqchip: xilinx: Try to fall back if xlnx, kind-of-intr " Thomas Gleixner
2016-11-14 12:13 ` [Patch v7 7/7] powerpc/virtex: Use generic xilinx irqchip driver Zubair Lutfullah Kakakhel
2016-11-15 12:28   ` Michal Simek
2016-11-22 10:55 ` [Patch v7 0/7] microblaze/PowerPC: Move irq-xilinx to irqchip Marc Zyngier
2016-11-22 11:10   ` Zubair Lutfullah Kakakhel

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20161114121351.10924-5-Zubair.Kakakhel@imgtec.com \
    --to=zubair.kakakhel@imgtec.com \
    --cc=jason@lakedaemon.net \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=marc.zyngier@arm.com \
    --cc=michal.simek@xilinx.com \
    --cc=monstr@monstr.eu \
    --cc=mpe@ellerman.id.au \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).