linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Thara Gopinath <thara.gopinath@linaro.org>
To: Zhang Rui <rui.zhang@intel.com>,
	daniel.lezcano@linaro.org, robh+dt@kernel.org
Cc: linux-pm@vger.kernel.org, devicetree@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [RFC PATCH 3/4] thermal:core:Add genetlink notifications for monitoring falling temperature
Date: Wed, 15 Jul 2020 19:15:00 -0400	[thread overview]
Message-ID: <021bec8e-2cf7-99fb-d224-e16796b95567@linaro.org> (raw)
In-Reply-To: <746420e6b213985518d8b314018e32dc3438e9af.camel@intel.com>



On 7/15/20 4:46 AM, Zhang Rui wrote:
> On Fri, 2020-07-10 at 09:51 -0400, Thara Gopinath wrote:
>> Add notification calls for trip type THERMAL_TRIP_COLD when
>> temperature
>> crosses the trip point in either direction.
>>
>> Signed-off-by: Thara Gopinath <thara.gopinath@linaro.org>
>> ---
>>   drivers/thermal/thermal_core.c | 21 +++++++++++++++------
>>   1 file changed, 15 insertions(+), 6 deletions(-)
>>
>> diff --git a/drivers/thermal/thermal_core.c
>> b/drivers/thermal/thermal_core.c
>> index 750a89f0c20a..e2302ca1cd3b 100644
>> --- a/drivers/thermal/thermal_core.c
>> +++ b/drivers/thermal/thermal_core.c
>> @@ -429,12 +429,21 @@ static void handle_thermal_trip(struct
>> thermal_zone_device *tz, int trip)
>>   		tz->ops->get_trip_hyst(tz, trip, &hyst);
>>   
>>   	if (tz->last_temperature != THERMAL_TEMP_INVALID) {
>> -		if (tz->last_temperature < trip_temp &&
>> -		    tz->temperature >= trip_temp)
>> -			thermal_notify_tz_trip_up(tz->id, trip);
>> -		if (tz->last_temperature >= trip_temp &&
>> -		    tz->temperature < (trip_temp - hyst))
>> -			thermal_notify_tz_trip_down(tz->id, trip);
>> +		if (type == THERMAL_TRIP_COLD) {
>> +			if (tz->last_temperature > trip_temp &&
>> +			    tz->temperature <= trip_temp)
>> +				thermal_notify_tz_trip_down(tz->id,
>> trip);
> 
> trip_type should also be part of the event because trip_down/trip_up
> for hot trip and cold trip have different meanings.
> Or can we use some more generic names like trip_on/trip_off? trip_on
> means the trip point is violated or actions need to be taken for the
> specific trip points, for both hot and cold trips. I know
> trip_on/trip_off doesn't represent what I mean clearly, but surely you
> can find a better name.

Makes sense.. I will fix this in the next version. I don't have a good 
name at the moment but will think of something!


-- 
Warm Regards
Thara

  reply	other threads:[~2020-07-15 23:15 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-10 13:51 [RFC PATCH 0/4] thermal: Introduce support for monitoring falling temperature Thara Gopinath
2020-07-10 13:51 ` [RFC PATCH 1/4] dt-bindings:thermal:Add cold trip point type Thara Gopinath
2020-07-13 15:05   ` Daniel Lezcano
2020-07-13 17:01     ` Thara Gopinath
2020-07-13 17:03       ` Daniel Lezcano
2020-07-10 13:51 ` [RFC PATCH 2/4] thermal: Add support for cold trip point Thara Gopinath
2020-07-10 13:51 ` [RFC PATCH 3/4] thermal:core:Add genetlink notifications for monitoring falling temperature Thara Gopinath
2020-07-15  8:46   ` Zhang Rui
2020-07-15 23:15     ` Thara Gopinath [this message]
2020-07-10 13:51 ` [RFC PATCH 4/4] thermal: Modify thermal governors to do nothing for "cold" trip points Thara Gopinath
2020-07-15  8:35   ` Zhang Rui
2020-07-15 23:13     ` Thara Gopinath
2020-07-13 15:03 ` [RFC PATCH 0/4] thermal: Introduce support for monitoring falling temperature Daniel Lezcano
2020-07-14 13:49   ` Zhang Rui
2020-07-14 21:39     ` Thara Gopinath
2020-07-15  8:27       ` Zhang Rui
2020-07-15 23:10         ` Thara Gopinath

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=021bec8e-2cf7-99fb-d224-e16796b95567@linaro.org \
    --to=thara.gopinath@linaro.org \
    --cc=daniel.lezcano@linaro.org \
    --cc=devicetree@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=robh+dt@kernel.org \
    --cc=rui.zhang@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).