linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* IRQ_NONE definition in NCR5380 driver...
@ 2003-05-29 23:27 Dave Airlie
  2003-05-30  8:16 ` Russell King
  2003-05-30  9:39 ` Alan Cox
  0 siblings, 2 replies; 3+ messages in thread
From: Dave Airlie @ 2003-05-29 23:27 UTC (permalink / raw)
  To: linux-kernel


Currently the NCR5380.h defines IRQ_NONE to be 255, is there any special
reason for this? why not use UINT32_MAX-1?..

The VAX actually has got more than 255 interrupt handlers which we've
mapped to IRQs, and it happens the external SCSI interface is at 255, so
this makes it a bit sick...

I've redefined it in our tree to 65535 but I see no reason not to go to
the above... any objections?

Dave.

-- 
David Airlie, Software Engineer
http://www.skynet.ie/~airlied / airlied@skynet.ie
pam_smb / Linux DecStation / Linux VAX / ILUG person


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: IRQ_NONE definition in NCR5380 driver...
  2003-05-29 23:27 IRQ_NONE definition in NCR5380 driver Dave Airlie
@ 2003-05-30  8:16 ` Russell King
  2003-05-30  9:39 ` Alan Cox
  1 sibling, 0 replies; 3+ messages in thread
From: Russell King @ 2003-05-30  8:16 UTC (permalink / raw)
  To: Dave Airlie; +Cc: linux-kernel

On Fri, May 30, 2003 at 12:27:25AM +0100, Dave Airlie wrote:
> Currently the NCR5380.h defines IRQ_NONE to be 255, is there any special
> reason for this? why not use UINT32_MAX-1?..
> 
> The VAX actually has got more than 255 interrupt handlers which we've
> mapped to IRQs, and it happens the external SCSI interface is at 255, so
> this makes it a bit sick...
> 
> I've redefined it in our tree to 65535 but I see no reason not to go to
> the above... any objections?

Only that ARM already has a NO_IRQ macro fairly well established for this
thing, which should probably be propagated to the other architectures.
Could we call it NO_IRQ instead?

I seem to remember that in the dim and distant past, several drivers
used to store IRQ numbers in byte-sized objects, so this would need to
be fixed before making NO_IRQ > 255.

-- 
Russell King (rmk@arm.linux.org.uk)                The developer of ARM Linux
             http://www.arm.linux.org.uk/personal/aboutme.html


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: IRQ_NONE definition in NCR5380 driver...
  2003-05-29 23:27 IRQ_NONE definition in NCR5380 driver Dave Airlie
  2003-05-30  8:16 ` Russell King
@ 2003-05-30  9:39 ` Alan Cox
  1 sibling, 0 replies; 3+ messages in thread
From: Alan Cox @ 2003-05-30  9:39 UTC (permalink / raw)
  To: Dave Airlie; +Cc: Linux Kernel Mailing List

On Gwe, 2003-05-30 at 00:27, Dave Airlie wrote:
> Currently the NCR5380.h defines IRQ_NONE to be 255, is there any special
> reason for this? why not use UINT32_MAX-1?..

Shouldnt cause any problems at all. I have the same problem with the IDE
layer and "picking an IRQ that cant exist". Maybe we need a global
IRQ_NONE type value


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2003-05-30 10:23 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2003-05-29 23:27 IRQ_NONE definition in NCR5380 driver Dave Airlie
2003-05-30  8:16 ` Russell King
2003-05-30  9:39 ` Alan Cox

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).