linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/7 v3] writeback: Avoid iput() from flusher thread
@ 2012-05-03 12:47 Jan Kara
  2012-05-03 12:47 ` [PATCH 1/9] writeback: Move clearing of I_SYNC into inode_sync_complete() Jan Kara
                   ` (9 more replies)
  0 siblings, 10 replies; 11+ messages in thread
From: Jan Kara @ 2012-05-03 12:47 UTC (permalink / raw)
  To: linux-fsdevel
  Cc: LKML, Al Viro, Christoph Hellwig, dchinner, Wu Fengguang, Jan Kara

  Hi,

  this is a third iteration of my patch series for getting rid of iput() from
flusher thread. I think all the comments should be addressed. So please have
a look.

Changes since v2:
  * split last patch into two - move of inode_sync_wait() and change of
    inode_sync_wait() logic
  * added patch renaming end_writeback() to clear_inode()
  * couple of minor changes in comments, function names, ...

Changes since v1:
  * contents of last two patches from my previous submission split to several
    patches
  * changed some calling conventions
  * fixed a couple of bugs I found in the process

								Honza


^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2012-05-07  2:57 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-05-03 12:47 [PATCH 0/7 v3] writeback: Avoid iput() from flusher thread Jan Kara
2012-05-03 12:47 ` [PATCH 1/9] writeback: Move clearing of I_SYNC into inode_sync_complete() Jan Kara
2012-05-03 12:47 ` [PATCH 2/9] writeback: Move requeueing when I_SYNC set to writeback_sb_inodes() Jan Kara
2012-05-03 12:47 ` [PATCH 3/9] writeback: Move I_DIRTY_PAGES handling Jan Kara
2012-05-03 12:47 ` [PATCH 4/9] writeback: Separate inode requeueing after writeback Jan Kara
2012-05-03 12:47 ` [PATCH 5/9] writeback: Remove wb->list_lock from writeback_single_inode() Jan Kara
2012-05-03 12:48 ` [PATCH 6/9] writeback: Refactor writeback_single_inode() Jan Kara
2012-05-03 12:48 ` [PATCH 7/9] vfs: Move waiting for inode writeback from end_writeback() to evict_inode() Jan Kara
2012-05-03 12:48 ` [PATCH 8/9] vfs: Rename end_writeback() to clear_inode() Jan Kara
2012-05-03 12:48 ` [PATCH 9/9] writeback: Avoid iput() from flusher thread Jan Kara
2012-05-07  2:57 ` [PATCH 0/7 v3] " Fengguang Wu

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).