linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] mtd_blkdev: Use a different name for block_device_operations variable
@ 2012-11-09 15:36 Ezequiel Garcia
  2012-11-21 15:02 ` Artem Bityutskiy
  0 siblings, 1 reply; 2+ messages in thread
From: Ezequiel Garcia @ 2012-11-09 15:36 UTC (permalink / raw)
  To: linux-mtd; +Cc: linux-kernel, Ezequiel Garcia, David Woodhouse

struct mtd_blktrans_ops is a type, and mtd_blktrans_ops is a variable.
To improve code clarity it's better to not use the same names,
so we just change the latter.

Cc: David Woodhouse <dwmw2@infradead.org>
Signed-off-by: Ezequiel Garcia <elezegarcia@gmail.com>
---
 drivers/mtd/mtd_blkdevs.c |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/mtd/mtd_blkdevs.c b/drivers/mtd/mtd_blkdevs.c
index f1f0671..26ef2a7 100644
--- a/drivers/mtd/mtd_blkdevs.c
+++ b/drivers/mtd/mtd_blkdevs.c
@@ -325,7 +325,7 @@ unlock:
 	return ret;
 }
 
-static const struct block_device_operations mtd_blktrans_ops = {
+static const struct block_device_operations mtd_block_ops = {
 	.owner		= THIS_MODULE,
 	.open		= blktrans_open,
 	.release	= blktrans_release,
@@ -401,7 +401,7 @@ int add_mtd_blktrans_dev(struct mtd_blktrans_dev *new)
 	gd->private_data = new;
 	gd->major = tr->major;
 	gd->first_minor = (new->devnum) << tr->part_bits;
-	gd->fops = &mtd_blktrans_ops;
+	gd->fops = &mtd_block_ops;
 
 	if (tr->part_bits)
 		if (new->devnum < 26)
-- 
1.7.8.6


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] mtd_blkdev: Use a different name for block_device_operations variable
  2012-11-09 15:36 [PATCH] mtd_blkdev: Use a different name for block_device_operations variable Ezequiel Garcia
@ 2012-11-21 15:02 ` Artem Bityutskiy
  0 siblings, 0 replies; 2+ messages in thread
From: Artem Bityutskiy @ 2012-11-21 15:02 UTC (permalink / raw)
  To: Ezequiel Garcia; +Cc: linux-mtd, linux-kernel, David Woodhouse

[-- Attachment #1: Type: text/plain, Size: 412 bytes --]

On Fri, 2012-11-09 at 12:36 -0300, Ezequiel Garcia wrote:
> struct mtd_blktrans_ops is a type, and mtd_blktrans_ops is a variable.
> To improve code clarity it's better to not use the same names,
> so we just change the latter.
> 
> Cc: David Woodhouse <dwmw2@infradead.org>
> Signed-off-by: Ezequiel Garcia <elezegarcia@gmail.com>

Pushed to l2-mtd.git, thanks!

-- 
Best Regards,
Artem Bityutskiy

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 836 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2012-11-21 15:01 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-11-09 15:36 [PATCH] mtd_blkdev: Use a different name for block_device_operations variable Ezequiel Garcia
2012-11-21 15:02 ` Artem Bityutskiy

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).