linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Antoine Tenart <antoine.tenart@free-electrons.com>
To: balbi@ti.com, gregkh@linuxfoundation.org,
	Peter.Chen@freescale.com, kishon@ti.com,
	stern@rowland.harvard.edu
Cc: Antoine Tenart <antoine.tenart@free-electrons.com>,
	sergei.shtylyov@cogentembedded.com,
	yoshihiro.shimoda.uh@renesas.com,
	alexandre.belloni@free-electrons.com,
	thomas.petazzoni@free-electrons.com, zmxu@marvell.com,
	jszhang@marvell.com, linux-usb@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: [PATCH v5 5/9] usb: rename gen_phy to phy in HCD
Date: Mon, 15 Sep 2014 12:35:05 +0200	[thread overview]
Message-ID: <1410777309-12552-6-git-send-email-antoine.tenart@free-electrons.com> (raw)
In-Reply-To: <1410777309-12552-1-git-send-email-antoine.tenart@free-electrons.com>

The patch adding support to the generic PHY framework introduced a
'gen_phy' member in the HCD structure. Rename it to 'phy' to have a
consistent USB framework.

Signed-off-by: Antoine Tenart <antoine.tenart@free-electrons.com>
Acked-by: Alan Stern <stern@rowland.harvard.edu>
---
 drivers/usb/core/hcd.c  | 22 +++++++++++-----------
 include/linux/usb/hcd.h |  4 +++-
 2 files changed, 14 insertions(+), 12 deletions(-)

diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
index 86fdce55ae16..6619239baf6d 100644
--- a/drivers/usb/core/hcd.c
+++ b/drivers/usb/core/hcd.c
@@ -2665,7 +2665,7 @@ int usb_add_hcd(struct usb_hcd *hcd,
 				phy_put(phy);
 				goto err_phy;
 			}
-			hcd->gen_phy = phy;
+			hcd->phy = phy;
 		}
 	}
 
@@ -2812,11 +2812,11 @@ err_allocate_root_hub:
 err_register_bus:
 	hcd_buffer_destroy(hcd);
 err_create_buf:
-	if (IS_ENABLED(CONFIG_GENERIC_PHY) && hcd->gen_phy) {
-		phy_power_off(hcd->gen_phy);
-		phy_exit(hcd->gen_phy);
-		phy_put(hcd->gen_phy);
-		hcd->gen_phy = NULL;
+	if (IS_ENABLED(CONFIG_GENERIC_PHY) && hcd->phy) {
+		phy_power_off(hcd->phy);
+		phy_exit(hcd->phy);
+		phy_put(hcd->phy);
+		hcd->phy = NULL;
 	}
 err_phy:
 	if (hcd->remove_phy && hcd->usb_phy) {
@@ -2896,11 +2896,11 @@ void usb_remove_hcd(struct usb_hcd *hcd)
 	usb_deregister_bus(&hcd->self);
 	hcd_buffer_destroy(hcd);
 
-	if (IS_ENABLED(CONFIG_GENERIC_PHY) && hcd->gen_phy) {
-		phy_power_off(hcd->gen_phy);
-		phy_exit(hcd->gen_phy);
-		phy_put(hcd->gen_phy);
-		hcd->gen_phy = NULL;
+	if (IS_ENABLED(CONFIG_GENERIC_PHY) && hcd->phy) {
+		phy_power_off(hcd->phy);
+		phy_exit(hcd->phy);
+		phy_put(hcd->phy);
+		hcd->phy = NULL;
 	}
 	if (hcd->remove_phy && hcd->usb_phy) {
 		usb_phy_shutdown(hcd->usb_phy);
diff --git a/include/linux/usb/hcd.h b/include/linux/usb/hcd.h
index 604d2e6e0c1c..19b3fbd1f9e1 100644
--- a/include/linux/usb/hcd.h
+++ b/include/linux/usb/hcd.h
@@ -105,9 +105,11 @@ struct usb_hcd {
 	/*
 	 * OTG and some Host controllers need software interaction with phys;
 	 * other external phys should be software-transparent
+	 *
+	 * Keep the usb_phy for compatibility reasons, for now
 	 */
 	struct usb_phy		*usb_phy;
-	struct phy		*gen_phy;
+	struct phy		*phy;
 
 	/* Flags that need to be manipulated atomically because they can
 	 * change while the host controller is running.  Always use
-- 
1.9.1


  parent reply	other threads:[~2014-09-15 10:35 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-09-15 10:35 [PATCH v5 0/9] usb: add support for the generic PHY framework Antoine Tenart
2014-09-15 10:35 ` [PATCH v5 1/9] usb: move the OTG state from the USB PHY to the OTG structure Antoine Tenart
2014-09-15 10:35 ` [PATCH v5 2/9] usb: rename phy to usb_phy in OTG Antoine Tenart
2014-09-15 10:35 ` [PATCH v5 3/9] usb: add support to the generic PHY framework " Antoine Tenart
2014-09-15 10:35 ` [PATCH v5 4/9] usb: rename phy to usb_phy in HCD Antoine Tenart
2014-09-15 18:09   ` Sergei Shtylyov
2014-09-16 13:53     ` Antoine Tenart
2014-09-16 14:01       ` Antoine Tenart
2014-09-15 10:35 ` Antoine Tenart [this message]
2014-09-15 18:12   ` [PATCH v5 5/9] usb: rename gen_phy to phy " Sergei Shtylyov
2014-09-15 10:35 ` [PATCH v5 6/9] usb: allow to supply the PHY in the drivers when using HCD Antoine Tenart
2014-09-15 10:35 ` [PATCH v5 7/9] usb: rename transceiver and phy to usb_phy in ChipIdea Antoine Tenart
2014-09-16  0:00   ` Peter Chen
2014-09-15 10:35 ` [PATCH v5 8/9] usb: chipidea: move usb_otg into struct ci_hdrc Antoine Tenart
2014-09-15 10:35 ` [PATCH v5 9/9] usb: chipidea: add support to the generic PHY framework in ChipIdea Antoine Tenart
2014-09-16  0:07   ` Peter Chen
2014-09-16 13:41     ` Antoine Tenart

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1410777309-12552-6-git-send-email-antoine.tenart@free-electrons.com \
    --to=antoine.tenart@free-electrons.com \
    --cc=Peter.Chen@freescale.com \
    --cc=alexandre.belloni@free-electrons.com \
    --cc=balbi@ti.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jszhang@marvell.com \
    --cc=kishon@ti.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=sergei.shtylyov@cogentembedded.com \
    --cc=stern@rowland.harvard.edu \
    --cc=thomas.petazzoni@free-electrons.com \
    --cc=yoshihiro.shimoda.uh@renesas.com \
    --cc=zmxu@marvell.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).