linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Peter Chen <peter.chen@freescale.com>
To: Antoine Tenart <antoine.tenart@free-electrons.com>
Cc: <balbi@ti.com>, <gregkh@linuxfoundation.org>, <kishon@ti.com>,
	<stern@rowland.harvard.edu>, <sergei.shtylyov@cogentembedded.com>,
	<yoshihiro.shimoda.uh@renesas.com>,
	<alexandre.belloni@free-electrons.com>,
	<thomas.petazzoni@free-electrons.com>, <zmxu@marvell.com>,
	<jszhang@marvell.com>, <linux-usb@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v5 9/9] usb: chipidea: add support to the generic PHY framework in ChipIdea
Date: Tue, 16 Sep 2014 08:07:21 +0800	[thread overview]
Message-ID: <20140916000720.GB3379@peterchendt> (raw)
In-Reply-To: <1410777309-12552-10-git-send-email-antoine.tenart@free-electrons.com>

On Mon, Sep 15, 2014 at 12:35:09PM +0200, Antoine Tenart wrote:
> This patch adds support of the PHY framework for ChipIdea drivers.
> Changes are done in both the ChipIdea common code and in the drivers
> accessing the PHY. This is done by adding a new PHY member in
> ChipIdea's structures and by taking care of it in the code.
> 
> Signed-off-by: Antoine Tenart <antoine.tenart@free-electrons.com>
> ---
>  drivers/usb/chipidea/ci.h      |  5 ++-
>  drivers/usb/chipidea/core.c    | 83 +++++++++++++++++++++++++++++++++---------
>  drivers/usb/chipidea/debug.c   |  2 +-
>  drivers/usb/chipidea/host.c    |  5 ++-
>  drivers/usb/chipidea/otg_fsm.c |  6 ++-
>  include/linux/usb/chipidea.h   |  2 +
>  6 files changed, 81 insertions(+), 22 deletions(-)
> 
> diff --git a/drivers/usb/chipidea/ci.h b/drivers/usb/chipidea/ci.h
> index dac5ab6adfa2..7e9e8223672a 100644
> --- a/drivers/usb/chipidea/ci.h
> +++ b/drivers/usb/chipidea/ci.h
> @@ -161,7 +161,8 @@ struct hw_bank {
>   * @test_mode: the selected test mode
>   * @platdata: platform specific information supplied by parent device
>   * @vbus_active: is VBUS active
> - * @usb_phy: pointer to USB PHY, if any
> + * @phy: pointer to PHY, if any
> + * @usb_phy: pointer to USB PHY, if any and if using the USB PHY framework
>   * @hcd: pointer to usb_hcd for ehci host driver
>   * @debugfs: root dentry for this controller in debugfs
>   * @id_event: indicates there is an id event, and handled at ci_otg_work
> @@ -202,6 +203,8 @@ struct ci_hdrc {
>  
>  	struct ci_hdrc_platform_data	*platdata;
>  	int				vbus_active;
> +	struct phy			*phy;
> +	/* old usb_phy interface */
>  	struct usb_phy			*usb_phy;
>  	struct usb_hcd			*hcd;
>  	struct dentry			*debugfs;
> diff --git a/drivers/usb/chipidea/core.c b/drivers/usb/chipidea/core.c
> index ee96b0696a7b..e1d3d3f44075 100644
> --- a/drivers/usb/chipidea/core.c
> +++ b/drivers/usb/chipidea/core.c
> @@ -47,6 +47,7 @@
>  #include <linux/delay.h>
>  #include <linux/device.h>
>  #include <linux/dma-mapping.h>
> +#include <linux/phy/phy.h>
>  #include <linux/platform_device.h>
>  #include <linux/module.h>
>  #include <linux/idr.h>
> @@ -293,6 +294,49 @@ static void hw_phymode_configure(struct ci_hdrc *ci)
>  }
>  
>  /**
> + * _ci_usb_phy_init: initialize phy taking in account both phy and usb_phy
> + * interfaces
> + * @ci: the controller
> + *
> + * This function returns an error code if the phy failed to init
> + */
> +static int _ci_usb_phy_init(struct ci_hdrc *ci)
> +{
> +	int ret;
> +
> +	if (ci->phy) {
> +		ret = phy_init(ci->phy);
> +		if (ret)
> +			return ret;
> +
> +		ret = phy_power_on(ci->phy);
> +		if (ret) {
> +			phy_exit(ci->phy);
> +			return ret;
> +		}
> +	} else {
> +		ret = usb_phy_init(ci->usb_phy);
> +	}
> +
> +	return ret;
> +}
> +
> +/**
> + * _ci_usb_phy_exit: deinitialize phy taking in account both phy and usb_phy
> + * interfaces
> + * @ci: the controller
> + */
> +static void ci_usb_phy_exit(struct ci_hdrc *ci)
> +{
> +	if (ci->phy) {
> +		phy_power_off(ci->phy);
> +		phy_exit(ci->phy);
> +	} else {
> +		usb_phy_shutdown(ci->usb_phy);
> +	}
> +}
> +
> +/**
>   * ci_usb_phy_init: initialize phy according to different phy type
>   * @ci: the controller
>    *
> @@ -306,7 +350,7 @@ static int ci_usb_phy_init(struct ci_hdrc *ci)
>  	case USBPHY_INTERFACE_MODE_UTMI:
>  	case USBPHY_INTERFACE_MODE_UTMIW:
>  	case USBPHY_INTERFACE_MODE_HSIC:
> -		ret = usb_phy_init(ci->usb_phy);
> +		ret = _ci_usb_phy_init(ci);
>  		if (ret)
>  			return ret;
>  		hw_phymode_configure(ci);
> @@ -314,12 +358,12 @@ static int ci_usb_phy_init(struct ci_hdrc *ci)
>  	case USBPHY_INTERFACE_MODE_ULPI:
>  	case USBPHY_INTERFACE_MODE_SERIAL:
>  		hw_phymode_configure(ci);
> -		ret = usb_phy_init(ci->usb_phy);
> +		ret = _ci_usb_phy_init(ci);
>  		if (ret)
>  			return ret;
>  		break;
>  	default:
> -		ret = usb_phy_init(ci->usb_phy);
> +		ret = _ci_usb_phy_init(ci);
>  	}
>  
>  	return ret;
> @@ -595,23 +639,26 @@ static int ci_hdrc_probe(struct platform_device *pdev)
>  		return -ENODEV;
>  	}
>  
> -	if (ci->platdata->usb_phy)
> +	if (ci->platdata->phy) {
> +		ci->phy = ci->platdata->phy;
> +	} else if (ci->platdata->usb_phy) {
>  		ci->usb_phy = ci->platdata->usb_phy;
> -	else
> +	} else {
> +		ci->phy = devm_phy_get(dev, "usb-phy");
>  		ci->usb_phy = devm_usb_get_phy(dev, USB_PHY_TYPE_USB2);
>  
> -	if (IS_ERR(ci->usb_phy)) {
> -		ret = PTR_ERR(ci->usb_phy);
> -		/*
> -		 * if -ENXIO is returned, it means PHY layer wasn't
> -		 * enabled, so it makes no sense to return -EPROBE_DEFER
> -		 * in that case, since no PHY driver will ever probe.
> -		 */
> -		if (ret == -ENXIO)
> -			return ret;
> +		/* if both generic PHY and USB PHY layers aren't enabled */
> +		if (PTR_ERR(ci->phy) == -ENOSYS &&
> +				PTR_ERR(ci->usb_phy) == -ENXIO)
> +			return -ENXIO;
> +
> +		if (IS_ERR(ci->phy) && IS_ERR(ci->usb_phy))
> +			return -EPROBE_DEFER;
>  
> -		dev_err(dev, "no usb2 phy configured\n");
> -		return -EPROBE_DEFER;
> +		if (IS_ERR(ci->phy))
> +			ci->phy = NULL;
> +		else if (IS_ERR(ci->usb_phy))
> +			ci->usb_phy = NULL;
>  	}
>  
>  	ret = ci_usb_phy_init(ci);
> @@ -718,7 +765,7 @@ static int ci_hdrc_probe(struct platform_device *pdev)
>  stop:
>  	ci_role_destroy(ci);
>  deinit_phy:
> -	usb_phy_shutdown(ci->usb_phy);
> +	ci_usb_phy_exit(ci);
>  
>  	return ret;
>  }
> @@ -731,7 +778,7 @@ static int ci_hdrc_remove(struct platform_device *pdev)
>  	free_irq(ci->irq, ci);
>  	ci_role_destroy(ci);
>  	ci_hdrc_enter_lpm(ci, true);
> -	usb_phy_shutdown(ci->usb_phy);
> +	ci_usb_phy_exit(ci);
>  	kfree(ci->hw_bank.regmap);
>  
>  	return 0;
> diff --git a/drivers/usb/chipidea/debug.c b/drivers/usb/chipidea/debug.c
> index 8f437e1512fa..999e9d683d7a 100644
> --- a/drivers/usb/chipidea/debug.c
> +++ b/drivers/usb/chipidea/debug.c
> @@ -220,7 +220,7 @@ static int ci_otg_show(struct seq_file *s, void *unused)
>  
>  	/* ------ State ----- */
>  	seq_printf(s, "OTG state: %s\n\n",
> -		usb_otg_state_string(ci->usb_phy->otg.state));
> +		   usb_otg_state_string(ci->otg.state));

This one should be at your 8th patch, isn't it?

Others look ok, but need test.

Peter
>  
>  	/* ------ State Machine Variables ----- */
>  	seq_printf(s, "a_bus_drop: %d\n", fsm->a_bus_drop);
> diff --git a/drivers/usb/chipidea/host.c b/drivers/usb/chipidea/host.c
> index 4fcebb6a6d14..e9a872ac355d 100644
> --- a/drivers/usb/chipidea/host.c
> +++ b/drivers/usb/chipidea/host.c
> @@ -59,7 +59,10 @@ static int host_start(struct ci_hdrc *ci)
>  	hcd->has_tt = 1;
>  
>  	hcd->power_budget = ci->platdata->power_budget;
> -	hcd->usb_phy = ci->usb_phy;
> +	if (ci->phy)
> +		hcd->phy = ci->phy;
> +	else
> +		hcd->usb_phy = ci->usb_phy;
>  
>  	ehci = hcd_to_ehci(hcd);
>  	ehci->caps = ci->hw_bank.cap;
> diff --git a/drivers/usb/chipidea/otg_fsm.c b/drivers/usb/chipidea/otg_fsm.c
> index 862d7cb01b92..3c2ab1ae00fc 100644
> --- a/drivers/usb/chipidea/otg_fsm.c
> +++ b/drivers/usb/chipidea/otg_fsm.c
> @@ -779,7 +779,11 @@ int ci_hdrc_otg_fsm_init(struct ci_hdrc *ci)
>  {
>  	int retval = 0;
>  
> -	ci->otg.usb_phy = ci->usb_phy;
> +	if (ci->phy)
> +		ci->otg.phy = ci->phy;
> +	else
> +		ci->otg.usb_phy = ci->usb_phy;
> +
>  	ci->otg.gadget = &ci->gadget;
>  	ci->fsm.otg = &ci->otg;
>  	ci->fsm.power_up = 1;
> diff --git a/include/linux/usb/chipidea.h b/include/linux/usb/chipidea.h
> index 57d757a1aa83..a0285623b9c1 100644
> --- a/include/linux/usb/chipidea.h
> +++ b/include/linux/usb/chipidea.h
> @@ -13,6 +13,8 @@ struct ci_hdrc_platform_data {
>  	/* offset of the capability registers */
>  	uintptr_t	 capoffset;
>  	unsigned	 power_budget;
> +	struct phy	*phy;
> +	/* old usb_phy interface */
>  	struct usb_phy	*usb_phy;
>  	enum usb_phy_interface phy_mode;
>  	unsigned long	 flags;
> -- 
> 1.9.1
> 

-- 
Best Regards,
Peter Chen

  reply	other threads:[~2014-09-16  0:07 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-09-15 10:35 [PATCH v5 0/9] usb: add support for the generic PHY framework Antoine Tenart
2014-09-15 10:35 ` [PATCH v5 1/9] usb: move the OTG state from the USB PHY to the OTG structure Antoine Tenart
2014-09-15 10:35 ` [PATCH v5 2/9] usb: rename phy to usb_phy in OTG Antoine Tenart
2014-09-15 10:35 ` [PATCH v5 3/9] usb: add support to the generic PHY framework " Antoine Tenart
2014-09-15 10:35 ` [PATCH v5 4/9] usb: rename phy to usb_phy in HCD Antoine Tenart
2014-09-15 18:09   ` Sergei Shtylyov
2014-09-16 13:53     ` Antoine Tenart
2014-09-16 14:01       ` Antoine Tenart
2014-09-15 10:35 ` [PATCH v5 5/9] usb: rename gen_phy to phy " Antoine Tenart
2014-09-15 18:12   ` Sergei Shtylyov
2014-09-15 10:35 ` [PATCH v5 6/9] usb: allow to supply the PHY in the drivers when using HCD Antoine Tenart
2014-09-15 10:35 ` [PATCH v5 7/9] usb: rename transceiver and phy to usb_phy in ChipIdea Antoine Tenart
2014-09-16  0:00   ` Peter Chen
2014-09-15 10:35 ` [PATCH v5 8/9] usb: chipidea: move usb_otg into struct ci_hdrc Antoine Tenart
2014-09-15 10:35 ` [PATCH v5 9/9] usb: chipidea: add support to the generic PHY framework in ChipIdea Antoine Tenart
2014-09-16  0:07   ` Peter Chen [this message]
2014-09-16 13:41     ` Antoine Tenart

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140916000720.GB3379@peterchendt \
    --to=peter.chen@freescale.com \
    --cc=alexandre.belloni@free-electrons.com \
    --cc=antoine.tenart@free-electrons.com \
    --cc=balbi@ti.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jszhang@marvell.com \
    --cc=kishon@ti.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=sergei.shtylyov@cogentembedded.com \
    --cc=stern@rowland.harvard.edu \
    --cc=thomas.petazzoni@free-electrons.com \
    --cc=yoshihiro.shimoda.uh@renesas.com \
    --cc=zmxu@marvell.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).