linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCHv2 0/4] Cleanup mm_populate() codepath
@ 2015-02-16 11:27 Kirill A. Shutemov
  2015-02-16 11:27 ` [PATCHv2 1/4] mm: rename FOLL_MLOCK to FOLL_POPULATE Kirill A. Shutemov
                   ` (3 more replies)
  0 siblings, 4 replies; 5+ messages in thread
From: Kirill A. Shutemov @ 2015-02-16 11:27 UTC (permalink / raw)
  To: Andrew Morton; +Cc: linux-mm, linux-kernel, Rik van Riel, Kirill A. Shutemov

While reading mlock()- and mm_populate()-related code, I've found several
things confusing. This patchset cleanup the codepath for future readers.

v2:
 - Fix typos pointed by David Rientjes;
 - Apply acks;

Kirill A. Shutemov (4):
  mm: rename FOLL_MLOCK to FOLL_POPULATE
  mm: rename __mlock_vma_pages_range() to populate_vma_page_range()
  mm: move gup() -> posix mlock() error conversion out of __mm_populate
  mm: move mm_populate()-related code to mm/gup.c

 Documentation/vm/unevictable-lru.txt |  26 +++----
 include/linux/mm.h                   |   2 +-
 mm/gup.c                             | 124 ++++++++++++++++++++++++++++++++-
 mm/huge_memory.c                     |   2 +-
 mm/internal.h                        |   2 +-
 mm/mlock.c                           | 131 +++--------------------------------
 mm/mmap.c                            |   4 +-
 7 files changed, 142 insertions(+), 149 deletions(-)

-- 
2.1.4


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2015-02-16 11:28 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-02-16 11:27 [PATCHv2 0/4] Cleanup mm_populate() codepath Kirill A. Shutemov
2015-02-16 11:27 ` [PATCHv2 1/4] mm: rename FOLL_MLOCK to FOLL_POPULATE Kirill A. Shutemov
2015-02-16 11:27 ` [PATCHv2 2/4] mm: rename __mlock_vma_pages_range() to populate_vma_page_range() Kirill A. Shutemov
2015-02-16 11:27 ` [PATCHv2 3/4] mm: move gup() -> posix mlock() error conversion out of __mm_populate Kirill A. Shutemov
2015-02-16 11:27 ` [PATCHv2 4/4] mm: move mm_populate()-related code to mm/gup.c Kirill A. Shutemov

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).