linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module
@ 2016-08-18 13:45 Javier Martinez Canillas
  2016-08-18 13:45 ` [PATCH 2/3] usb: gadget: " Javier Martinez Canillas
  2016-08-18 13:45 ` [PATCH 3/3] USB: serial: " Javier Martinez Canillas
  0 siblings, 2 replies; 7+ messages in thread
From: Javier Martinez Canillas @ 2016-08-18 13:45 UTC (permalink / raw)
  To: linux-kernel
  Cc: Javier Martinez Canillas, Stefan Koch, Alan Stern,
	Sergei Shtylyov, Chris Bainbridge, linux-usb, Geert Uytterhoeven,
	Greg Kroah-Hartman, Heiner Kallweit, Mathias Nyman

The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
built-in or as a module, use that macro instead of open coding the same.

Using the macro makes the code more readable by helping abstract away some
of the Kconfig built-in and module enable details.

Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>
---

 drivers/usb/core/hcd.c           | 2 +-
 drivers/usb/core/otg_whitelist.h | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
index d2e3f655c26f..0e2c733d20c3 100644
--- a/drivers/usb/core/hcd.c
+++ b/drivers/usb/core/hcd.c
@@ -3033,7 +3033,7 @@ EXPORT_SYMBOL_GPL(usb_hcd_platform_shutdown);
 
 /*-------------------------------------------------------------------------*/
 
-#if defined(CONFIG_USB_MON) || defined(CONFIG_USB_MON_MODULE)
+#if IS_ENABLED(CONFIG_USB_MON)
 
 const struct usb_mon_operations *mon_ops;
 
diff --git a/drivers/usb/core/otg_whitelist.h b/drivers/usb/core/otg_whitelist.h
index a95b0c989c21..085049d37d7a 100644
--- a/drivers/usb/core/otg_whitelist.h
+++ b/drivers/usb/core/otg_whitelist.h
@@ -38,7 +38,7 @@ static struct usb_device_id whitelist_table[] = {
 { USB_DEVICE(0x0525, 0xa4a2), },
 #endif
 
-#if	defined(CONFIG_USB_TEST) || defined(CONFIG_USB_TEST_MODULE)
+#if	IS_ENABLED(CONFIG_USB_TEST)
 /* gadget zero, for testing */
 { USB_DEVICE(0x0525, 0xa4a0), },
 #endif
-- 
2.5.5

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module
  2016-08-18 13:45 [PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas
@ 2016-08-18 13:45 ` Javier Martinez Canillas
  2016-08-18 13:49   ` Felipe Balbi
  2016-08-18 13:45 ` [PATCH 3/3] USB: serial: " Javier Martinez Canillas
  1 sibling, 1 reply; 7+ messages in thread
From: Javier Martinez Canillas @ 2016-08-18 13:45 UTC (permalink / raw)
  To: linux-kernel
  Cc: Javier Martinez Canillas, Greg Kroah-Hartman, linux-usb, Felipe Balbi

The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
built-in or as a module, use that macro instead of open coding the same.

Using the macro makes the code more readable by helping abstract away some
of the Kconfig built-in and module enable details.

Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>
---

 drivers/usb/gadget/udc/omap_udc.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/usb/gadget/udc/omap_udc.c b/drivers/usb/gadget/udc/omap_udc.c
index 9b7d39484ed3..a8709f9e5648 100644
--- a/drivers/usb/gadget/udc/omap_udc.c
+++ b/drivers/usb/gadget/udc/omap_udc.c
@@ -2875,7 +2875,7 @@ bad_on_1710:
 	xceiv = NULL;
 	/* "udc" is now valid */
 	pullup_disable(udc);
-#if	defined(CONFIG_USB_OHCI_HCD) || defined(CONFIG_USB_OHCI_HCD_MODULE)
+#if	IS_ENABLED(CONFIG_USB_OHCI_HCD)
 	udc->gadget.is_otg = (config->otg != 0);
 #endif
 
-- 
2.5.5

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module
  2016-08-18 13:45 [PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas
  2016-08-18 13:45 ` [PATCH 2/3] usb: gadget: " Javier Martinez Canillas
@ 2016-08-18 13:45 ` Javier Martinez Canillas
  2016-08-18 13:46   ` Felipe Balbi
  2016-08-22  7:40   ` Johan Hovold
  1 sibling, 2 replies; 7+ messages in thread
From: Javier Martinez Canillas @ 2016-08-18 13:45 UTC (permalink / raw)
  To: linux-kernel
  Cc: Javier Martinez Canillas, Greg Kroah-Hartman, linux-usb, Johan Hovold

The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
built-in or as a module, use that macro instead of open coding the same.

Using the macro makes the code more readable by helping abstract away some
of the Kconfig built-in and module enable details.

Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>
---

 drivers/usb/serial/keyspan_pda.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/usb/serial/keyspan_pda.c b/drivers/usb/serial/keyspan_pda.c
index 4f7e072e4e00..e49ad0c63ad8 100644
--- a/drivers/usb/serial/keyspan_pda.c
+++ b/drivers/usb/serial/keyspan_pda.c
@@ -30,12 +30,12 @@
 #include <linux/usb/ezusb.h>
 
 /* make a simple define to handle if we are compiling keyspan_pda or xircom support */
-#if defined(CONFIG_USB_SERIAL_KEYSPAN_PDA) || defined(CONFIG_USB_SERIAL_KEYSPAN_PDA_MODULE)
+#if IS_ENABLED(CONFIG_USB_SERIAL_KEYSPAN_PDA)
 	#define KEYSPAN
 #else
 	#undef KEYSPAN
 #endif
-#if defined(CONFIG_USB_SERIAL_XIRCOM) || defined(CONFIG_USB_SERIAL_XIRCOM_MODULE)
+#if IS_ENABLED(CONFIG_USB_SERIAL_XIRCOM)
 	#define XIRCOM
 #else
 	#undef XIRCOM
-- 
2.5.5

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module
  2016-08-18 13:45 ` [PATCH 3/3] USB: serial: " Javier Martinez Canillas
@ 2016-08-18 13:46   ` Felipe Balbi
  2016-08-18 13:47     ` Felipe Balbi
  2016-08-22  7:40   ` Johan Hovold
  1 sibling, 1 reply; 7+ messages in thread
From: Felipe Balbi @ 2016-08-18 13:46 UTC (permalink / raw)
  To: Javier Martinez Canillas, linux-kernel
  Cc: Javier Martinez Canillas, Greg Kroah-Hartman, linux-usb, Johan Hovold

[-- Attachment #1: Type: text/plain, Size: 1644 bytes --]


Hi,

Javier Martinez Canillas <javier@osg.samsung.com> writes:
> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
>
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.
>
> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>

Assuming this is going through trivial tree:

Acked-by: Felipe Balbi <felipe.balbi@linux.intel.com>

thanks

> ---
>
>  drivers/usb/serial/keyspan_pda.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/usb/serial/keyspan_pda.c b/drivers/usb/serial/keyspan_pda.c
> index 4f7e072e4e00..e49ad0c63ad8 100644
> --- a/drivers/usb/serial/keyspan_pda.c
> +++ b/drivers/usb/serial/keyspan_pda.c
> @@ -30,12 +30,12 @@
>  #include <linux/usb/ezusb.h>
>  
>  /* make a simple define to handle if we are compiling keyspan_pda or xircom support */
> -#if defined(CONFIG_USB_SERIAL_KEYSPAN_PDA) || defined(CONFIG_USB_SERIAL_KEYSPAN_PDA_MODULE)
> +#if IS_ENABLED(CONFIG_USB_SERIAL_KEYSPAN_PDA)
>  	#define KEYSPAN
>  #else
>  	#undef KEYSPAN
>  #endif
> -#if defined(CONFIG_USB_SERIAL_XIRCOM) || defined(CONFIG_USB_SERIAL_XIRCOM_MODULE)
> +#if IS_ENABLED(CONFIG_USB_SERIAL_XIRCOM)
>  	#define XIRCOM
>  #else
>  	#undef XIRCOM
> -- 
> 2.5.5
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-usb" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

-- 
balbi

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 800 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module
  2016-08-18 13:46   ` Felipe Balbi
@ 2016-08-18 13:47     ` Felipe Balbi
  0 siblings, 0 replies; 7+ messages in thread
From: Felipe Balbi @ 2016-08-18 13:47 UTC (permalink / raw)
  To: Javier Martinez Canillas, linux-kernel
  Cc: Javier Martinez Canillas, Greg Kroah-Hartman, linux-usb, Johan Hovold

[-- Attachment #1: Type: text/plain, Size: 678 bytes --]


Hi,

Felipe Balbi <felipe.balbi@linux.intel.com> writes:
> Hi,
>
> Javier Martinez Canillas <javier@osg.samsung.com> writes:
>> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
>> built-in or as a module, use that macro instead of open coding the same.
>>
>> Using the macro makes the code more readable by helping abstract away some
>> of the Kconfig built-in and module enable details.
>>
>> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>
>
> Assuming this is going through trivial tree:
>
> Acked-by: Felipe Balbi <felipe.balbi@linux.intel.com>

sorry, this was supposed to be for omap_udc patch.

-- 
balbi

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 800 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module
  2016-08-18 13:45 ` [PATCH 2/3] usb: gadget: " Javier Martinez Canillas
@ 2016-08-18 13:49   ` Felipe Balbi
  0 siblings, 0 replies; 7+ messages in thread
From: Felipe Balbi @ 2016-08-18 13:49 UTC (permalink / raw)
  To: Javier Martinez Canillas, linux-kernel
  Cc: Javier Martinez Canillas, Greg Kroah-Hartman, linux-usb

[-- Attachment #1: Type: text/plain, Size: 1331 bytes --]

Javier Martinez Canillas <javier@osg.samsung.com> writes:

> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
>
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.
>
> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>

Acked-by: Felipe Balbi <felipe.balbi@linux.intel.com>

> ---
>
>  drivers/usb/gadget/udc/omap_udc.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/usb/gadget/udc/omap_udc.c b/drivers/usb/gadget/udc/omap_udc.c
> index 9b7d39484ed3..a8709f9e5648 100644
> --- a/drivers/usb/gadget/udc/omap_udc.c
> +++ b/drivers/usb/gadget/udc/omap_udc.c
> @@ -2875,7 +2875,7 @@ bad_on_1710:
>  	xceiv = NULL;
>  	/* "udc" is now valid */
>  	pullup_disable(udc);
> -#if	defined(CONFIG_USB_OHCI_HCD) || defined(CONFIG_USB_OHCI_HCD_MODULE)
> +#if	IS_ENABLED(CONFIG_USB_OHCI_HCD)
>  	udc->gadget.is_otg = (config->otg != 0);
>  #endif
>  
> -- 
> 2.5.5
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-usb" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

-- 
balbi

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 800 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module
  2016-08-18 13:45 ` [PATCH 3/3] USB: serial: " Javier Martinez Canillas
  2016-08-18 13:46   ` Felipe Balbi
@ 2016-08-22  7:40   ` Johan Hovold
  1 sibling, 0 replies; 7+ messages in thread
From: Johan Hovold @ 2016-08-22  7:40 UTC (permalink / raw)
  To: Javier Martinez Canillas
  Cc: linux-kernel, Greg Kroah-Hartman, linux-usb, Johan Hovold

On Thu, Aug 18, 2016 at 09:45:06AM -0400, Javier Martinez Canillas wrote:
> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
> 
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.
> 
> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>

Now applied, thanks.

Johan

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2016-08-22  7:40 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-18 13:45 [PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas
2016-08-18 13:45 ` [PATCH 2/3] usb: gadget: " Javier Martinez Canillas
2016-08-18 13:49   ` Felipe Balbi
2016-08-18 13:45 ` [PATCH 3/3] USB: serial: " Javier Martinez Canillas
2016-08-18 13:46   ` Felipe Balbi
2016-08-18 13:47     ` Felipe Balbi
2016-08-22  7:40   ` Johan Hovold

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).