linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v7 00/16] mtd: nand: denali: Denali NAND IP improvements
@ 2017-06-13 13:45 Masahiro Yamada
  2017-06-13 13:45 ` [PATCH v7 01/16] mtd: nand: denali: set NAND_ECC_CUSTOM_PAGE_ACCESS Masahiro Yamada
                   ` (16 more replies)
  0 siblings, 17 replies; 19+ messages in thread
From: Masahiro Yamada @ 2017-06-13 13:45 UTC (permalink / raw)
  To: linux-mtd
  Cc: Enrico Jorns, Artem Bityutskiy, Dinh Nguyen, Boris Brezillon,
	Marek Vasut, David Woodhouse, Masami Hiramatsu, Chuanxiao Dong,
	Jassi Brar, Masahiro Yamada, Cyrille Pitchen, linux-kernel,
	Brian Norris, Richard Weinberger


This patch series intends to solve various problems.

[1] The driver just retrieves the OOB area as-is
    whereas the controller uses syndrome page layout.
[2] ONFi devices are not working
[3] It can not read Bad Block Marker

Outstanding changes are:
 - Fix raw/oob callbacks for syndrome page layout
 - Implement setup_data_interface() callback
 - Fix/implement more commands for ONFi devices
 - Allow to skip the driver internal bounce buffer
 - Support PIO in case DMA is not supported
 - Switch from ->cmdfunc over to ->cmd_ctrl

18 patches were merged by v2.
11 patches were merged by v3.
2 patches were merged by v4.
5 patches were merged by v5.
Here is the rest of the series.

v1: https://lkml.org/lkml/2016/11/26/144
v2: https://lkml.org/lkml/2017/3/22/804
v3: https://lkml.org/lkml/2017/3/30/90
v4: https://lkml.org/lkml/2017/6/5/1005


Masahiro Yamada (16):
  mtd: nand: denali: set NAND_ECC_CUSTOM_PAGE_ACCESS
  mtd: nand: denali: remove unneeded find_valid_banks()
  mtd: nand: denali: handle timing parameters by setup_data_interface()
  mtd: nand: denali: rework interrupt handling
  mtd: nand: denali: switch over to cmd_ctrl instead of cmdfunc
  mtd: nand: denali: fix bank reset function to detect the number of
    chips
  mtd: nand: denali: use interrupt instead of polling for bank reset
  mtd: nand: denali: propagate page to helpers via function argument
  mtd: nand: denali: merge struct nand_buf into struct denali_nand_info
  mtd: nand: denali: use flag instead of register macro for direction
  mtd: nand: denali: fix raw and oob accessors for syndrome page layout
  mtd: nand: denali: support hardware-assisted erased page detection
  mtd: nand: denali: skip driver internal bounce buffer when possible
  mtd: nand: denali: use non-managed kmalloc() for DMA buffer
  mtd: nand: denali: enable bad block table scan
  mtd: nand: denali: avoid magic numbers and rename for clarification

 drivers/mtd/nand/denali.c     | 1724 ++++++++++++++++++-----------------------
 drivers/mtd/nand/denali.h     |   63 +-
 drivers/mtd/nand/denali_dt.c  |   15 +-
 drivers/mtd/nand/denali_pci.c |   22 +-
 4 files changed, 806 insertions(+), 1018 deletions(-)

-- 
2.7.4

^ permalink raw reply	[flat|nested] 19+ messages in thread

end of thread, other threads:[~2017-06-20  7:28 UTC | newest]

Thread overview: 19+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-06-13 13:45 [PATCH v7 00/16] mtd: nand: denali: Denali NAND IP improvements Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 01/16] mtd: nand: denali: set NAND_ECC_CUSTOM_PAGE_ACCESS Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 02/16] mtd: nand: denali: remove unneeded find_valid_banks() Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 03/16] mtd: nand: denali: handle timing parameters by setup_data_interface() Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 04/16] mtd: nand: denali: rework interrupt handling Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 05/16] mtd: nand: denali: switch over to cmd_ctrl instead of cmdfunc Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 06/16] mtd: nand: denali: fix bank reset function to detect the number of chips Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 07/16] mtd: nand: denali: use interrupt instead of polling for bank reset Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 08/16] mtd: nand: denali: propagate page to helpers via function argument Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 09/16] mtd: nand: denali: merge struct nand_buf into struct denali_nand_info Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 10/16] mtd: nand: denali: use flag instead of register macro for direction Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 11/16] mtd: nand: denali: fix raw and oob accessors for syndrome page layout Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 12/16] mtd: nand: denali: support hardware-assisted erased page detection Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 13/16] mtd: nand: denali: skip driver internal bounce buffer when possible Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 14/16] mtd: nand: denali: use non-managed kmalloc() for DMA buffer Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 15/16] mtd: nand: denali: enable bad block table scan Masahiro Yamada
2017-06-13 13:45 ` [PATCH v7 16/16] mtd: nand: denali: avoid magic numbers and rename for clarification Masahiro Yamada
2017-06-16  5:38   ` Masahiro Yamada
2017-06-20  7:28 ` [PATCH v7 00/16] mtd: nand: denali: Denali NAND IP improvements Boris Brezillon

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).