linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/2] ASoC: stm32: spdifrx: change dai name
@ 2018-01-31 16:47 Olivier Moysan
  2018-01-31 16:47 ` [PATCH 1/2] ASoC: stm32: spdifrx: fix typo in function name Olivier Moysan
  2018-01-31 16:47 ` [PATCH 2/2] ASoC: stm32: spdifrx: Use default dai name Olivier Moysan
  0 siblings, 2 replies; 5+ messages in thread
From: Olivier Moysan @ 2018-01-31 16:47 UTC (permalink / raw)
  To: lgirdwood, broonie, perex, tiwai, mcoquelin.stm32,
	alexandre.torgue, alsa-devel, linux-arm-kernel, kernel,
	linux-kernel, olivier.moysan
  Cc: arnaud.pouliquen, benjamin.gaignard

This patchset changes spdifrx dai name and fixes a typo issue.

Olivier Moysan (2):
  ASoC: stm32: spdifrx: fix typo in function name.
  ASoC: stm32: spdifrx: Use default dai name

 sound/soc/stm/stm32_spdifrx.c | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

-- 
1.9.1

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [PATCH 1/2] ASoC: stm32: spdifrx: fix typo in function name.
  2018-01-31 16:47 [PATCH 0/2] ASoC: stm32: spdifrx: change dai name Olivier Moysan
@ 2018-01-31 16:47 ` Olivier Moysan
  2018-02-12 12:27   ` Applied "ASoC: stm32: spdifrx: fix typo in function name." to the asoc tree Mark Brown
  2018-01-31 16:47 ` [PATCH 2/2] ASoC: stm32: spdifrx: Use default dai name Olivier Moysan
  1 sibling, 1 reply; 5+ messages in thread
From: Olivier Moysan @ 2018-01-31 16:47 UTC (permalink / raw)
  To: lgirdwood, broonie, perex, tiwai, mcoquelin.stm32,
	alexandre.torgue, alsa-devel, linux-arm-kernel, kernel,
	linux-kernel, olivier.moysan
  Cc: arnaud.pouliquen, benjamin.gaignard

Fix function name prefix for naming consistency.

Signed-off-by: olivier moysan <olivier.moysan@st.com>
---
 sound/soc/stm/stm32_spdifrx.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/sound/soc/stm/stm32_spdifrx.c b/sound/soc/stm/stm32_spdifrx.c
index b9bdefc..42ad2ae 100644
--- a/sound/soc/stm/stm32_spdifrx.c
+++ b/sound/soc/stm/stm32_spdifrx.c
@@ -858,8 +858,8 @@ static void stm32_spdifrx_shutdown(struct snd_pcm_substream *substream,
 	{}
 };
 
-static int stm_spdifrx_parse_of(struct platform_device *pdev,
-				struct stm32_spdifrx_data *spdifrx)
+static int stm32_spdifrx_parse_of(struct platform_device *pdev,
+				  struct stm32_spdifrx_data *spdifrx)
 {
 	struct device_node *np = pdev->dev.of_node;
 	const struct of_device_id *of_id;
@@ -914,7 +914,7 @@ static int stm32_spdifrx_probe(struct platform_device *pdev)
 
 	platform_set_drvdata(pdev, spdifrx);
 
-	ret = stm_spdifrx_parse_of(pdev, spdifrx);
+	ret = stm32_spdifrx_parse_of(pdev, spdifrx);
 	if (ret)
 		return ret;
 
-- 
1.9.1

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* [PATCH 2/2] ASoC: stm32: spdifrx: Use default dai name
  2018-01-31 16:47 [PATCH 0/2] ASoC: stm32: spdifrx: change dai name Olivier Moysan
  2018-01-31 16:47 ` [PATCH 1/2] ASoC: stm32: spdifrx: fix typo in function name Olivier Moysan
@ 2018-01-31 16:47 ` Olivier Moysan
  2018-02-12 12:27   ` Applied "ASoC: stm32: spdifrx: Use default dai name" to the asoc tree Mark Brown
  1 sibling, 1 reply; 5+ messages in thread
From: Olivier Moysan @ 2018-01-31 16:47 UTC (permalink / raw)
  To: lgirdwood, broonie, perex, tiwai, mcoquelin.stm32,
	alexandre.torgue, alsa-devel, linux-arm-kernel, kernel,
	linux-kernel, olivier.moysan
  Cc: arnaud.pouliquen, benjamin.gaignard

Use dai name provided by framework from dev_name() function.

Signed-off-by: olivier moysan <olivier.moysan@st.com>
---
 sound/soc/stm/stm32_spdifrx.c | 1 -
 1 file changed, 1 deletion(-)

diff --git a/sound/soc/stm/stm32_spdifrx.c b/sound/soc/stm/stm32_spdifrx.c
index 42ad2ae..373df4f 100644
--- a/sound/soc/stm/stm32_spdifrx.c
+++ b/sound/soc/stm/stm32_spdifrx.c
@@ -819,7 +819,6 @@ static void stm32_spdifrx_shutdown(struct snd_pcm_substream *substream,
 
 static struct snd_soc_dai_driver stm32_spdifrx_dai[] = {
 	{
-		.name = "spdifrx-capture-cpu-dai",
 		.probe = stm32_spdifrx_dai_probe,
 		.capture = {
 			.stream_name = "CPU-Capture",
-- 
1.9.1

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Applied "ASoC: stm32: spdifrx: Use default dai name" to the asoc tree
  2018-01-31 16:47 ` [PATCH 2/2] ASoC: stm32: spdifrx: Use default dai name Olivier Moysan
@ 2018-02-12 12:27   ` Mark Brown
  0 siblings, 0 replies; 5+ messages in thread
From: Mark Brown @ 2018-02-12 12:27 UTC (permalink / raw)
  To: olivier moysan
  Cc: Mark Brown, lgirdwood, broonie, perex, tiwai, mcoquelin.stm32,
	alexandre.torgue, alsa-devel, linux-arm-kernel, kernel,
	linux-kernel, olivier.moysan, arnaud.pouliquen,
	benjamin.gaignard, alsa-devel

The patch

   ASoC: stm32: spdifrx: Use default dai name

has been applied to the asoc tree at

   https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git 

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.  

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark

>From 037002b14b7ae217aa79b260228ba51afc516a8c Mon Sep 17 00:00:00 2001
From: olivier moysan <olivier.moysan@st.com>
Date: Wed, 31 Jan 2018 17:47:03 +0100
Subject: [PATCH] ASoC: stm32: spdifrx: Use default dai name

Use dai name provided by framework from dev_name() function.

Signed-off-by: olivier moysan <olivier.moysan@st.com>
Signed-off-by: Mark Brown <broonie@kernel.org>
---
 sound/soc/stm/stm32_spdifrx.c | 1 -
 1 file changed, 1 deletion(-)

diff --git a/sound/soc/stm/stm32_spdifrx.c b/sound/soc/stm/stm32_spdifrx.c
index 42ad2ae22d21..373df4f24be1 100644
--- a/sound/soc/stm/stm32_spdifrx.c
+++ b/sound/soc/stm/stm32_spdifrx.c
@@ -819,7 +819,6 @@ static const struct snd_soc_dai_ops stm32_spdifrx_pcm_dai_ops = {
 
 static struct snd_soc_dai_driver stm32_spdifrx_dai[] = {
 	{
-		.name = "spdifrx-capture-cpu-dai",
 		.probe = stm32_spdifrx_dai_probe,
 		.capture = {
 			.stream_name = "CPU-Capture",
-- 
2.16.1

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Applied "ASoC: stm32: spdifrx: fix typo in function name." to the asoc tree
  2018-01-31 16:47 ` [PATCH 1/2] ASoC: stm32: spdifrx: fix typo in function name Olivier Moysan
@ 2018-02-12 12:27   ` Mark Brown
  0 siblings, 0 replies; 5+ messages in thread
From: Mark Brown @ 2018-02-12 12:27 UTC (permalink / raw)
  To: olivier moysan
  Cc: Mark Brown, lgirdwood, broonie, perex, tiwai, mcoquelin.stm32,
	alexandre.torgue, alsa-devel, linux-arm-kernel, kernel,
	linux-kernel, olivier.moysan, arnaud.pouliquen,
	benjamin.gaignard, alsa-devel

The patch

   ASoC: stm32: spdifrx: fix typo in function name.

has been applied to the asoc tree at

   https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git 

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.  

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark

>From b9aa4716281247960e009dd55c38bcc4c2e4cb94 Mon Sep 17 00:00:00 2001
From: olivier moysan <olivier.moysan@st.com>
Date: Wed, 31 Jan 2018 17:47:02 +0100
Subject: [PATCH] ASoC: stm32: spdifrx: fix typo in function name.

Fix function name prefix for naming consistency.

Signed-off-by: olivier moysan <olivier.moysan@st.com>
Signed-off-by: Mark Brown <broonie@kernel.org>
---
 sound/soc/stm/stm32_spdifrx.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/sound/soc/stm/stm32_spdifrx.c b/sound/soc/stm/stm32_spdifrx.c
index b9bdefcd3e10..42ad2ae22d21 100644
--- a/sound/soc/stm/stm32_spdifrx.c
+++ b/sound/soc/stm/stm32_spdifrx.c
@@ -858,8 +858,8 @@ static const struct of_device_id stm32_spdifrx_ids[] = {
 	{}
 };
 
-static int stm_spdifrx_parse_of(struct platform_device *pdev,
-				struct stm32_spdifrx_data *spdifrx)
+static int stm32_spdifrx_parse_of(struct platform_device *pdev,
+				  struct stm32_spdifrx_data *spdifrx)
 {
 	struct device_node *np = pdev->dev.of_node;
 	const struct of_device_id *of_id;
@@ -914,7 +914,7 @@ static int stm32_spdifrx_probe(struct platform_device *pdev)
 
 	platform_set_drvdata(pdev, spdifrx);
 
-	ret = stm_spdifrx_parse_of(pdev, spdifrx);
+	ret = stm32_spdifrx_parse_of(pdev, spdifrx);
 	if (ret)
 		return ret;
 
-- 
2.16.1

^ permalink raw reply related	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2018-02-12 12:28 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-01-31 16:47 [PATCH 0/2] ASoC: stm32: spdifrx: change dai name Olivier Moysan
2018-01-31 16:47 ` [PATCH 1/2] ASoC: stm32: spdifrx: fix typo in function name Olivier Moysan
2018-02-12 12:27   ` Applied "ASoC: stm32: spdifrx: fix typo in function name." to the asoc tree Mark Brown
2018-01-31 16:47 ` [PATCH 2/2] ASoC: stm32: spdifrx: Use default dai name Olivier Moysan
2018-02-12 12:27   ` Applied "ASoC: stm32: spdifrx: Use default dai name" to the asoc tree Mark Brown

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).