linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Atish Patra <atish.patra@wdc.com>
To: palmer@sifive.com, linux-riscv@lists.infradead.org
Cc: mark.rutland@arm.com, hch@infradead.org, anup@brainfault.org,
	atish.patra@wdc.com, tglx@linutronix.de,
	linux-kernel@vger.kernel.org, Damien.LeMoal@wdc.com,
	marc.zyngier@arm.com, jeremy.linton@arm.com,
	gregkh@linuxfoundation.org, jason@lakedaemon.net,
	catalin.marinas@arm.com, dmitriy@oss-tech.org,
	ard.biesheuvel@linaro.org
Subject: [PATCH v4 00/12] SMP cleanup and new features
Date: Tue, 11 Sep 2018 13:05:27 -0700	[thread overview]
Message-ID: <1536696339-15204-1-git-send-email-atish.patra@wdc.com> (raw)

This patch series has updated the assorted cleanup series by palmer.
The original cleanup patch series can be found here.
http://lists.infradead.org/pipermail/linux-riscv/2018-August/001232.html

It also implemented decoupling linux logical cpu ids from hardware cpu id.
Some of the work has been inspired from ARM64.
Tested on QEMU & HighFive Unleashed board with/without SMP enabled.

Both the patch series have been combined to avoid conflicts as a lot
of common code is changed in both the series. I have mostly addressed
review comments and fixed checkpatch errors from palmer's series.

v1->v2:

1. Dropped cpu_ops patch.
2. Moved back IRQ cause definitions to irq.h
3. Keep boot cpu hart id and assign zero as the cpu id for boot cpu.
4. Renamed cpu id and hart id correctly.

v2-v3:

1. Added cleanup patches from palmer.
2. Moved the hotplug related functions to it's own file.
3. Updated stub functions as per coding guidelines.
4. Renamed __cpu_logical_map to a more coherent name.

v3-v4:

1. Addressed minor typos in commit text and code.
2. Included Anup's do_IRQ patch.
3. Dropped cpu hotplug patch. As there are some concerns
   about approach, I will submit it separately.

Anup Patel (1):
  RISC-V: No need to pass scause as arg to do_IRQ()

Atish Patra (4):
  RISC-V: Disable preemption before enabling interrupts
  RISC-V: User WRITE_ONCE instead of direct access
  RISC-V: Add logical CPU indexing for RISC-V
  RISC-V: Use Linux logical cpu number instead of hartid

Palmer Dabbelt (7):
  RISC-V: Don't set cacheinfo.{physical_line_partition,attributes}
  RISC-V: Filter ISA and MMU values in cpuinfo
  RISC-V: Comment on the TLB flush in smp_callin()
  RISC-V: Provide a cleaner raw_smp_processor_id()
  RISC-V: Rename riscv_of_processor_hart to riscv_of_processor_hartid
  RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu
  RISC-V: Use mmgrab()

 arch/riscv/include/asm/processor.h |  2 +-
 arch/riscv/include/asm/smp.h       | 38 ++++++++++++-----
 arch/riscv/include/asm/tlbflush.h  | 16 ++++++--
 arch/riscv/kernel/cacheinfo.c      |  7 ----
 arch/riscv/kernel/cpu.c            | 83 ++++++++++++++++++++++++++++++++------
 arch/riscv/kernel/entry.S          |  1 -
 arch/riscv/kernel/head.S           |  4 +-
 arch/riscv/kernel/irq.c            |  4 +-
 arch/riscv/kernel/setup.c          | 10 +++++
 arch/riscv/kernel/smp.c            | 43 +++++++++++++++-----
 arch/riscv/kernel/smpboot.c        | 46 ++++++++++++++-------
 drivers/clocksource/riscv_timer.c  | 12 ++++--
 drivers/irqchip/irq-sifive-plic.c  | 10 +++--
 13 files changed, 207 insertions(+), 69 deletions(-)

-- 
2.7.4


             reply	other threads:[~2018-09-11 20:05 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-09-11 20:05 Atish Patra [this message]
2018-09-11 20:05 ` [PATCH v4 01/12] RISC-V: No need to pass scause as arg to do_IRQ() Atish Patra
2018-09-11 20:05 ` [PATCH v4 02/12] RISC-V: Don't set cacheinfo.{physical_line_partition,attributes} Atish Patra
2018-09-11 20:05 ` [PATCH v4 03/12] RISC-V: Filter ISA and MMU values in cpuinfo Atish Patra
2018-09-11 20:05 ` [PATCH v4 04/12] RISC-V: Comment on the TLB flush in smp_callin() Atish Patra
2018-09-11 20:05 ` [PATCH v4 05/12] RISC-V: Disable preemption before enabling interrupts Atish Patra
2018-09-11 20:05 ` [PATCH v4 06/12] RISC-V: Provide a cleaner raw_smp_processor_id() Atish Patra
2018-09-11 20:05 ` [PATCH v4 07/12] RISC-V: Rename riscv_of_processor_hart to riscv_of_processor_hartid Atish Patra
2018-09-11 20:05 ` [PATCH v4 08/12] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu Atish Patra
2018-09-11 20:05 ` [PATCH v4 09/12] RISC-V: Use mmgrab() Atish Patra
2018-09-11 20:05 ` [PATCH v4 10/12] RISC-V: User WRITE_ONCE instead of direct access Atish Patra
2018-09-11 20:32   ` Andreas Schwab
2018-09-13 18:21     ` Atish Patra
2018-09-11 20:05 ` [PATCH v4 11/12] RISC-V: Add logical CPU indexing for RISC-V Atish Patra
2018-09-11 20:05 ` [PATCH v4 12/12] RISC-V: Use Linux logical cpu number instead of hartid Atish Patra

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1536696339-15204-1-git-send-email-atish.patra@wdc.com \
    --to=atish.patra@wdc.com \
    --cc=Damien.LeMoal@wdc.com \
    --cc=anup@brainfault.org \
    --cc=ard.biesheuvel@linaro.org \
    --cc=catalin.marinas@arm.com \
    --cc=dmitriy@oss-tech.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=hch@infradead.org \
    --cc=jason@lakedaemon.net \
    --cc=jeremy.linton@arm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-riscv@lists.infradead.org \
    --cc=marc.zyngier@arm.com \
    --cc=mark.rutland@arm.com \
    --cc=palmer@sifive.com \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).