linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [RFC PATCH 0/6] Rename functions to match their entry points
@ 2019-07-10 12:36 Janusz Krzysztofik
  2019-07-10 12:36 ` [RFC PATCH 1/6] drm/i915: Rename "_load"/"_unload" to match PCI " Janusz Krzysztofik
                   ` (6 more replies)
  0 siblings, 7 replies; 9+ messages in thread
From: Janusz Krzysztofik @ 2019-07-10 12:36 UTC (permalink / raw)
  To: Chris Wilson
  Cc: Jani Nikula, Joonas Lahtinen, Rodrigo Vivi, David Airlie,
	Daniel Vetter, Michał Wajdeczko, intel-gfx, dri-devel,
	linux-kernel, Janusz Krzysztofik

Need for this was identified while working on split of driver unbind
path into _remove() and _release() parts.  Consistency in function
naming has been recognized as helpful when trying to work out which
phase the code is in.

What I'm still not sure about is desired depth of that modification -
how deep should we go down with renaming to not override meaningfull
function names.  Please advise if you think still more deep renaming
makes sense.

Thanks,
Janusz

Janusz Krzysztofik (6):
  drm/i915: Rename "_load"/"_unload" to match PCI entry points
  drm/i915: Replace "_load" with "_probe" consequently
  drm/i915: Propagate "_release" function name suffix down
  drm/i915: Propagate "_remove" function name suffix down
  drm/i915: Propagate "_probe" function name suffix down
  drm/i915: Rename "inject_load_failure" module parameter

 drivers/gpu/drm/i915/display/intel_bios.c     |   4 +-
 drivers/gpu/drm/i915/display/intel_bios.h     |   2 +-
 .../gpu/drm/i915/display/intel_connector.c    |   2 +-
 drivers/gpu/drm/i915/display/intel_display.c  |   2 +-
 .../drm/i915/display/intel_display_power.c    |   6 +-
 .../drm/i915/display/intel_display_power.h    |   2 +-
 drivers/gpu/drm/i915/gt/intel_engine_cs.c     |   2 +-
 drivers/gpu/drm/i915/i915_drv.c               | 111 +++++++++---------
 drivers/gpu/drm/i915/i915_drv.h               |  20 ++--
 drivers/gpu/drm/i915/i915_gem.c               |  12 +-
 drivers/gpu/drm/i915/i915_gem_gtt.c           |   4 +-
 drivers/gpu/drm/i915/i915_gem_gtt.h           |   2 +-
 drivers/gpu/drm/i915/i915_params.c            |   2 +-
 drivers/gpu/drm/i915/i915_params.h            |   2 +-
 drivers/gpu/drm/i915/i915_pci.c               |   6 +-
 drivers/gpu/drm/i915/intel_gvt.c              |   7 +-
 drivers/gpu/drm/i915/intel_gvt.h              |   4 +-
 drivers/gpu/drm/i915/intel_runtime_pm.c       |   2 +-
 drivers/gpu/drm/i915/intel_runtime_pm.h       |   2 +-
 drivers/gpu/drm/i915/intel_uncore.c           |   2 +-
 drivers/gpu/drm/i915/intel_wopcm.c            |   2 +-
 21 files changed, 100 insertions(+), 98 deletions(-)

-- 
2.21.0


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2019-07-10 12:55 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-07-10 12:36 [RFC PATCH 0/6] Rename functions to match their entry points Janusz Krzysztofik
2019-07-10 12:36 ` [RFC PATCH 1/6] drm/i915: Rename "_load"/"_unload" to match PCI " Janusz Krzysztofik
2019-07-10 12:36 ` [RFC PATCH 2/6] drm/i915: Replace "_load" with "_probe" consequently Janusz Krzysztofik
2019-07-10 12:36 ` [RFC PATCH 3/6] drm/i915: Propagate "_release" function name suffix down Janusz Krzysztofik
2019-07-10 12:36 ` [RFC PATCH 4/6] drm/i915: Propagate "_remove" " Janusz Krzysztofik
2019-07-10 12:36 ` [RFC PATCH 5/6] drm/i915: Propagate "_probe" " Janusz Krzysztofik
2019-07-10 12:36 ` [RFC PATCH 6/6] drm/i915: Rename "inject_load_failure" module parameter Janusz Krzysztofik
2019-07-10 12:47 ` [RFC PATCH 0/6] Rename functions to match their entry points Chris Wilson
2019-07-10 12:54   ` Janusz Krzysztofik

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).