linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/4] ufs: core: Always read the descriptors with max length
@ 2022-10-31 16:25 Arthur Simchaev
  2022-10-31 16:25 ` [PATCH 1/4] ufs: core: Remove redundant wb check Arthur Simchaev
                   ` (3 more replies)
  0 siblings, 4 replies; 7+ messages in thread
From: Arthur Simchaev @ 2022-10-31 16:25 UTC (permalink / raw)
  To: martin.petersen
  Cc: avri.altman, Avi.Shchislowski, beanhuo, linux-kernel, linux-scsi,
	Arthur Simchaev

Read any descriptor with a maximum size of QUERY_DESC_MAX_SIZE.
According to the spec the device rerurns the actual size.
Thus can improve code readability and save CPU cycles.
While at it, cleanup few leftovers around the descriptor size parameter.

Suggested-by: Bean Huo <beanhuo@micron.com>

Arthur Simchaev (4):
  ufs:core: Remove redundant wb check
  ufs:core: Remove redundant desc_size variable from hba
  ufs: core: Remove len parameter from ufshcd_set_active_icc_lvl
  ufs: core: Remove ufshcd_map_desc_id_to_length function

 drivers/ufs/core/ufs_bsg.c     |   7 +--
 drivers/ufs/core/ufshcd-priv.h |   3 --
 drivers/ufs/core/ufshcd.c      | 100 ++++++++++-------------------------------
 drivers/ufs/core/ufshpb.c      |   5 +--
 include/ufs/ufshcd.h           |   1 -
 5 files changed, 26 insertions(+), 90 deletions(-)

-- 
2.7.4


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2022-11-01  8:45 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-10-31 16:25 [PATCH 0/4] ufs: core: Always read the descriptors with max length Arthur Simchaev
2022-10-31 16:25 ` [PATCH 1/4] ufs: core: Remove redundant wb check Arthur Simchaev
2022-10-31 16:25 ` [PATCH 2/4] ufs: core: Remove redundant desc_size variable from hba Arthur Simchaev
2022-10-31 16:25 ` [PATCH 3/4] ufs: core: Remove len parameter from ufshcd_set_active_icc_lvl Arthur Simchaev
2022-10-31 16:25 ` [PATCH 4/4] ufs: core: Remove ufshcd_map_desc_id_to_length function Arthur Simchaev
2022-11-01  1:51   ` kernel test robot
2022-11-01  8:45   ` kernel test robot

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).