linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* (no subject)
@ 2006-01-18  6:48 Ian Kent
  0 siblings, 0 replies; only message in thread
From: Ian Kent @ 2006-01-18  6:48 UTC (permalink / raw)
  To: Andrew Morton; +Cc: Kernel Mailing List, linux-fsdevel, autofs

This is the first set of patches for autofs in moving toward a
kernel <-> userspace communication protocol update.

The changes implemented in the patch set are:

1) lookup-cleanup - cleanup of whitespace and formating changes.
2) readdir-cleanup - changes readdir routines to use the cursor
   based routines in libfs.c.
3) failed-lookup - fix stale dentrys stopping mounts.
4) expire-cleanup - change return values and names of two functions
   to aid code readability.
5) expire-traversal-cleanup - simplify expire by adapting it to
   use the "next_entry" function from namespace.c.
6) expire-tree-false-negative - fix an expire case which returns
   busy on tree mounts when they are not.
7) expire-not-busy-only - alter expire semantics to match that
   needed for a rework of autofs direct mounts.
8) remove-update_atime - remove update of atime in favour of
   letting the VFS update it.
9) add-show_options - add show_options method to display autofs4
   mount options in the proc filesystem.
10) waitq-cleanup - whitespace cleanup of waitq.c
11) rename-simple_empty_nolock - rename function according to
   kernel conventions.
12) may_umount-to-boolean - change may_umount* functions to
  boolean to aid code readability.


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2006-01-18  6:50 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2006-01-18  6:48 Ian Kent

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).