linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* 2.6.24 x86 apm module name change not in Kconfig
@ 2008-02-02 21:56 A.E.Lawrence
  2008-02-03 10:32 ` [PATCH] x86: restore correct module name for apm Sam Ravnborg
  0 siblings, 1 reply; 6+ messages in thread
From: A.E.Lawrence @ 2008-02-02 21:56 UTC (permalink / raw)
  To: linux-kernel

Legacy i386 box failed to shutdown under 2.6.24 because it tried to load
module apm rather than apm_32.

If it is intended that apm_32 not be aliased as apm, then
 arch/x86/Kconfig
which currently says "module will be called apm."
needs to be updated to match.

ael

^ permalink raw reply	[flat|nested] 6+ messages in thread

* [PATCH] x86: restore correct module name for apm
  2008-02-02 21:56 2.6.24 x86 apm module name change not in Kconfig A.E.Lawrence
@ 2008-02-03 10:32 ` Sam Ravnborg
  2008-02-03 11:25   ` Ingo Molnar
                     ` (2 more replies)
  0 siblings, 3 replies; 6+ messages in thread
From: Sam Ravnborg @ 2008-02-03 10:32 UTC (permalink / raw)
  To: A.E.Lawrence, Ingo Molnar; +Cc: linux-kernel

The apm module were renamed to apm_32 during the merge of 32 and 64 bit x86 which
is unfortunate.
As apm is 32 bit specific we like to keep the _32 in the filename
but the module should be named apm.

Fix this in the Makefile.
Reported by "A.E.Lawrence" <lawrence_a_e@ntlworld.com>

Signed-off-by: Sam Ravnborg <sam@ravnborg.org>
Cc: Cc: Ingo Molnar <mingo@elte.hu>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: "H. Peter Anvin" <hpa@zytor.com>
Cc: "A.E.Lawrence" <lawrence_a_e@ntlworld.com>
---

build tested only but obviously correct.

	Sam

diff --git a/arch/x86/kernel/Makefile b/arch/x86/kernel/Makefile
index 6f81300..f080635 100644
--- a/arch/x86/kernel/Makefile
+++ b/arch/x86/kernel/Makefile
@@ -37,7 +37,8 @@ obj-$(CONFIG_X86_MSR)		+= msr.o
 obj-$(CONFIG_X86_CPUID)		+= cpuid.o
 obj-$(CONFIG_MICROCODE)		+= microcode.o
 obj-$(CONFIG_PCI)		+= early-quirks.o
-obj-$(CONFIG_APM)		+= apm_32.o
+apm-y				:= apm_32.o
+obj-$(CONFIG_APM)		+= apm.o
 obj-$(CONFIG_X86_SMP)		+= smp_$(BITS).o smpboot_$(BITS).o tsc_sync.o
 obj-$(CONFIG_X86_32_SMP)	+= smpcommon_32.o
 obj-$(CONFIG_X86_64_SMP)	+= smp_64.o smpboot_64.o tsc_sync.o

^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH] x86: restore correct module name for apm
  2008-02-03 10:32 ` [PATCH] x86: restore correct module name for apm Sam Ravnborg
@ 2008-02-03 11:25   ` Ingo Molnar
  2008-02-03 11:49   ` Frans Pop
  2008-02-03 11:52   ` A.E.Lawrence
  2 siblings, 0 replies; 6+ messages in thread
From: Ingo Molnar @ 2008-02-03 11:25 UTC (permalink / raw)
  To: Sam Ravnborg; +Cc: A.E.Lawrence, linux-kernel


* Sam Ravnborg <sam@ravnborg.org> wrote:

> The apm module were renamed to apm_32 during the merge of 32 and 64 
> bit x86 which is unfortunate. As apm is 32 bit specific we like to 
> keep the _32 in the filename but the module should be named apm.
> 
> Fix this in the Makefile.

thanks, applied.

	Ingo

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] x86: restore correct module name for apm
  2008-02-03 10:32 ` [PATCH] x86: restore correct module name for apm Sam Ravnborg
  2008-02-03 11:25   ` Ingo Molnar
@ 2008-02-03 11:49   ` Frans Pop
  2008-02-03 11:52   ` A.E.Lawrence
  2 siblings, 0 replies; 6+ messages in thread
From: Frans Pop @ 2008-02-03 11:49 UTC (permalink / raw)
  To: Sam Ravnborg; +Cc: lawrence_a_e, linux-kernel, mingo

Sam Ravnborg wrote:
> The apm module were renamed to apm_32 during the merge of 32 and 64 bit
> x86 which is unfortunate.
> As apm is 32 bit specific we like to keep the _32 in the filename
> but the module should be named apm.
> 
> Fix this in the Makefile.
> Reported by "A.E.Lawrence" <lawrence_a_e@ntlworld.com>
> 
> Signed-off-by: Sam Ravnborg <sam@ravnborg.org>
> Cc: Cc: Ingo Molnar <mingo@elte.hu>
> Cc: Thomas Gleixner <tglx@linutronix.de>
> Cc: "H. Peter Anvin" <hpa@zytor.com>
> Cc: "A.E.Lawrence" <lawrence_a_e@ntlworld.com>

I assume this will be pushed for stable 2.6.24 as well?

Cheers,
FJP

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] x86: restore correct module name for apm
  2008-02-03 10:32 ` [PATCH] x86: restore correct module name for apm Sam Ravnborg
  2008-02-03 11:25   ` Ingo Molnar
  2008-02-03 11:49   ` Frans Pop
@ 2008-02-03 11:52   ` A.E.Lawrence
  2008-02-03 12:17     ` Sam Ravnborg
  2 siblings, 1 reply; 6+ messages in thread
From: A.E.Lawrence @ 2008-02-03 11:52 UTC (permalink / raw)
  To: Sam Ravnborg; +Cc: Ingo Molnar, linux-kernel

Sam Ravnborg wrote:
> The apm module were renamed to apm_32 during the merge of 32 and 64 bit x86 which
> is unfortunate.
> As apm is 32 bit specific we like to keep the _32 in the filename
> but the module should be named apm.
> 
> Fix this in the Makefile.
> Reported by "A.E.Lawrence" <lawrence_a_e@ntlworld.com>

..snip..
> 
> build tested only but obviously correct.
> 
> 	Sam

It is also at
  http://bugzilla.kernel.org/show_bug.cgi?id=9877
which someone (me?) should probably now close.

A E Lawrence

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] x86: restore correct module name for apm
  2008-02-03 11:52   ` A.E.Lawrence
@ 2008-02-03 12:17     ` Sam Ravnborg
  0 siblings, 0 replies; 6+ messages in thread
From: Sam Ravnborg @ 2008-02-03 12:17 UTC (permalink / raw)
  To: A.E.Lawrence; +Cc: Ingo Molnar, linux-kernel

On Sun, Feb 03, 2008 at 11:52:16AM +0000, A.E.Lawrence wrote:
> Sam Ravnborg wrote:
> > The apm module were renamed to apm_32 during the merge of 32 and 64 bit x86 which
> > is unfortunate.
> > As apm is 32 bit specific we like to keep the _32 in the filename
> > but the module should be named apm.
> > 
> > Fix this in the Makefile.
> > Reported by "A.E.Lawrence" <lawrence_a_e@ntlworld.com>
> 
> ..snip..
> > 
> > build tested only but obviously correct.
> > 
> > 	Sam
> 
> It is also at
>   http://bugzilla.kernel.org/show_bug.cgi?id=9877
> which someone (me?) should probably now close.

I please do so.
But I think you should wait until it hits mainline

	Sam

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2008-02-03 12:17 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2008-02-02 21:56 2.6.24 x86 apm module name change not in Kconfig A.E.Lawrence
2008-02-03 10:32 ` [PATCH] x86: restore correct module name for apm Sam Ravnborg
2008-02-03 11:25   ` Ingo Molnar
2008-02-03 11:49   ` Frans Pop
2008-02-03 11:52   ` A.E.Lawrence
2008-02-03 12:17     ` Sam Ravnborg

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).