linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 1/3]  clean up functions related to pages_min V2
@ 2009-05-21  0:23 Minchan Kim
  2009-05-27  5:25 ` Andrew Morton
  0 siblings, 1 reply; 5+ messages in thread
From: Minchan Kim @ 2009-05-21  0:23 UTC (permalink / raw)
  To: Andrew Morton, LKML, linux-mm
  Cc: Mel Gorman, KOSAKI Motohiro, Rik van Riel, Johannes Weiner,
	Yasunori Goto

Changelog since V1 
 o Change function name from setup_per_zone_wmark_min to setup_per_zone_wmarks
   - by Mel Gorman advise
 o Modify description - by KOSAKI advise

Mel changed zone->pages_[high/low/min] with zone->watermark array.
So, the functions related to pages_min also have to be changed.

* setup_per_zone_pages_min
* init_per_zone_pages_min

This patch is just clean up. so it doesn't affect behavior.

Signed-off-by: Minchan Kim <minchan.kim@gmail.com>
Acked-by: Mel Gorman <mel@csn.ul.ie>
---
 include/linux/mm.h  |    2 +-
 mm/memory_hotplug.c |    2 +-
 mm/page_alloc.c     |   15 ++++++++-------
 3 files changed, 10 insertions(+), 9 deletions(-)

diff --git a/include/linux/mm.h b/include/linux/mm.h
index a569862..7ea4d1b 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1058,7 +1058,7 @@ extern int __meminit __early_pfn_to_nid(unsigned long pfn);
 extern void set_dma_reserve(unsigned long new_dma_reserve);
 extern void memmap_init_zone(unsigned long, int, unsigned long,
 				unsigned long, enum memmap_context);
-extern void setup_per_zone_pages_min(void);
+extern void setup_per_zone_wmarks(void);
 extern void mem_init(void);
 extern void __init mmap_init(void);
 extern void show_mem(void);
diff --git a/mm/memory_hotplug.c b/mm/memory_hotplug.c
index c083cf5..037291e 100644
--- a/mm/memory_hotplug.c
+++ b/mm/memory_hotplug.c
@@ -422,7 +422,7 @@ int online_pages(unsigned long pfn, unsigned long nr_pages)
 	zone->present_pages += onlined_pages;
 	zone->zone_pgdat->node_present_pages += onlined_pages;
 
-	setup_per_zone_pages_min();
+	setup_per_zone_wmarks();
 	if (onlined_pages) {
 		kswapd_run(zone_to_nid(zone));
 		node_set_state(zone_to_nid(zone), N_HIGH_MEMORY);
diff --git a/mm/page_alloc.c b/mm/page_alloc.c
index 9c712f0..b518ea7 100644
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
@@ -4471,12 +4471,13 @@ static void setup_per_zone_lowmem_reserve(void)
 }
 
 /**
- * setup_per_zone_pages_min - called when min_free_kbytes changes.
+ * setup_per_zone_wmarks - called when min_free_kbytes changes 
+ * or when memory is hot-added
  *
- * Ensures that the pages_{min,low,high} values for each zone are set correctly
+ * Ensures that the watermark[min,low,high] values for each zone are set correctly
  * with respect to min_free_kbytes.
  */
-void setup_per_zone_pages_min(void)
+void setup_per_zone_wmarks(void)
 {
 	unsigned long pages_min = min_free_kbytes >> (PAGE_SHIFT - 10);
 	unsigned long lowmem_pages = 0;
@@ -4594,7 +4595,7 @@ static void __init setup_per_zone_inactive_ratio(void)
  * 8192MB:	11584k
  * 16384MB:	16384k
  */
-static int __init init_per_zone_pages_min(void)
+static int __init init_per_zone_wmark_min(void)
 {
 	unsigned long lowmem_kbytes;
 
@@ -4605,12 +4606,12 @@ static int __init init_per_zone_pages_min(void)
 		min_free_kbytes = 128;
 	if (min_free_kbytes > 65536)
 		min_free_kbytes = 65536;
-	setup_per_zone_pages_min();
+	setup_per_zone_wmarks();
 	setup_per_zone_lowmem_reserve();
 	setup_per_zone_inactive_ratio();
 	return 0;
 }
-module_init(init_per_zone_pages_min)
+module_init(init_per_zone_wmark_min)
 
 /*
  * min_free_kbytes_sysctl_handler - just a wrapper around proc_dointvec() so 
@@ -4622,7 +4623,7 @@ int min_free_kbytes_sysctl_handler(ctl_table *table, int write,
 {
 	proc_dointvec(table, write, file, buffer, length, ppos);
 	if (write)
-		setup_per_zone_pages_min();
+		setup_per_zone_wmarks();
 	return 0;
 }
 
-- 
1.5.4.3




-- 
Kinds Regards
Minchan Kim

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH 1/3]  clean up functions related to pages_min V2
  2009-05-21  0:23 [PATCH 1/3] clean up functions related to pages_min V2 Minchan Kim
@ 2009-05-27  5:25 ` Andrew Morton
  2009-05-27  6:06   ` Minchan Kim
  2009-05-27 11:29   ` Minchan Kim
  0 siblings, 2 replies; 5+ messages in thread
From: Andrew Morton @ 2009-05-27  5:25 UTC (permalink / raw)
  To: Minchan Kim
  Cc: LKML, linux-mm, Mel Gorman, KOSAKI Motohiro, Rik van Riel,
	Johannes Weiner, Yasunori Goto

On Thu, 21 May 2009 09:23:04 +0900 Minchan Kim <minchan.kim@gmail.com> wrote:

> Changelog since V1 
>  o Change function name from setup_per_zone_wmark_min to setup_per_zone_wmarks
>    - by Mel Gorman advise
>  o Modify description - by KOSAKI advise
> 
> Mel changed zone->pages_[high/low/min] with zone->watermark array.
> So, the functions related to pages_min also have to be changed.
> 
> * setup_per_zone_pages_min
> * init_per_zone_pages_min
> 
> This patch is just clean up. so it doesn't affect behavior.
> 

I cannot actually find a usable changelog amongst all that text.  Can
you try again please?

afacit the patch simply changes the names of a couple of functions. 
The changelog should concisely and completely describe what those naming
changes are, and the reason for making them.


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH 1/3]  clean up functions related to pages_min V2
  2009-05-27  5:25 ` Andrew Morton
@ 2009-05-27  6:06   ` Minchan Kim
  2009-05-27 11:29   ` Minchan Kim
  1 sibling, 0 replies; 5+ messages in thread
From: Minchan Kim @ 2009-05-27  6:06 UTC (permalink / raw)
  To: Andrew Morton
  Cc: Minchan Kim, LKML, linux-mm, Mel Gorman, KOSAKI Motohiro,
	Rik van Riel, Johannes Weiner, Yasunori Goto

On Tue, 26 May 2009 22:25:10 -0700
Andrew Morton <akpm@linux-foundation.org> wrote:

> On Thu, 21 May 2009 09:23:04 +0900 Minchan Kim <minchan.kim@gmail.com> wrote:
> 
> > Changelog since V1 
> >  o Change function name from setup_per_zone_wmark_min to setup_per_zone_wmarks
> >    - by Mel Gorman advise
> >  o Modify description - by KOSAKI advise
> > 
> > Mel changed zone->pages_[high/low/min] with zone->watermark array.
> > So, the functions related to pages_min also have to be changed.
> > 
> > * setup_per_zone_pages_min
> > * init_per_zone_pages_min
> > 
> > This patch is just clean up. so it doesn't affect behavior.
> > 
> 
> I cannot actually find a usable changelog amongst all that text.  Can
> you try again please?
> 
> afacit the patch simply changes the names of a couple of functions. 
> The changelog should concisely and completely describe what those naming
> changes are, and the reason for making them.
> 

Okay. I will do that :)

-- 
Kinds Regards
Minchan Kim

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH 1/3]  clean up functions related to pages_min V2
  2009-05-27  5:25 ` Andrew Morton
  2009-05-27  6:06   ` Minchan Kim
@ 2009-05-27 11:29   ` Minchan Kim
  2009-05-27 20:38     ` Andrew Morton
  1 sibling, 1 reply; 5+ messages in thread
From: Minchan Kim @ 2009-05-27 11:29 UTC (permalink / raw)
  To: Andrew Morton
  Cc: Minchan Kim, LKML, linux-mm, Mel Gorman, KOSAKI Motohiro,
	Rik van Riel, Johannes Weiner, Yasunori Goto

On Tue, 26 May 2009 22:25:10 -0700
Andrew Morton <akpm@linux-foundation.org> wrote:

> On Thu, 21 May 2009 09:23:04 +0900 Minchan Kim <minchan.kim@gmail.com> wrote:
> 
> > Changelog since V1 
> >  o Change function name from setup_per_zone_wmark_min to setup_per_zone_wmarks
> >    - by Mel Gorman advise
> >  o Modify description - by KOSAKI advise
> > 
> > Mel changed zone->pages_[high/low/min] with zone->watermark array.
> > So, the functions related to pages_min also have to be changed.
> > 
> > * setup_per_zone_pages_min
> > * init_per_zone_pages_min
> > 
> > This patch is just clean up. so it doesn't affect behavior.
> > 
> 
> I cannot actually find a usable changelog amongst all that text.  Can
> you try again please?
> 
> afacit the patch simply changes the names of a couple of functions. 
> The changelog should concisely and completely describe what those naming
> changes are, and the reason for making them.
> 

I will add just description of patch since Andrew already merged this patch 
except description.

== CUT_HERE ==

This patch change names of two functions. so It doesn't affect behavior. 
Now, setup_per_zone_pages_min changes low, high of zone as well as min.
So, a better name might have been setup_per_zone_wmarks.That's because
Mel changed zone->pages_[hig/low/min] to zone->watermark array.(434b5394fd85c212619306cda6bf087be737b35a)

 * setup_per_zone_pages_min => setup_per_zone_wmarks

Of course, we have to change init_per_zone_pages_min, too.
There are not pages_min any more. 

 * init_per_zone_pages_min => init_per_zone_wmark_min

Signed-off-by: Minchan Kim <minchan.kim@gmail.com>
Acked-by: Mel Gorman <mel@csn.ul.ie>

-- 
Kinds Regards
Minchan Kim

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH 1/3]  clean up functions related to pages_min V2
  2009-05-27 11:29   ` Minchan Kim
@ 2009-05-27 20:38     ` Andrew Morton
  0 siblings, 0 replies; 5+ messages in thread
From: Andrew Morton @ 2009-05-27 20:38 UTC (permalink / raw)
  To: Minchan Kim
  Cc: minchan.kim, linux-kernel, linux-mm, mel, kosaki.motohiro, riel,
	hannes, y-goto

On Wed, 27 May 2009 20:29:55 +0900
Minchan Kim <minchan.kim@gmail.com> wrote:

> This patch change names of two functions. so It doesn't affect behavior. 
> Now, setup_per_zone_pages_min changes low, high of zone as well as min.
> So, a better name might have been setup_per_zone_wmarks.That's because
> Mel changed zone->pages_[hig/low/min] to zone->watermark array.(434b5394fd85c212619306cda6bf087be737b35a)
> 

When quoting changeset IDs, please do it in the form

  0594ad1a66381076f0fa06f5605ea5023f600586 ("mfd/pcf50633-gpio.c: add MODULE_LICENSE")

There's a good reason for this, but I forget what it is.  Perhaps so
that the same commit can be located if it has a different hash?  I
expect that commits get a different hash when backported into -stable,
for example.

I spend my life making changes like that to changelogs, but when I went
to fix up your 434b5394fd85c212619306cda6bf087be737b35a, I was unable
to locate any commit which has that hash.

<searches for a while>

Ah, you're referring to a -mmotm patch.  The hashes in -mmotm aren't
useful because the tree gets regenerated each time.  So let's refer to
that patch via just its title, "page allocator: replace the
watermark-related union in struct zone with a watermark[] array".



^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2009-05-27 20:40 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-05-21  0:23 [PATCH 1/3] clean up functions related to pages_min V2 Minchan Kim
2009-05-27  5:25 ` Andrew Morton
2009-05-27  6:06   ` Minchan Kim
2009-05-27 11:29   ` Minchan Kim
2009-05-27 20:38     ` Andrew Morton

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).