linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: David Miller <davem@davemloft.net>
To: fthain@telegraphics.com.au
Cc: joe@perches.com, p_gortmaker@yahoo.com, netdev@vger.kernel.org,
	linux-kernel@vger.kernel.org, linux-m68k@vger.kernel.org
Subject: Re: another cleanup patch gone wrong
Date: Thu, 15 Apr 2010 20:01:13 -0700 (PDT)	[thread overview]
Message-ID: <20100415.200113.215578006.davem@davemloft.net> (raw)
In-Reply-To: <alpine.OSX.2.00.1004161214270.271@localhost>

From: Finn Thain <fthain@telegraphics.com.au>
Date: Fri, 16 Apr 2010 12:34:24 +1000 (EST)

> 
> ...but this one was already merged, unfortunately.
> 
>> Use printk_once
>> Add #define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
>> Convert printks without KERN_<level> to pr_info and pr_cont
>> 
>> Signed-off-by: Joe Perches <joe@perches.com>
>> Signed-off-by: David S. Miller <davem@davemloft.net>
>> 
>> 
>> diff --git a/drivers/net/mac8390.c b/drivers/net/mac8390.c
>> index 517cee4..8bd09e2 100644 (file)
>> --- a/drivers/net/mac8390.c
>> +++ b/drivers/net/mac8390.c
>> @@ -17,6 +17,8 @@
>>  /* 2002-12-30: Try to support more cards, some clues from NetBSD driver */
>>  /* 2003-12-26: Make sure Asante cards always work. */
>>  
>> +#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
>> +
> 
> Why the macro? You only used it once.

It gets expanded internally into all of the pr_*() calls.

> The pr_xxx naming convention belongs to a kernel-wide include file. Is it 
> really a good idea to start repurposing it in .c files?

This is exactly how it can be used, and there is much
precedent for this now.

>> -                       printk("Don't know how to access card memory!\n");
>> +                       pr_info("Don't know how to access card memory!\n");
> 
> No, this is pr_err. The driver sets dev->mem_start expecting it to work, 
> obviously.

It was an unspecified printk() so Joe's conversion is equal
and that's a good way for him to have made these changes.

If we want to mark this as KERN_ERR or whatever, that's entirely
a seperate change.

I think your objections to Joe's changes are completely uncalled
for and his changes were good ones.

  reply	other threads:[~2010-04-16  3:01 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-04-16  2:34 another cleanup patch gone wrong Finn Thain
2010-04-16  3:01 ` David Miller [this message]
2010-04-16  3:45   ` [PATCH] mac8390: fix pr_info() calls, was " Finn Thain
2010-04-16  3:54     ` Joe Perches
2010-04-16  3:59       ` Finn Thain
2010-04-16  4:21     ` [PATCH] mac8390: fix pr_info() calls and change return code Finn Thain
2010-04-16  4:34       ` Joe Perches
2010-04-16 13:57         ` Finn Thain
2010-04-16 20:28           ` David Miller
2010-04-17  2:28             ` Finn Thain
2010-04-16  5:53       ` David Miller
2010-04-16 14:14       ` [PATCH] mac8390: change an error return code and some cleanup Finn Thain
2010-04-17  3:16         ` [PATCH] mac8390: change an error return code and some cleanup, take 3 Finn Thain
2010-04-21 23:30           ` David Miller
2010-04-22  1:13             ` Finn Thain
2010-05-28 17:29             ` [PATCH] mac8390: change an error return code and some cleanup, take 4 Finn Thain
2010-05-31  7:19               ` David Miller
2010-05-31  9:21                 ` fthain
2010-05-31  9:58                   ` Geert Uytterhoeven
2010-05-31 11:07                     ` fthain
2010-05-31 11:30                       ` David Miller
2010-05-31 12:55                         ` Finn Thain
2010-05-31 13:02                           ` David Miller
2010-06-01 12:18                             ` [PATCH 1/2] mac8390: propagate error code from request_irq Finn Thain
2010-06-02 12:17                               ` David Miller
2010-06-01 12:18                             ` [PATCH 2/2] mac8390: raise error logging priority Finn Thain
2010-06-02 14:06                               ` David Miller
2010-06-02 15:36                                 ` Finn Thain
2010-05-31 15:08                     ` [PATCH] mac8390: change an error return code and some cleanup, take 4 Joe Perches
2010-05-31 15:14                       ` David Miller
2010-05-31 15:19                         ` Finn Thain
2010-05-31 11:27                   ` David Miller
2010-04-16  3:11 ` another cleanup patch gone wrong Joe Perches
2010-04-16  3:21   ` Finn Thain

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20100415.200113.215578006.davem@davemloft.net \
    --to=davem@davemloft.net \
    --cc=fthain@telegraphics.com.au \
    --cc=joe@perches.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-m68k@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=p_gortmaker@yahoo.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).