linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v4 1/4] dt: add of_get_child_count helper function
@ 2012-04-26 14:40 Dong Aisheng
  2012-04-26 14:40 ` [PATCH v3 2/4] pinctrl: pinctrl-imx: add imx pinctrl core driver Dong Aisheng
                   ` (3 more replies)
  0 siblings, 4 replies; 35+ messages in thread
From: Dong Aisheng @ 2012-04-26 14:40 UTC (permalink / raw)
  To: linux-kernel
  Cc: linux-arm-kernel, devicetree-discuss, linus.walleij, swarren,
	s.hauer, shawn.guo, kernel, grant.likely, rob.herring, cjb,
	b20223

From: Dong Aisheng <dong.aisheng@linaro.org>

Currently most code to get child count in kernel are almost same,
add a helper to implement this function for dt to use.

Cc: Grant Likely <grant.likely@secretlab.ca>
Acked-by: Rob Herring <rob.herring@calxeda.com>
Signed-off-by: Dong Aisheng <dong.aisheng@linaro.org>

---
Rob missed this patch for 3.4 kernel.
Based on Rob's suggestion, we can get it go in with pinctrl driver.
Since Rob once had applied it, i added Rob's ack.
See:
https://lkml.org/lkml/2012/4/14/239

changes v3->v4:
 * addressed Grant's suggestion to use for_each_child_of_node.

changes v2->v3:
 Addressed some people's comments:
 * do not use assignment as expression
 * return 0 for non-dt case

Changes v1->v2:
 * change the name from of_get_child_number to of_get_child_count
---
 include/linux/of.h |   16 ++++++++++++++++
 1 files changed, 16 insertions(+), 0 deletions(-)

diff --git a/include/linux/of.h b/include/linux/of.h
index e3f942d..1c14976 100644
--- a/include/linux/of.h
+++ b/include/linux/of.h
@@ -193,6 +193,17 @@ extern struct device_node *of_get_next_child(const struct device_node *node,
 	for (child = of_get_next_child(parent, NULL); child != NULL; \
 	     child = of_get_next_child(parent, child))
 
+static inline int of_get_child_count(const struct device_node *np)
+{
+	struct device_node *child = NULL;
+	int num = 0;
+
+	for_each_child_of_node(np, child)
+		num++;
+
+	return num;
+}
+
 extern struct device_node *of_find_node_with_property(
 	struct device_node *from, const char *prop_name);
 #define for_each_node_with_property(dn, prop_name) \
@@ -300,6 +311,11 @@ static inline bool of_have_populated_dt(void)
 #define for_each_child_of_node(parent, child) \
 	while (0)
 
+static inline int of_get_child_count(const struct device_node *np)
+{
+	return 0;
+}
+
 static inline int of_device_is_compatible(const struct device_node *device,
 					  const char *name)
 {
-- 
1.7.0.4



^ permalink raw reply related	[flat|nested] 35+ messages in thread

end of thread, other threads:[~2012-05-01 23:05 UTC | newest]

Thread overview: 35+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-04-26 14:40 [PATCH v4 1/4] dt: add of_get_child_count helper function Dong Aisheng
2012-04-26 14:40 ` [PATCH v3 2/4] pinctrl: pinctrl-imx: add imx pinctrl core driver Dong Aisheng
2012-04-26 14:44   ` Jean-Christophe PLAGNIOL-VILLARD
2012-04-26 15:15     ` Jean-Christophe PLAGNIOL-VILLARD
2012-04-27  5:48       ` Shawn Guo
2012-04-27  6:28         ` Jean-Christophe PLAGNIOL-VILLARD
2012-04-27  7:25           ` Shawn Guo
2012-04-27  7:11             ` Jean-Christophe PLAGNIOL-VILLARD
2012-04-27  8:11               ` Shawn Guo
2012-04-27  9:29                 ` Jean-Christophe PLAGNIOL-VILLARD
2012-04-27  3:48     ` Dong Aisheng
2012-04-27  6:31       ` Jean-Christophe PLAGNIOL-VILLARD
2012-04-27  7:30     ` Sascha Hauer
2012-04-26 14:44   ` Dong Aisheng
2012-04-27  5:30   ` Shawn Guo
2012-04-27  8:54   ` Shawn Guo
2012-04-27 11:24     ` Dong Aisheng
2012-04-26 14:40 ` [PATCH v3 3/4] pinctrl: pinctrl-imx: add imx6q pinctrl driver Dong Aisheng
2012-04-27  5:35   ` Shawn Guo
2012-04-27  6:45   ` Sascha Hauer
2012-04-27  7:16     ` Dong Aisheng
2012-04-26 14:40 ` [PATCH v3 4/4] mmc: sdhci-imx-esdhc: convert to use pinctrl subsystem Dong Aisheng
2012-04-26 16:32   ` Stephen Warren
2012-04-27  7:35   ` Sascha Hauer
2012-04-27  8:29     ` Dong Aisheng
2012-04-27  8:26       ` Shawn Guo
2012-04-27  8:31       ` Sascha Hauer
2012-04-27  8:54         ` Dong Aisheng
2012-04-27  8:47           ` Sascha Hauer
2012-04-27  9:13             ` Dong Aisheng
2012-04-26 16:24 ` [PATCH v4 1/4] dt: add of_get_child_count helper function Stephen Warren
2012-04-27  3:28   ` Dong Aisheng
2012-04-27  3:36     ` [PATCH v5 1/1] " Dong Aisheng
2012-04-27 15:25       ` Stephen Warren
2012-05-01 23:05       ` Linus Walleij

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).