linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* Re: Thermal: Add a thermal notifier for user space
       [not found] <20121212180547.F12BE6606F0@gitolite.kernel.org>
@ 2012-12-12 18:28 ` Dave Jones
  2012-12-13  0:23   ` Zhang Rui
  0 siblings, 1 reply; 4+ messages in thread
From: Dave Jones @ 2012-12-12 18:28 UTC (permalink / raw)
  To: Linux Kernel Mailing List; +Cc: Durgadoss R, Zhang Rui

On Wed, Dec 12, 2012 at 06:05:47PM +0000, Linux Kernel wrote:
 > Gitweb:     http://git.kernel.org/linus/;a=commit;h=1cc807a234cb988d69ba18f6a3a1c68d71e54bed
 > Commit:     1cc807a234cb988d69ba18f6a3a1c68d71e54bed
 > Parent:     e151a202a084f9f4310d1aa4398325c56ca95fda
 > Author:     Durgadoss R <durgadoss.r@intel.com>
 > AuthorDate: Tue Sep 18 11:05:03 2012 +0530
 > Committer:  Zhang Rui <rui.zhang@intel.com>
 > CommitDate: Mon Nov 5 14:00:08 2012 +0800
 > 
 >     Thermal: Add a thermal notifier for user space
 >     
 >     This patch registers a governor which will let the
 >     user land manage the platform thermals. Whenever a
 >     trip happens, this governor just notifies the user
 >     space using kobj_uevent().
 >     
 >     Signed-off-by: Durgadoss R <durgadoss.r@intel.com>
 >     Signed-off-by: Zhang Rui <rui.zhang@intel.com>

 
 > +config USER_SPACE
 > +	bool "User_space thermal governor"
 > +	depends on THERMAL
 > +	help
 > +	  Enable this to let the user space manage the platform thermals.

This is terribly generic sounding.  Might I suggest THERMAL_USER_SPACE instead ?

	Dave


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Thermal: Add a thermal notifier for user space
  2012-12-12 18:28 ` Thermal: Add a thermal notifier for user space Dave Jones
@ 2012-12-13  0:23   ` Zhang Rui
  2012-12-13  0:26     ` Dave Jones
  2012-12-13 14:34     ` R, Durgadoss
  0 siblings, 2 replies; 4+ messages in thread
From: Zhang Rui @ 2012-12-13  0:23 UTC (permalink / raw)
  To: Dave Jones; +Cc: Linux Kernel Mailing List, Durgadoss R

On Wed, 2012-12-12 at 13:28 -0500, Dave Jones wrote:
> On Wed, Dec 12, 2012 at 06:05:47PM +0000, Linux Kernel wrote:
>  > Gitweb:     http://git.kernel.org/linus/;a=commit;h=1cc807a234cb988d69ba18f6a3a1c68d71e54bed
>  > Commit:     1cc807a234cb988d69ba18f6a3a1c68d71e54bed
>  > Parent:     e151a202a084f9f4310d1aa4398325c56ca95fda
>  > Author:     Durgadoss R <durgadoss.r@intel.com>
>  > AuthorDate: Tue Sep 18 11:05:03 2012 +0530
>  > Committer:  Zhang Rui <rui.zhang@intel.com>
>  > CommitDate: Mon Nov 5 14:00:08 2012 +0800
>  > 
>  >     Thermal: Add a thermal notifier for user space
>  >     
>  >     This patch registers a governor which will let the
>  >     user land manage the platform thermals. Whenever a
>  >     trip happens, this governor just notifies the user
>  >     space using kobj_uevent().
>  >     
>  >     Signed-off-by: Durgadoss R <durgadoss.r@intel.com>
>  >     Signed-off-by: Zhang Rui <rui.zhang@intel.com>
> 
>  
>  > +config USER_SPACE
>  > +	bool "User_space thermal governor"
>  > +	depends on THERMAL
>  > +	help
>  > +	  Enable this to let the user space manage the platform thermals.
> 
> This is terribly generic sounding.  Might I suggest THERMAL_USER_SPACE instead ?
> 
Hi, Dave,

You're right. How about the patch attached?

thanks,
rui

>From 595a531b3fbfd21d3d84a16fb8df93fdc0fe47e5 Mon Sep 17 00:00:00 2001
From: Zhang Rui <rui.zhang@intel.com>
Date: Thu, 13 Dec 2012 08:05:12 +0800
Subject: [PATCH] Thermal: Rename thermal governor Kconfig options

Rename thermal governor Kconfig options,
CONFIG_STEP_WISE, CONFIG_FAIR_SHARE, CONFIG_USER_SPACE
to
CONFIG_THERMAL_GOVERNOR_STEP_WISE,
CONFIG_THERMAL_GOVERNOR_FAIR_SHARE,
CONFIG_THERMAL_GOVERNOR_USER_SPACE,
to avoid confusions brought by the previous generic naming.

Signed-off-by: Zhang Rui <rui.zhang@intel.com>
---
 drivers/thermal/Kconfig  |   12 ++++++------
 drivers/thermal/Makefile |    6 +++---
 2 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/drivers/thermal/Kconfig b/drivers/thermal/Kconfig
index 8636fae..13fed80 100644
--- a/drivers/thermal/Kconfig
+++ b/drivers/thermal/Kconfig
@@ -29,14 +29,14 @@ choice
 
 config THERMAL_DEFAULT_GOV_STEP_WISE
 	bool "step_wise"
-	select STEP_WISE
+	select THERMAL_GOVERNOR_STEP_WISE
 	help
 	  Use the step_wise governor as default. This throttles the
 	  devices one step at a time.
 
 config THERMAL_DEFAULT_GOV_FAIR_SHARE
 	bool "fair_share"
-	select FAIR_SHARE
+	select THERMAL_GOVERNOR_FAIR_SHARE
 	help
 	  Use the fair_share governor as default. This throttles the
 	  devices based on their 'contribution' to a zone. The
@@ -44,24 +44,24 @@ config THERMAL_DEFAULT_GOV_FAIR_SHARE
 
 config THERMAL_DEFAULT_GOV_USER_SPACE
 	bool "user_space"
-	select USER_SPACE
+	select THERMAL_GOVERNOR_USER_SPACE
 	help
 	  Select this if you want to let the user space manage the
 	  lpatform thermals.
 
 endchoice
 
-config FAIR_SHARE
+config THERMAL_GOVERNOR_FAIR_SHARE
 	bool "Fair-share thermal governor"
 	help
 	  Enable this to manage platform thermals using fair-share governor.
 
-config STEP_WISE
+config THERMAL_GOVERNOR_STEP_WISE
 	bool "Step_wise thermal governor"
 	help
 	  Enable this to manage platform thermals using a simple linear
 
-config USER_SPACE
+config THERMAL_GOVERNOR_USER_SPACE
 	bool "User_space thermal governor"
 	help
 	  Enable this to let the user space manage the platform thermals.
diff --git a/drivers/thermal/Makefile b/drivers/thermal/Makefile
index d8da683..4f5103d 100644
--- a/drivers/thermal/Makefile
+++ b/drivers/thermal/Makefile
@@ -5,9 +5,9 @@
 obj-$(CONFIG_THERMAL)		+= thermal_sys.o
 
 # governors
-obj-$(CONFIG_FAIR_SHARE)	+= fair_share.o
-obj-$(CONFIG_STEP_WISE)		+= step_wise.o
-obj-$(CONFIG_USER_SPACE)	+= user_space.o
+obj-$(CONFIG_THERMAL_GOVERNOR_FAIR_SHARE)	+= fair_share.o
+obj-$(CONFIG_THERMAL_GOVERNOR_STEP_WISE)	+= step_wise.o
+obj-$(CONFIG_THERMAL_GOVERNOR_USER_SPACE)	+= user_space.o
 
 # cpufreq cooling
 obj-$(CONFIG_CPU_THERMAL)	+= cpu_cooling.o
-- 
1.7.9.5





^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: Thermal: Add a thermal notifier for user space
  2012-12-13  0:23   ` Zhang Rui
@ 2012-12-13  0:26     ` Dave Jones
  2012-12-13 14:34     ` R, Durgadoss
  1 sibling, 0 replies; 4+ messages in thread
From: Dave Jones @ 2012-12-13  0:26 UTC (permalink / raw)
  To: Zhang Rui; +Cc: Linux Kernel Mailing List, Durgadoss R

On Thu, Dec 13, 2012 at 08:23:19AM +0800, Zhang Rui wrote:
 
 > > 
 > > This is terribly generic sounding.  Might I suggest THERMAL_USER_SPACE instead ?
 > > 
 > Hi, Dave,
 > 
 > You're right. How about the patch attached?

Looks good to me,

thanks,

	Dave


^ permalink raw reply	[flat|nested] 4+ messages in thread

* RE: Thermal: Add a thermal notifier for user space
  2012-12-13  0:23   ` Zhang Rui
  2012-12-13  0:26     ` Dave Jones
@ 2012-12-13 14:34     ` R, Durgadoss
  1 sibling, 0 replies; 4+ messages in thread
From: R, Durgadoss @ 2012-12-13 14:34 UTC (permalink / raw)
  To: Zhang, Rui, Dave Jones; +Cc: Linux Kernel Mailing List

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #1: Type: text/plain; charset="utf-8", Size: 4754 bytes --]

> -----Original Message-----
> From: Zhang, Rui
> Sent: Thursday, December 13, 2012 5:53 AM
> To: Dave Jones
> Cc: Linux Kernel Mailing List; R, Durgadoss
> Subject: Re: Thermal: Add a thermal notifier for user space
> 
> On Wed, 2012-12-12 at 13:28 -0500, Dave Jones wrote:
> > On Wed, Dec 12, 2012 at 06:05:47PM +0000, Linux Kernel wrote:
> >  > Gitweb:
> http://git.kernel.org/linus/;a=commit;h=1cc807a234cb988d69ba18f6a3a1c68
> d71e54bed
> >  > Commit:     1cc807a234cb988d69ba18f6a3a1c68d71e54bed
> >  > Parent:     e151a202a084f9f4310d1aa4398325c56ca95fda
> >  > Author:     Durgadoss R <durgadoss.r@intel.com>
> >  > AuthorDate: Tue Sep 18 11:05:03 2012 +0530
> >  > Committer:  Zhang Rui <rui.zhang@intel.com>
> >  > CommitDate: Mon Nov 5 14:00:08 2012 +0800
> >  >
> >  >     Thermal: Add a thermal notifier for user space
> >  >
> >  >     This patch registers a governor which will let the
> >  >     user land manage the platform thermals. Whenever a
> >  >     trip happens, this governor just notifies the user
> >  >     space using kobj_uevent().
> >  >
> >  >     Signed-off-by: Durgadoss R <durgadoss.r@intel.com>
> >  >     Signed-off-by: Zhang Rui <rui.zhang@intel.com>
> >
> >
> >  > +config USER_SPACE
> >  > +	bool "User_space thermal governor"
> >  > +	depends on THERMAL
> >  > +	help
> >  > +	  Enable this to let the user space manage the platform thermals.
> >
> > This is terribly generic sounding.  Might I suggest THERMAL_USER_SPACE
> instead ?
> >
> Hi, Dave,

Agree with you Dave. Could have chosen a better name :-)

Thanks Rui for the Quick fix.

> 
> You're right. How about the patch attached?
> 
> thanks,
> rui
> 
> From 595a531b3fbfd21d3d84a16fb8df93fdc0fe47e5 Mon Sep 17 00:00:00
> 2001
> From: Zhang Rui <rui.zhang@intel.com>
> Date: Thu, 13 Dec 2012 08:05:12 +0800
> Subject: [PATCH] Thermal: Rename thermal governor Kconfig options
> 
> Rename thermal governor Kconfig options,
> CONFIG_STEP_WISE, CONFIG_FAIR_SHARE, CONFIG_USER_SPACE
> to
> CONFIG_THERMAL_GOVERNOR_STEP_WISE,
> CONFIG_THERMAL_GOVERNOR_FAIR_SHARE,
> CONFIG_THERMAL_GOVERNOR_USER_SPACE,
> to avoid confusions brought by the previous generic naming.
> 

Acked-by: Durgadoss R <durgadoss.r@intel.com>

Thanks,
Durga

> Signed-off-by: Zhang Rui <rui.zhang@intel.com>
> ---
>  drivers/thermal/Kconfig  |   12 ++++++------
>  drivers/thermal/Makefile |    6 +++---
>  2 files changed, 9 insertions(+), 9 deletions(-)
> 
> diff --git a/drivers/thermal/Kconfig b/drivers/thermal/Kconfig
> index 8636fae..13fed80 100644
> --- a/drivers/thermal/Kconfig
> +++ b/drivers/thermal/Kconfig
> @@ -29,14 +29,14 @@ choice
> 
>  config THERMAL_DEFAULT_GOV_STEP_WISE
>  	bool "step_wise"
> -	select STEP_WISE
> +	select THERMAL_GOVERNOR_STEP_WISE
>  	help
>  	  Use the step_wise governor as default. This throttles the
>  	  devices one step at a time.
> 
>  config THERMAL_DEFAULT_GOV_FAIR_SHARE
>  	bool "fair_share"
> -	select FAIR_SHARE
> +	select THERMAL_GOVERNOR_FAIR_SHARE
>  	help
>  	  Use the fair_share governor as default. This throttles the
>  	  devices based on their 'contribution' to a zone. The
> @@ -44,24 +44,24 @@ config THERMAL_DEFAULT_GOV_FAIR_SHARE
> 
>  config THERMAL_DEFAULT_GOV_USER_SPACE
>  	bool "user_space"
> -	select USER_SPACE
> +	select THERMAL_GOVERNOR_USER_SPACE
>  	help
>  	  Select this if you want to let the user space manage the
>  	  lpatform thermals.
> 
>  endchoice
> 
> -config FAIR_SHARE
> +config THERMAL_GOVERNOR_FAIR_SHARE
>  	bool "Fair-share thermal governor"
>  	help
>  	  Enable this to manage platform thermals using fair-share governor.
> 
> -config STEP_WISE
> +config THERMAL_GOVERNOR_STEP_WISE
>  	bool "Step_wise thermal governor"
>  	help
>  	  Enable this to manage platform thermals using a simple linear
> 
> -config USER_SPACE
> +config THERMAL_GOVERNOR_USER_SPACE
>  	bool "User_space thermal governor"
>  	help
>  	  Enable this to let the user space manage the platform thermals.
> diff --git a/drivers/thermal/Makefile b/drivers/thermal/Makefile
> index d8da683..4f5103d 100644
> --- a/drivers/thermal/Makefile
> +++ b/drivers/thermal/Makefile
> @@ -5,9 +5,9 @@
>  obj-$(CONFIG_THERMAL)		+= thermal_sys.o
> 
>  # governors
> -obj-$(CONFIG_FAIR_SHARE)	+= fair_share.o
> -obj-$(CONFIG_STEP_WISE)		+= step_wise.o
> -obj-$(CONFIG_USER_SPACE)	+= user_space.o
> +obj-$(CONFIG_THERMAL_GOVERNOR_FAIR_SHARE)	+= fair_share.o
> +obj-$(CONFIG_THERMAL_GOVERNOR_STEP_WISE)	+= step_wise.o
> +obj-$(CONFIG_THERMAL_GOVERNOR_USER_SPACE)	+= user_space.o
> 
>  # cpufreq cooling
>  obj-$(CONFIG_CPU_THERMAL)	+= cpu_cooling.o
> --
> 1.7.9.5
> 
> 
> 

ÿôèº{.nÇ+‰·Ÿ®‰­†+%ŠËÿ±éݶ\x17¥Šwÿº{.nÇ+‰·¥Š{±þG«éÿŠ{ayº\x1dʇڙë,j\a­¢f£¢·hšïêÿ‘êçz_è®\x03(­éšŽŠÝ¢j"ú\x1a¶^[m§ÿÿ¾\a«þG«éÿ¢¸?™¨è­Ú&£ø§~á¶iO•æ¬z·švØ^\x14\x04\x1a¶^[m§ÿÿÃ\fÿ¶ìÿ¢¸?–I¥

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2012-12-13 14:34 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <20121212180547.F12BE6606F0@gitolite.kernel.org>
2012-12-12 18:28 ` Thermal: Add a thermal notifier for user space Dave Jones
2012-12-13  0:23   ` Zhang Rui
2012-12-13  0:26     ` Dave Jones
2012-12-13 14:34     ` R, Durgadoss

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).