linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v7 0/5] Add ST-Ericsson AB8500 HWMON driver
@ 2013-03-27  7:13 Hongbo Zhang
  2013-03-27  7:13 ` [PATCH v7 1/5] ab8500_btemp: make ab8500_btemp_get* interfaces public Hongbo Zhang
                   ` (5 more replies)
  0 siblings, 6 replies; 13+ messages in thread
From: Hongbo Zhang @ 2013-03-27  7:13 UTC (permalink / raw)
  To: linux, khali, lm-sensors, cbou, dwmw2
  Cc: linaro-kernel, STEricsson_nomadik_linux, linus.walleij,
	lee.jones, linux-kernel, Hongbo Zhang

Guenter and Anton,
Only one minor update as Guenter mentioned for v6, thank you.

v6 -> v7 changes:
- move exporting symbols from [5/5] to [4/5], which was a mistake.

v5 -> v6 changes:
- add depend on AB8500_BM in Kconfig
- fix wrong usage of clamp_val()
- export symbols for module compiling

v4 -> v5 changes:
- split the old [2/3]-ab8500-re-arrange-ab8500-power-and-temperature-data into
  new three [2/5], [3/5] and [4/5] patches.
- hwmon driver minor coding style clean ups:
  - {} usage in if-else statement in ab8500_read_sensor function
  - index error fix in gpadc_monitor function
  - fix issue of clamp_val() usage
  - remove unnecessary else in function abx500_attrs_visible
  - remove redundant print message about irq set up
  - return the calling function return value directly in probe function

v3 -> v4 changes:
for patch [3/3]
- define delays in HZ
- update ab8500_read_sensor function, returning temp by parameter
- remove ab8500_is_visible function
- use clamp_val in set_min and set_max callback
- remove unnecessary locks in remove and suspend functions
- let abx500 and ab8500 use its own data structure
for patch [2/3]
- move the data tables from driver/power/ab8500_bmdata.c to
  include/linux/power/ab8500.h
- rename driver/power/ab8500_bmdata.c to driver/power/ab8500_bm.c
- rename these variable names to eliminate CamelCase warnings
- add const attribute to these data

v2 -> v3 changes:
- Add interface for converting voltage to temperature
- Remove temp5 sensor since we cannot offer temperature read interface of it
- Update hyst to use absolute temperature instead of a difference
- Add the 3/3 patch

v1 -> v2 changes:
- Add Documentation/hwmon/abx500 and Documentation/hwmon/abx500
- Make devices which cannot report milli-Celsius invisible
- Add temp5_crit interface
- Re-work the old find_active_thresholds() to threshold_updated()
- Reset updated_min_alarm and updated_max_alarm at the end of each loop
- Update the hyst mechamisn to make it works as real hyst
- Remove non-stand attributes
- Re-order the operations sequence inside probe and remove functions
- Update all the lock usages to eliminate race conditions
- Make attibutes index starts from 0
also changes:
- Since the old [1/2] "ARM: ux500: rename ab8500 to abx500 for hwmon driver"
  has been merged by Samuel, so won't send it again.
- Add another new patch "ab8500_btemp: export two symblols" as [2/2] of this
  patch set.

Hongbo Zhang (5):
  ab8500_btemp: make ab8500_btemp_get* interfaces public
  ab8500: power: eliminate CamelCase warning of some variables
  ab8500: power: add const attributes to some data arrays
  ab8500: power: export abx500_res_to_temp tables for hwmon
  hwmon: add ST-Ericsson ABX500 hwmon driver

 Documentation/hwmon/ab8500           |  22 ++
 Documentation/hwmon/abx500           |  28 ++
 drivers/hwmon/Kconfig                |  13 +
 drivers/hwmon/Makefile               |   1 +
 drivers/hwmon/ab8500.c               | 206 +++++++++++++++
 drivers/hwmon/abx500.c               | 491 +++++++++++++++++++++++++++++++++++
 drivers/hwmon/abx500.h               |  69 +++++
 drivers/power/ab8500_bmdata.c        |  42 +--
 drivers/power/ab8500_btemp.c         |   5 +-
 drivers/power/ab8500_fg.c            |   4 +-
 include/linux/mfd/abx500.h           |   6 +-
 include/linux/mfd/abx500/ab8500-bm.h |   5 +
 include/linux/power/ab8500.h         |  16 ++
 13 files changed, 885 insertions(+), 23 deletions(-)
 create mode 100644 Documentation/hwmon/ab8500
 create mode 100644 Documentation/hwmon/abx500
 create mode 100644 drivers/hwmon/ab8500.c
 create mode 100644 drivers/hwmon/abx500.c
 create mode 100644 drivers/hwmon/abx500.h
 create mode 100644 include/linux/power/ab8500.h

-- 
1.8.0


^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2013-03-31 20:03 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-03-27  7:13 [PATCH v7 0/5] Add ST-Ericsson AB8500 HWMON driver Hongbo Zhang
2013-03-27  7:13 ` [PATCH v7 1/5] ab8500_btemp: make ab8500_btemp_get* interfaces public Hongbo Zhang
2013-03-27  7:13 ` [PATCH v7 2/5] ab8500: power: eliminate CamelCase warning of some variables Hongbo Zhang
2013-03-27  7:13 ` [PATCH v7 3/5] ab8500: power: add const attributes to some data arrays Hongbo Zhang
2013-03-27  7:13 ` [PATCH v7 4/5] ab8500: power: export abx500_res_to_temp tables for hwmon Hongbo Zhang
2013-03-27 19:47   ` Guenter Roeck
2013-03-27  7:13 ` [PATCH v7 5/5] hwmon: add ST-Ericsson ABX500 hwmon driver Hongbo Zhang
2013-03-27 19:48   ` Guenter Roeck
2013-03-28  2:31     ` Hongbo Zhang
2013-03-30 23:18     ` Anton Vorontsov
2013-03-30 23:27       ` Guenter Roeck
2013-03-31 19:59         ` Anton Vorontsov
2013-03-30 23:13 ` [PATCH v7 0/5] Add ST-Ericsson AB8500 HWMON driver Anton Vorontsov

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).