linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 1/2] IOMMU/trivial: Use for_each_drhd_unit() instead of list_for_each_entry()
@ 2013-10-31  9:25 Yijing Wang
  2013-11-01 13:19 ` Joerg Roedel
  0 siblings, 1 reply; 2+ messages in thread
From: Yijing Wang @ 2013-10-31  9:25 UTC (permalink / raw)
  To: Joerg Roedel, David Woodhouse
  Cc: iommu, linux-kernel, Yijing Wang, Hanjun Guo

Use for_each_drhd_unit() instead of list_for_each_entry for
better readability.

Signed-off-by: Yijing Wang <wangyijing@huawei.com>
---
 drivers/iommu/dmar.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/drivers/iommu/dmar.c b/drivers/iommu/dmar.c
index 785675a..da2d0d9 100644
--- a/drivers/iommu/dmar.c
+++ b/drivers/iommu/dmar.c
@@ -403,7 +403,7 @@ dmar_find_matched_drhd_unit(struct pci_dev *dev)
 
 	dev = pci_physfn(dev);
 
-	list_for_each_entry(dmaru, &dmar_drhd_units, list) {
+	for_each_drhd_unit(dmaru) {
 		drhd = container_of(dmaru->hdr,
 				    struct acpi_dmar_hardware_unit,
 				    header);
-- 
1.7.1



^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH 1/2] IOMMU/trivial: Use for_each_drhd_unit() instead of list_for_each_entry()
  2013-10-31  9:25 [PATCH 1/2] IOMMU/trivial: Use for_each_drhd_unit() instead of list_for_each_entry() Yijing Wang
@ 2013-11-01 13:19 ` Joerg Roedel
  0 siblings, 0 replies; 2+ messages in thread
From: Joerg Roedel @ 2013-11-01 13:19 UTC (permalink / raw)
  To: Yijing Wang; +Cc: David Woodhouse, iommu, linux-kernel, Hanjun Guo

On Thu, Oct 31, 2013 at 05:25:16PM +0800, Yijing Wang wrote:
> Use for_each_drhd_unit() instead of list_for_each_entry for
> better readability.
> 
> Signed-off-by: Yijing Wang <wangyijing@huawei.com>

Applied both, thanks.



^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2013-11-01 13:19 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-10-31  9:25 [PATCH 1/2] IOMMU/trivial: Use for_each_drhd_unit() instead of list_for_each_entry() Yijing Wang
2013-11-01 13:19 ` Joerg Roedel

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).