linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v3] bitops: Fix shift overflow in GENMASK macros
@ 2014-11-04 10:58 Maxime COQUELIN
  2014-11-04 13:27 ` Peter Zijlstra
  2014-11-05 11:10 ` Rasmus Villemoes
  0 siblings, 2 replies; 6+ messages in thread
From: Maxime COQUELIN @ 2014-11-04 10:58 UTC (permalink / raw)
  To: gong.chen, Peter Zijlstra, Ingo Molnar,  Paul E. McKenney, tytso,
	linux-kernel, stable
  Cc: kernel, maxime.coquelin, eric.paire

On some 32 bits architectures, including x86, GENMASK(31, 0) returns 0
instead of the expected ~0UL.

This is the same on some 64 bits architectures with GENMASK_ULL(63, 0).

This is due to an overflow in the shift operand, 1 << 32 for GENMASK,
1 << 64 for GENMASK_ULL.

Fixes: 10ef6b0dffe404bcc54e94cb2ca1a5b18445a66b
Cc: <stable@vger.kernel.org> #v3.13+
Reported-by: Eric Paire <eric.paire@st.com>
Suggested-by: Peter Zijlstra <peterz@infradead.org>
Signed-off-by: Maxime Coquelin <maxime.coquelin@st.com>
---
 include/linux/bitops.h | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/include/linux/bitops.h b/include/linux/bitops.h
index be5fd38..c2ce66c 100644
--- a/include/linux/bitops.h
+++ b/include/linux/bitops.h
@@ -18,8 +18,11 @@
  * position @h. For example
  * GENMASK_ULL(39, 21) gives us the 64bit vector 0x000000ffffe00000.
  */
-#define GENMASK(h, l)		(((U32_C(1) << ((h) - (l) + 1)) - 1) << (l))
-#define GENMASK_ULL(h, l)	(((U64_C(1) << ((h) - (l) + 1)) - 1) << (l))
+#define GENMASK(h, l) \
+	((~0UL >> (BITS_PER_LONG - ((h) - (l) + 1))) << (l))
+
+#define GENMASK_ULL(h, l) \
+	((~0ULL >> (BITS_PER_LONG_LONG - ((h) - (l) + 1))) << (l))
 
 extern unsigned int __sw_hweight8(unsigned int w);
 extern unsigned int __sw_hweight16(unsigned int w);
-- 
1.9.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH v3] bitops: Fix shift overflow in GENMASK macros
  2014-11-04 10:58 [PATCH v3] bitops: Fix shift overflow in GENMASK macros Maxime COQUELIN
@ 2014-11-04 13:27 ` Peter Zijlstra
  2014-11-05 11:10 ` Rasmus Villemoes
  1 sibling, 0 replies; 6+ messages in thread
From: Peter Zijlstra @ 2014-11-04 13:27 UTC (permalink / raw)
  To: Maxime COQUELIN
  Cc: gong.chen, Ingo Molnar,  Paul E. McKenney, tytso, linux-kernel,
	stable, kernel, eric.paire

On Tue, Nov 04, 2014 at 11:58:17AM +0100, Maxime COQUELIN wrote:
> On some 32 bits architectures, including x86, GENMASK(31, 0) returns 0
> instead of the expected ~0UL.
> 
> This is the same on some 64 bits architectures with GENMASK_ULL(63, 0).
> 
> This is due to an overflow in the shift operand, 1 << 32 for GENMASK,
> 1 << 64 for GENMASK_ULL.
> 
> Fixes: 10ef6b0dffe404bcc54e94cb2ca1a5b18445a66b
> Cc: <stable@vger.kernel.org> #v3.13+
> Reported-by: Eric Paire <eric.paire@st.com>
> Suggested-by: Peter Zijlstra <peterz@infradead.org>
> Signed-off-by: Maxime Coquelin <maxime.coquelin@st.com>


There doesn't appear to be a clear maintainer for this file, so I'll try
and stick in in tip.

Thanks!


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH v3] bitops: Fix shift overflow in GENMASK macros
  2014-11-04 10:58 [PATCH v3] bitops: Fix shift overflow in GENMASK macros Maxime COQUELIN
  2014-11-04 13:27 ` Peter Zijlstra
@ 2014-11-05 11:10 ` Rasmus Villemoes
  2014-11-05 15:47   ` Maxime Coquelin
  1 sibling, 1 reply; 6+ messages in thread
From: Rasmus Villemoes @ 2014-11-05 11:10 UTC (permalink / raw)
  To: Maxime COQUELIN
  Cc: gong.chen, Peter Zijlstra, Ingo Molnar,  Paul E. McKenney, tytso,
	linux-kernel, stable, kernel, eric.paire

On Tue, Nov 04 2014, Maxime COQUELIN <maxime.coquelin@st.com> wrote:

> -#define GENMASK(h, l)		(((U32_C(1) << ((h) - (l) + 1)) - 1) << (l))
> -#define GENMASK_ULL(h, l)	(((U64_C(1) << ((h) - (l) + 1)) - 1) << (l))
> +#define GENMASK(h, l) \
> +	((~0UL >> (BITS_PER_LONG - ((h) - (l) + 1))) << (l))
> +
> +#define GENMASK_ULL(h, l) \
> +	((~0ULL >> (BITS_PER_LONG_LONG - ((h) - (l) + 1))) << (l))

Slightly bikeshedding here, but may I suggest spelling it

  (((~0UL) << (l)) & (~0UL >> (BITS_PER_LONG - 1 - (h))))

? This will ensure the arguments are expanded once each, and will, IMHO,
DTRT if/when l > h (namely, yield 0).

Rasmus

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH v3] bitops: Fix shift overflow in GENMASK macros
  2014-11-05 11:10 ` Rasmus Villemoes
@ 2014-11-05 15:47   ` Maxime Coquelin
  2014-11-05 16:44     ` Peter Zijlstra
  0 siblings, 1 reply; 6+ messages in thread
From: Maxime Coquelin @ 2014-11-05 15:47 UTC (permalink / raw)
  To: Rasmus Villemoes
  Cc: gong.chen, Peter Zijlstra, Ingo Molnar, Paul E. McKenney, tytso,
	linux-kernel, stable, kernel, eric.paire


On 11/05/2014 12:10 PM, Rasmus Villemoes wrote:
> On Tue, Nov 04 2014, Maxime COQUELIN <maxime.coquelin@st.com> wrote:
>
>> -#define GENMASK(h, l)		(((U32_C(1) << ((h) - (l) + 1)) - 1) << (l))
>> -#define GENMASK_ULL(h, l)	(((U64_C(1) << ((h) - (l) + 1)) - 1) << (l))
>> +#define GENMASK(h, l) \
>> +	((~0UL >> (BITS_PER_LONG - ((h) - (l) + 1))) << (l))
>> +
>> +#define GENMASK_ULL(h, l) \
>> +	((~0ULL >> (BITS_PER_LONG_LONG - ((h) - (l) + 1))) << (l))
> Slightly bikeshedding here, but may I suggest spelling it
>
>    (((~0UL) << (l)) & (~0UL >> (BITS_PER_LONG - 1 - (h))))
>
> ? This will ensure the arguments are expanded once each, and will, IMHO,
> DTRT if/when l > h (namely, yield 0).
That's a good point.

Peter, what is your view?

Kind regards,
Maxime
>
> Rasmus


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH v3] bitops: Fix shift overflow in GENMASK macros
  2014-11-05 15:47   ` Maxime Coquelin
@ 2014-11-05 16:44     ` Peter Zijlstra
  2014-11-06  9:56       ` Maxime Coquelin
  0 siblings, 1 reply; 6+ messages in thread
From: Peter Zijlstra @ 2014-11-05 16:44 UTC (permalink / raw)
  To: Maxime Coquelin
  Cc: Rasmus Villemoes, gong.chen, Ingo Molnar, Paul E. McKenney,
	tytso, linux-kernel, stable, kernel, eric.paire

On Wed, Nov 05, 2014 at 04:47:14PM +0100, Maxime Coquelin wrote:
> 
> On 11/05/2014 12:10 PM, Rasmus Villemoes wrote:
> >On Tue, Nov 04 2014, Maxime COQUELIN <maxime.coquelin@st.com> wrote:
> >
> >>-#define GENMASK(h, l)		(((U32_C(1) << ((h) - (l) + 1)) - 1) << (l))
> >>-#define GENMASK_ULL(h, l)	(((U64_C(1) << ((h) - (l) + 1)) - 1) << (l))
> >>+#define GENMASK(h, l) \
> >>+	((~0UL >> (BITS_PER_LONG - ((h) - (l) + 1))) << (l))
> >>+
> >>+#define GENMASK_ULL(h, l) \
> >>+	((~0ULL >> (BITS_PER_LONG_LONG - ((h) - (l) + 1))) << (l))
> >Slightly bikeshedding here, but may I suggest spelling it
> >
> >   (((~0UL) << (l)) & (~0UL >> (BITS_PER_LONG - 1 - (h))))
> >
> >? This will ensure the arguments are expanded once each, and will, IMHO,
> >DTRT if/when l > h (namely, yield 0).
> That's a good point.
> 
> Peter, what is your view?

I'm fine with that, feel free to post another version and I'll replace
v3.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH v3] bitops: Fix shift overflow in GENMASK macros
  2014-11-05 16:44     ` Peter Zijlstra
@ 2014-11-06  9:56       ` Maxime Coquelin
  0 siblings, 0 replies; 6+ messages in thread
From: Maxime Coquelin @ 2014-11-06  9:56 UTC (permalink / raw)
  To: Peter Zijlstra
  Cc: Rasmus Villemoes, gong.chen, Ingo Molnar, Paul E. McKenney,
	tytso, linux-kernel, stable, kernel, eric.paire


On 11/05/2014 05:44 PM, Peter Zijlstra wrote:
> On Wed, Nov 05, 2014 at 04:47:14PM +0100, Maxime Coquelin wrote:
>> On 11/05/2014 12:10 PM, Rasmus Villemoes wrote:
>>> On Tue, Nov 04 2014, Maxime COQUELIN <maxime.coquelin@st.com> wrote:
>>>
>>>> -#define GENMASK(h, l)		(((U32_C(1) << ((h) - (l) + 1)) - 1) << (l))
>>>> -#define GENMASK_ULL(h, l)	(((U64_C(1) << ((h) - (l) + 1)) - 1) << (l))
>>>> +#define GENMASK(h, l) \
>>>> +	((~0UL >> (BITS_PER_LONG - ((h) - (l) + 1))) << (l))
>>>> +
>>>> +#define GENMASK_ULL(h, l) \
>>>> +	((~0ULL >> (BITS_PER_LONG_LONG - ((h) - (l) + 1))) << (l))
>>> Slightly bikeshedding here, but may I suggest spelling it
>>>
>>>    (((~0UL) << (l)) & (~0UL >> (BITS_PER_LONG - 1 - (h))))
>>>
>>> ? This will ensure the arguments are expanded once each, and will, IMHO,
>>> DTRT if/when l > h (namely, yield 0).
>> That's a good point.
>>
>> Peter, what is your view?
> I'm fine with that, feel free to post another version and I'll replace
> v3.

Thanks Peter, v4 just sent.

Regards,
Maxime

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2014-11-06  9:57 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-11-04 10:58 [PATCH v3] bitops: Fix shift overflow in GENMASK macros Maxime COQUELIN
2014-11-04 13:27 ` Peter Zijlstra
2014-11-05 11:10 ` Rasmus Villemoes
2014-11-05 15:47   ` Maxime Coquelin
2014-11-05 16:44     ` Peter Zijlstra
2014-11-06  9:56       ` Maxime Coquelin

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).