linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/4] sched / idle: Reduce the number of branches in the idle loop
@ 2015-05-04 13:54 Rafael J. Wysocki
  2015-05-04 13:56 ` [PATCH 1/4] sched / idle: Move the default idle call code to a separate function Rafael J. Wysocki
                   ` (4 more replies)
  0 siblings, 5 replies; 14+ messages in thread
From: Rafael J. Wysocki @ 2015-05-04 13:54 UTC (permalink / raw)
  To: Peter Zijlstra, Linux PM list; +Cc: Linux Kernel Mailing List, Daniel Lezcano

Hi,

The "reflect" variable that had to be added to cpuidle_idle_call() to fix a
regression during the 4.0 cycle has bothered me a bit since then and guess
what?  It is not necessary.

After the last regression fix related to tick_broadcast_exit() I realized
that it should be possible to eliminate this variable by splitting
cpuidle_idle_call() into smaller routines and reordering the code in
question which is done by this patch series.

It also gets rid of one more redundant check while at it.

[1/4] Move the default idle call code into a separate function.
[2/4] Make cpuidle_reflect() check the sign of its index arg.
[3/4] Eliminate the "reflect" check from cpuidle_idle_call().
[4/4] Eliminate a redundant check of the cpuidle_enter() return value.

All on top of 4.1-rc2.

Thanks!


-- 
I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.

^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, other threads:[~2015-05-04 20:58 UTC | newest]

Thread overview: 14+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-05-04 13:54 [PATCH 0/4] sched / idle: Reduce the number of branches in the idle loop Rafael J. Wysocki
2015-05-04 13:56 ` [PATCH 1/4] sched / idle: Move the default idle call code to a separate function Rafael J. Wysocki
2015-05-04 14:00   ` Daniel Lezcano
2015-05-04 14:22   ` Peter Zijlstra
2015-05-04 21:08     ` Rafael J. Wysocki
2015-05-04 13:57 ` [PATCH 2/4] cpuidle: Check the sign of index in cpuidle_reflect() Rafael J. Wysocki
2015-05-04 14:02   ` Daniel Lezcano
2015-05-04 13:57 ` [PATCH 3/4] sched / idle: Eliminate the "reflect" check from cpuidle_idle_call() Rafael J. Wysocki
2015-05-04 14:49   ` Daniel Lezcano
2015-05-04 13:58 ` [PATCH 4/4] sched / idle: Call default_idle_call() from cpuidle_enter_state() Rafael J. Wysocki
2015-05-04 15:04   ` Daniel Lezcano
2015-05-04 21:11     ` Rafael J. Wysocki
2015-05-04 14:25 ` [PATCH 0/4] sched / idle: Reduce the number of branches in the idle loop Peter Zijlstra
2015-05-04 21:23   ` Rafael J. Wysocki

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).