linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] mfd: da9062-core: Rename get_device_type to da9062_get_device_type
@ 2015-10-09 10:22 Axel Lin
  2015-10-13  8:18 ` Lee Jones
  0 siblings, 1 reply; 2+ messages in thread
From: Axel Lin @ 2015-10-09 10:22 UTC (permalink / raw)
  To: Lee Jones; +Cc: Support Opensource, Steve Twiss, linux-kernel

Rename get_device_type() to da9062_get_device_type().
This function is only used in this file so make it static.

Signed-off-by: Axel Lin <axel.lin@ingics.com>
---
 drivers/mfd/da9062-core.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/mfd/da9062-core.c b/drivers/mfd/da9062-core.c
index f80d947..a9ad024 100644
--- a/drivers/mfd/da9062-core.c
+++ b/drivers/mfd/da9062-core.c
@@ -198,7 +198,7 @@ static int da9062_clear_fault_log(struct da9062 *chip)
 	return ret;
 }
 
-int get_device_type(struct da9062 *chip)
+static int da9062_get_device_type(struct da9062 *chip)
 {
 	int device_id, variant_id, variant_mrc;
 	int ret;
@@ -466,7 +466,7 @@ static int da9062_i2c_probe(struct i2c_client *i2c,
 	if (ret < 0)
 		dev_warn(chip->dev, "Cannot clear fault log\n");
 
-	ret = get_device_type(chip);
+	ret = da9062_get_device_type(chip);
 	if (ret)
 		return ret;
 
-- 
2.1.4




^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] mfd: da9062-core: Rename get_device_type to da9062_get_device_type
  2015-10-09 10:22 [PATCH] mfd: da9062-core: Rename get_device_type to da9062_get_device_type Axel Lin
@ 2015-10-13  8:18 ` Lee Jones
  0 siblings, 0 replies; 2+ messages in thread
From: Lee Jones @ 2015-10-13  8:18 UTC (permalink / raw)
  To: Axel Lin; +Cc: Support Opensource, Steve Twiss, linux-kernel

On Fri, 09 Oct 2015, Axel Lin wrote:

> Rename get_device_type() to da9062_get_device_type().
> This function is only used in this file so make it static.
> 
> Signed-off-by: Axel Lin <axel.lin@ingics.com>
> ---
>  drivers/mfd/da9062-core.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Applied, thanks.

> diff --git a/drivers/mfd/da9062-core.c b/drivers/mfd/da9062-core.c
> index f80d947..a9ad024 100644
> --- a/drivers/mfd/da9062-core.c
> +++ b/drivers/mfd/da9062-core.c
> @@ -198,7 +198,7 @@ static int da9062_clear_fault_log(struct da9062 *chip)
>  	return ret;
>  }
>  
> -int get_device_type(struct da9062 *chip)
> +static int da9062_get_device_type(struct da9062 *chip)
>  {
>  	int device_id, variant_id, variant_mrc;
>  	int ret;
> @@ -466,7 +466,7 @@ static int da9062_i2c_probe(struct i2c_client *i2c,
>  	if (ret < 0)
>  		dev_warn(chip->dev, "Cannot clear fault log\n");
>  
> -	ret = get_device_type(chip);
> +	ret = da9062_get_device_type(chip);
>  	if (ret)
>  		return ret;
>  

-- 
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2015-10-13  8:18 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-10-09 10:22 [PATCH] mfd: da9062-core: Rename get_device_type to da9062_get_device_type Axel Lin
2015-10-13  8:18 ` Lee Jones

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).