linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0210/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 10:50 Baole Ni
  2016-08-03 15:23 ` Krzysztof Kozlowski
  0 siblings, 1 reply; 2+ messages in thread
From: Baole Ni @ 2016-08-02 10:50 UTC (permalink / raw)
  To: airlied, kyungmin.park, kgene, k.kozlowski, dougthompson, bp
  Cc: dri-devel, linux-kernel, airlied, daniel.vetter, treding,
	alexander.deucher, ville.syrjala, chuansheng.liu, baolex.ni

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 drivers/gpu/drm/qxl/qxl_drv.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/qxl/qxl_drv.c b/drivers/gpu/drm/qxl/qxl_drv.c
index dc9df5f..f62a099 100644
--- a/drivers/gpu/drm/qxl/qxl_drv.c
+++ b/drivers/gpu/drm/qxl/qxl_drv.c
@@ -51,10 +51,10 @@ static int qxl_modeset = -1;
 int qxl_num_crtc = 4;
 
 MODULE_PARM_DESC(modeset, "Disable/Enable modesetting");
-module_param_named(modeset, qxl_modeset, int, 0400);
+module_param_named(modeset, qxl_modeset, int, S_IRUSR);
 
 MODULE_PARM_DESC(num_heads, "Number of virtual crtcs to expose (default 4)");
-module_param_named(num_heads, qxl_num_crtc, int, 0400);
+module_param_named(num_heads, qxl_num_crtc, int, S_IRUSR);
 
 static struct drm_driver qxl_driver;
 static struct pci_driver qxl_pci_driver;
-- 
2.9.2

^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH 0210/1285] Replace numeric parameter like 0444 with macro
  2016-08-02 10:50 [PATCH 0210/1285] Replace numeric parameter like 0444 with macro Baole Ni
@ 2016-08-03 15:23 ` Krzysztof Kozlowski
  0 siblings, 0 replies; 2+ messages in thread
From: Krzysztof Kozlowski @ 2016-08-03 15:23 UTC (permalink / raw)
  To: Baole Ni
  Cc: airlied, kyungmin.park, kgene, k.kozlowski, dougthompson, bp,
	dri-devel, linux-kernel, airlied, daniel.vetter, treding,
	alexander.deucher, ville.syrjala, chuansheng.liu

On Tue, Aug 02, 2016 at 06:50:01PM +0800, Baole Ni wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
> 
> Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
> Signed-off-by: Baole Ni <baolex.ni@intel.com>
> ---
>  drivers/gpu/drm/qxl/qxl_drv.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

I got almost 1000 patches out of your mail bomb. For all of them: NACK.
Other people pointed actual reasons (title, readability, cc-list). The
commit msg should be also written in a more readable way.

Anyway, in Intel there are a lot of people having kernel contributions
so it is a shame that you didn't ask them for advice how to do it...

BR,
Krzysztof

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2016-08-03 16:19 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 10:50 [PATCH 0210/1285] Replace numeric parameter like 0444 with macro Baole Ni
2016-08-03 15:23 ` Krzysztof Kozlowski

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).