linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0157/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 10:45 Baole Ni
  2016-08-02 18:54 ` Olof Johansson
  0 siblings, 1 reply; 3+ messages in thread
From: Baole Ni @ 2016-08-02 10:45 UTC (permalink / raw)
  To: mchehab, maurochehab, mchehab, mchehab, m.chehab, olof, egor,
	dougthompson, bp
  Cc: linuxppc-dev, linux-edac, linux-kernel, chuansheng.liu,
	baolex.ni, lee.jones

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 drivers/edac/pasemi_edac.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/edac/pasemi_edac.c b/drivers/edac/pasemi_edac.c
index 9c971b5..8150e95 100644
--- a/drivers/edac/pasemi_edac.c
+++ b/drivers/edac/pasemi_edac.c
@@ -310,6 +310,6 @@ module_exit(pasemi_edac_exit);
 MODULE_LICENSE("GPL");
 MODULE_AUTHOR("Egor Martovetsky <egor@pasemi.com>");
 MODULE_DESCRIPTION("MC support for PA Semi PWRficient memory controller");
-module_param(edac_op_state, int, 0444);
+module_param(edac_op_state, int, S_IRUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(edac_op_state, "EDAC Error Reporting state: 0=Poll,1=NMI");
 
-- 
2.9.2

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH 0157/1285] Replace numeric parameter like 0444 with macro
  2016-08-02 10:45 [PATCH 0157/1285] Replace numeric parameter like 0444 with macro Baole Ni
@ 2016-08-02 18:54 ` Olof Johansson
  2016-08-02 19:11   ` Segher Boessenkool
  0 siblings, 1 reply; 3+ messages in thread
From: Olof Johansson @ 2016-08-02 18:54 UTC (permalink / raw)
  To: Baole Ni
  Cc: mchehab, maurochehab, mchehab, mchehab, m.chehab, egor,
	dougthompson, bp, linuxppc-dev, linux-edac, linux-kernel,
	chuansheng.liu, lee.jones

On Tue, Aug 02, 2016 at 06:45:15PM +0800, Baole Ni wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.

Am I the only one who find the readability to be MUCH better for the
numeric values?


-Olof

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH 0157/1285] Replace numeric parameter like 0444 with macro
  2016-08-02 18:54 ` Olof Johansson
@ 2016-08-02 19:11   ` Segher Boessenkool
  0 siblings, 0 replies; 3+ messages in thread
From: Segher Boessenkool @ 2016-08-02 19:11 UTC (permalink / raw)
  To: Olof Johansson
  Cc: Baole Ni, chuansheng.liu, maurochehab, mchehab, linux-edac,
	lee.jones, linux-kernel, mchehab, egor, dougthompson, bp,
	mchehab, linuxppc-dev, m.chehab

On Tue, Aug 02, 2016 at 11:54:47AM -0700, Olof Johansson wrote:
> On Tue, Aug 02, 2016 at 06:45:15PM +0800, Baole Ni wrote:
> > I find that the developers often just specified the numeric value
> > when calling a macro which is defined with a parameter for access permission.
> > As we know, these numeric value for access permission have had the corresponding macro,
> > and that using macro can improve the robustness and readability of the code,
> > thus, I suggest replacing the numeric parameter with the macro.
> 
> Am I the only one who find the readability to be MUCH better for the
> numeric values?

You are not the only one.  Robustness is a non-issue here as well (except
that this patch series showed that some mail servers struggle to handle
1285 emails).


Segher

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2016-08-02 20:34 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 10:45 [PATCH 0157/1285] Replace numeric parameter like 0444 with macro Baole Ni
2016-08-02 18:54 ` Olof Johansson
2016-08-02 19:11   ` Segher Boessenkool

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).