linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] vt: fix Scroll Lock LED trigger name
@ 2016-11-15 23:55 Maciej S. Szmigiero
  2016-11-16  0:19 ` Samuel Thibault
                   ` (2 more replies)
  0 siblings, 3 replies; 7+ messages in thread
From: Maciej S. Szmigiero @ 2016-11-15 23:55 UTC (permalink / raw)
  To: Greg Kroah-Hartman, Jiri Slaby
  Cc: Dmitry Torokhov, Samuel Thibault, linux-kernel

There is a disagreement between drivers/tty/vt/keyboard.c and
drivers/input/input-leds.c with regard to what is a Scroll Lock LED
trigger name: input calls it "kbd-scrolllock", but vt calls it
"kbd-scrollock" (two l's).
This prevents Scroll Lock LED trigger from binding to this LED by default.

Since it is a scroLL Lock LED, this interface was introduced only about a
year ago and in an Internet search people seem to reference this trigger
only to set it to this LED let's simply rename it to "kbd-scrolllock".

Also, it looks like this was supposed to be changed before this code was
merged: https://lkml.org/lkml/2015/6/9/697 but it was done only on
the input side.

Signed-off-by: Maciej S. Szmigiero <mail@maciej.szmigiero.name>
---
 drivers/tty/vt/keyboard.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/tty/vt/keyboard.c b/drivers/tty/vt/keyboard.c
index d5d81d4d3c04..3dd6a491cdba 100644
--- a/drivers/tty/vt/keyboard.c
+++ b/drivers/tty/vt/keyboard.c
@@ -982,7 +982,7 @@ static void kbd_led_trigger_activate(struct led_classdev *cdev)
 	KBD_LED_TRIGGER((_led_bit) + 8, _name)
 
 static struct kbd_led_trigger kbd_led_triggers[] = {
-	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrollock"),
+	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrolllock"),
 	KBD_LED_TRIGGER(VC_NUMLOCK,   "kbd-numlock"),
 	KBD_LED_TRIGGER(VC_CAPSLOCK,  "kbd-capslock"),
 	KBD_LED_TRIGGER(VC_KANALOCK,  "kbd-kanalock"),

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH] vt: fix Scroll Lock LED trigger name
  2016-11-15 23:55 [PATCH] vt: fix Scroll Lock LED trigger name Maciej S. Szmigiero
@ 2016-11-16  0:19 ` Samuel Thibault
  2016-11-16  7:24 ` Greg Kroah-Hartman
  2016-12-05 13:47 ` Pavel Machek
  2 siblings, 0 replies; 7+ messages in thread
From: Samuel Thibault @ 2016-11-16  0:19 UTC (permalink / raw)
  To: Maciej S. Szmigiero
  Cc: Greg Kroah-Hartman, Jiri Slaby, Dmitry Torokhov, linux-kernel

Maciej S. Szmigiero, on Wed 16 Nov 2016 00:55:57 +0100, wrote:
> There is a disagreement between drivers/tty/vt/keyboard.c and
> drivers/input/input-leds.c with regard to what is a Scroll Lock LED
> trigger name: input calls it "kbd-scrolllock", but vt calls it
> "kbd-scrollock" (two l's).
> This prevents Scroll Lock LED trigger from binding to this LED by default.
> 
> Since it is a scroLL Lock LED, this interface was introduced only about a
> year ago and in an Internet search people seem to reference this trigger
> only to set it to this LED let's simply rename it to "kbd-scrolllock".
> 
> Also, it looks like this was supposed to be changed before this code was
> merged: https://lkml.org/lkml/2015/6/9/697 but it was done only on
> the input side.
> 
> Signed-off-by: Maciej S. Szmigiero <mail@maciej.szmigiero.name>

Acked-by: Samuel Thibault <samuel.thibault@ens-lyon.org>

> ---
>  drivers/tty/vt/keyboard.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/tty/vt/keyboard.c b/drivers/tty/vt/keyboard.c
> index d5d81d4d3c04..3dd6a491cdba 100644
> --- a/drivers/tty/vt/keyboard.c
> +++ b/drivers/tty/vt/keyboard.c
> @@ -982,7 +982,7 @@ static void kbd_led_trigger_activate(struct led_classdev *cdev)
>  	KBD_LED_TRIGGER((_led_bit) + 8, _name)
>  
>  static struct kbd_led_trigger kbd_led_triggers[] = {
> -	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrollock"),
> +	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrolllock"),
>  	KBD_LED_TRIGGER(VC_NUMLOCK,   "kbd-numlock"),
>  	KBD_LED_TRIGGER(VC_CAPSLOCK,  "kbd-capslock"),
>  	KBD_LED_TRIGGER(VC_KANALOCK,  "kbd-kanalock"),
> 

-- 
Samuel
"2 + 2 = 5 pour d'assez grandes valeurs de 2"

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] vt: fix Scroll Lock LED trigger name
  2016-11-15 23:55 [PATCH] vt: fix Scroll Lock LED trigger name Maciej S. Szmigiero
  2016-11-16  0:19 ` Samuel Thibault
@ 2016-11-16  7:24 ` Greg Kroah-Hartman
  2016-11-16  8:10   ` Samuel Thibault
  2016-12-05 13:47 ` Pavel Machek
  2 siblings, 1 reply; 7+ messages in thread
From: Greg Kroah-Hartman @ 2016-11-16  7:24 UTC (permalink / raw)
  To: Maciej S. Szmigiero
  Cc: Jiri Slaby, Dmitry Torokhov, Samuel Thibault, linux-kernel

On Wed, Nov 16, 2016 at 12:55:57AM +0100, Maciej S. Szmigiero wrote:
> There is a disagreement between drivers/tty/vt/keyboard.c and
> drivers/input/input-leds.c with regard to what is a Scroll Lock LED
> trigger name: input calls it "kbd-scrolllock", but vt calls it
> "kbd-scrollock" (two l's).
> This prevents Scroll Lock LED trigger from binding to this LED by default.
> 
> Since it is a scroLL Lock LED, this interface was introduced only about a
> year ago and in an Internet search people seem to reference this trigger
> only to set it to this LED let's simply rename it to "kbd-scrolllock".
> 
> Also, it looks like this was supposed to be changed before this code was
> merged: https://lkml.org/lkml/2015/6/9/697 but it was done only on
> the input side.
> 
> Signed-off-by: Maciej S. Szmigiero <mail@maciej.szmigiero.name>
> ---
>  drivers/tty/vt/keyboard.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/tty/vt/keyboard.c b/drivers/tty/vt/keyboard.c
> index d5d81d4d3c04..3dd6a491cdba 100644
> --- a/drivers/tty/vt/keyboard.c
> +++ b/drivers/tty/vt/keyboard.c
> @@ -982,7 +982,7 @@ static void kbd_led_trigger_activate(struct led_classdev *cdev)
>  	KBD_LED_TRIGGER((_led_bit) + 8, _name)
>  
>  static struct kbd_led_trigger kbd_led_triggers[] = {
> -	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrollock"),
> +	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrolllock"),
>  	KBD_LED_TRIGGER(VC_NUMLOCK,   "kbd-numlock"),
>  	KBD_LED_TRIGGER(VC_CAPSLOCK,  "kbd-capslock"),
>  	KBD_LED_TRIGGER(VC_KANALOCK,  "kbd-kanalock"),

So, how far back should this change be backported to?

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] vt: fix Scroll Lock LED trigger name
  2016-11-16  7:24 ` Greg Kroah-Hartman
@ 2016-11-16  8:10   ` Samuel Thibault
  2016-11-16  8:15     ` Greg Kroah-Hartman
  0 siblings, 1 reply; 7+ messages in thread
From: Samuel Thibault @ 2016-11-16  8:10 UTC (permalink / raw)
  To: Greg Kroah-Hartman
  Cc: Maciej S. Szmigiero, Jiri Slaby, Dmitry Torokhov, linux-kernel

Hello,

Greg Kroah-Hartman, on Wed 16 Nov 2016 08:24:42 +0100, wrote:
> >  static struct kbd_led_trigger kbd_led_triggers[] = {
> > -	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrollock"),
> > +	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrolllock"),
> >  	KBD_LED_TRIGGER(VC_NUMLOCK,   "kbd-numlock"),
> >  	KBD_LED_TRIGGER(VC_CAPSLOCK,  "kbd-capslock"),
> >  	KBD_LED_TRIGGER(VC_KANALOCK,  "kbd-kanalock"),
> 
> So, how far back should this change be backported to?

This was introduced in Linux 4.2.

Samuel

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] vt: fix Scroll Lock LED trigger name
  2016-11-16  8:10   ` Samuel Thibault
@ 2016-11-16  8:15     ` Greg Kroah-Hartman
  0 siblings, 0 replies; 7+ messages in thread
From: Greg Kroah-Hartman @ 2016-11-16  8:15 UTC (permalink / raw)
  To: Samuel Thibault, Maciej S. Szmigiero, Jiri Slaby,
	Dmitry Torokhov, linux-kernel

On Wed, Nov 16, 2016 at 09:10:04AM +0100, Samuel Thibault wrote:
> Hello,
> 
> Greg Kroah-Hartman, on Wed 16 Nov 2016 08:24:42 +0100, wrote:
> > >  static struct kbd_led_trigger kbd_led_triggers[] = {
> > > -	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrollock"),
> > > +	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrolllock"),
> > >  	KBD_LED_TRIGGER(VC_NUMLOCK,   "kbd-numlock"),
> > >  	KBD_LED_TRIGGER(VC_CAPSLOCK,  "kbd-capslock"),
> > >  	KBD_LED_TRIGGER(VC_KANALOCK,  "kbd-kanalock"),
> > 
> > So, how far back should this change be backported to?
> 
> This was introduced in Linux 4.2.

Great, thanks for letting me know.

greg k-h

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] vt: fix Scroll Lock LED trigger name
  2016-11-15 23:55 [PATCH] vt: fix Scroll Lock LED trigger name Maciej S. Szmigiero
  2016-11-16  0:19 ` Samuel Thibault
  2016-11-16  7:24 ` Greg Kroah-Hartman
@ 2016-12-05 13:47 ` Pavel Machek
  2016-12-05 16:23   ` Samuel Thibault
  2 siblings, 1 reply; 7+ messages in thread
From: Pavel Machek @ 2016-12-05 13:47 UTC (permalink / raw)
  To: Maciej S. Szmigiero
  Cc: Greg Kroah-Hartman, Jiri Slaby, Dmitry Torokhov, Samuel Thibault,
	linux-kernel

[-- Attachment #1: Type: text/plain, Size: 1584 bytes --]

Hi!

> There is a disagreement between drivers/tty/vt/keyboard.c and
> drivers/input/input-leds.c with regard to what is a Scroll Lock LED
> trigger name: input calls it "kbd-scrolllock", but vt calls it
> "kbd-scrollock" (two l's).
> This prevents Scroll Lock LED trigger from binding to this LED by default.
> 
> Since it is a scroLL Lock LED, this interface was introduced only about a
> year ago and in an Internet search people seem to reference this trigger
> only to set it to this LED let's simply rename it to "kbd-scrolllock".
> 
> Also, it looks like this was supposed to be changed before this code was
> merged: https://lkml.org/lkml/2015/6/9/697 but it was done only on
> the input side.
> 
> Signed-off-by: Maciej S. Szmigiero <mail@maciej.szmigiero.name>
> ---
>  drivers/tty/vt/keyboard.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/tty/vt/keyboard.c b/drivers/tty/vt/keyboard.c
> index d5d81d4d3c04..3dd6a491cdba 100644
> --- a/drivers/tty/vt/keyboard.c
> +++ b/drivers/tty/vt/keyboard.c
> @@ -982,7 +982,7 @@ static void kbd_led_trigger_activate(struct led_classdev *cdev)
>  	KBD_LED_TRIGGER((_led_bit) + 8, _name)
>  
>  static struct kbd_led_trigger kbd_led_triggers[] = {
> -	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrollock"),
> +	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrolllock"),

Would it be feasible to rename "VC_SCROLLOCK" to "VC_SCROLLLOCK", too?

-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 181 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] vt: fix Scroll Lock LED trigger name
  2016-12-05 13:47 ` Pavel Machek
@ 2016-12-05 16:23   ` Samuel Thibault
  0 siblings, 0 replies; 7+ messages in thread
From: Samuel Thibault @ 2016-12-05 16:23 UTC (permalink / raw)
  To: Pavel Machek
  Cc: Maciej S. Szmigiero, Greg Kroah-Hartman, Jiri Slaby,
	Dmitry Torokhov, linux-kernel

Hello,

Pavel Machek, on Mon 05 Dec 2016 14:47:43 +0100, wrote:
> > There is a disagreement between drivers/tty/vt/keyboard.c and
> > drivers/input/input-leds.c with regard to what is a Scroll Lock LED
> > trigger name: input calls it "kbd-scrolllock", but vt calls it
> > "kbd-scrollock" (two l's).
> > This prevents Scroll Lock LED trigger from binding to this LED by default.
> > 
> > Since it is a scroLL Lock LED, this interface was introduced only about a
> > year ago and in an Internet search people seem to reference this trigger
> > only to set it to this LED let's simply rename it to "kbd-scrolllock".
> > 
> > Also, it looks like this was supposed to be changed before this code was
> > merged: https://lkml.org/lkml/2015/6/9/697 but it was done only on
> > the input side.
> > 
> > Signed-off-by: Maciej S. Szmigiero <mail@maciej.szmigiero.name>
> > ---
> >  drivers/tty/vt/keyboard.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/drivers/tty/vt/keyboard.c b/drivers/tty/vt/keyboard.c
> > index d5d81d4d3c04..3dd6a491cdba 100644
> > --- a/drivers/tty/vt/keyboard.c
> > +++ b/drivers/tty/vt/keyboard.c
> > @@ -982,7 +982,7 @@ static void kbd_led_trigger_activate(struct led_classdev *cdev)
> >  	KBD_LED_TRIGGER((_led_bit) + 8, _name)
> >  
> >  static struct kbd_led_trigger kbd_led_triggers[] = {
> > -	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrollock"),
> > +	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrolllock"),
> 
> Would it be feasible to rename "VC_SCROLLOCK" to "VC_SCROLLLOCK", too?

Well, no, that's a misnamed userland API.

Samuel

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2016-12-05 16:23 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-11-15 23:55 [PATCH] vt: fix Scroll Lock LED trigger name Maciej S. Szmigiero
2016-11-16  0:19 ` Samuel Thibault
2016-11-16  7:24 ` Greg Kroah-Hartman
2016-11-16  8:10   ` Samuel Thibault
2016-11-16  8:15     ` Greg Kroah-Hartman
2016-12-05 13:47 ` Pavel Machek
2016-12-05 16:23   ` Samuel Thibault

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).