linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/1] drivers/staging/vt6656/main_usb.c: usb_device_reset
@ 2017-04-18  8:24 Chewie Lin
  2017-04-18  8:24 ` [PATCH 1/1] " Chewie Lin
  0 siblings, 1 reply; 4+ messages in thread
From: Chewie Lin @ 2017-04-18  8:24 UTC (permalink / raw)
  To: greg, forest, devel, linux-kernel

Hi, 
This is a simple patch as a part of learning about kernel device driver
in the Eudyptula challenge. thanks again for your time!

linsh

Chewie Lin (1):
  drivers/staging/vt6656/main_usb.c: usb_device_reset

 drivers/staging/vt6656/main_usb.c | 15 ++++-----------
 1 file changed, 4 insertions(+), 11 deletions(-)

-- 
2.12.2

^ permalink raw reply	[flat|nested] 4+ messages in thread

* [PATCH 1/1] drivers/staging/vt6656/main_usb.c: usb_device_reset
  2017-04-18  8:24 [PATCH 0/1] drivers/staging/vt6656/main_usb.c: usb_device_reset Chewie Lin
@ 2017-04-18  8:24 ` Chewie Lin
  2017-04-18  8:33   ` Greg KH
  0 siblings, 1 reply; 4+ messages in thread
From: Chewie Lin @ 2017-04-18  8:24 UTC (permalink / raw)
  To: greg, forest, devel, linux-kernel

Removed the usb_device_reset(), replace with call to usb_reset_device() 
directly. Plus it removes the confusing function name and addressed 
the checkpatch warning as well by swap string in the dev_warn() call with 
__func__ argument, instead of explicitly calling the function name in 
the string:

        WARNING: Prefer using "%s", __func__ to embedded function names
        #417: FILE: main_usb.c:417:
        +                        "usb_device_reset fail status=%d\n", status);

        total: 0 errors, 1 warnings, 1058 lines checked

And after fix:

         main_usb.c has no obvious style problems and is ready for submission.


Signed-off-by: Chewie Lin <linsh@oregonstate.edu>
---
 drivers/staging/vt6656/main_usb.c | 15 ++++-----------
 1 file changed, 4 insertions(+), 11 deletions(-)

diff --git a/drivers/staging/vt6656/main_usb.c b/drivers/staging/vt6656/main_usb.c
index 9e074e9daf4e..028f54b453d0 100644
--- a/drivers/staging/vt6656/main_usb.c
+++ b/drivers/staging/vt6656/main_usb.c
@@ -407,16 +407,6 @@ static void vnt_free_rx_bufs(struct vnt_private *priv)
 	}
 }
 
-static void usb_device_reset(struct vnt_private *priv)
-{
-	int status;
-
-	status = usb_reset_device(priv->usb);
-	if (status)
-		dev_warn(&priv->usb->dev,
-			 "usb_device_reset fail status=%d\n", status);
-}
-
 static void vnt_free_int_bufs(struct vnt_private *priv)
 {
 	kfree(priv->int_buf.data_buf);
@@ -995,7 +985,10 @@ vt6656_probe(struct usb_interface *intf, const struct usb_device_id *id)
 
 	SET_IEEE80211_DEV(priv->hw, &intf->dev);
 
-	usb_device_reset(priv);
+	rc = usb_reset_device(priv->usb);
+	if (rc)
+		dev_warn(&priv->usb->dev,
+			 "%s reset fail status=%d\n", __func__, rc);
 
 	clear_bit(DEVICE_FLAGS_DISCONNECTED, &priv->flags);
 	vnt_reset_command_timer(priv);
-- 
2.12.2

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/1] drivers/staging/vt6656/main_usb.c: usb_device_reset
  2017-04-18  8:24 ` [PATCH 1/1] " Chewie Lin
@ 2017-04-18  8:33   ` Greg KH
  2017-04-18 10:32     ` Joe Perches
  0 siblings, 1 reply; 4+ messages in thread
From: Greg KH @ 2017-04-18  8:33 UTC (permalink / raw)
  To: Chewie Lin; +Cc: forest, devel, linux-kernel

On Tue, Apr 18, 2017 at 01:24:37AM -0700, Chewie Lin wrote:
> Removed the usb_device_reset(), replace with call to usb_reset_device() 
> directly. Plus it removes the confusing function name and addressed 
> the checkpatch warning as well by swap string in the dev_warn() call with 
> __func__ argument, instead of explicitly calling the function name in 
> the string:
> 
>         WARNING: Prefer using "%s", __func__ to embedded function names
>         #417: FILE: main_usb.c:417:
>         +                        "usb_device_reset fail status=%d\n", status);
> 
>         total: 0 errors, 1 warnings, 1058 lines checked
> 
> And after fix:
> 
>          main_usb.c has no obvious style problems and is ready for submission.
> 
> 
> Signed-off-by: Chewie Lin <linsh@oregonstate.edu>

Your subject line is odd, don't you think?  Compare it to other patches
for this driver and please fix it up and resend.

And there's never a need for a 0/X email for a single patch submission,
no need to do that again.

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/1] drivers/staging/vt6656/main_usb.c: usb_device_reset
  2017-04-18  8:33   ` Greg KH
@ 2017-04-18 10:32     ` Joe Perches
  0 siblings, 0 replies; 4+ messages in thread
From: Joe Perches @ 2017-04-18 10:32 UTC (permalink / raw)
  To: Greg KH, Chewie Lin; +Cc: forest, devel, linux-kernel

On Tue, 2017-04-18 at 10:33 +0200, Greg KH wrote:
> On Tue, Apr 18, 2017 at 01:24:37AM -0700, Chewie Lin wrote:
> > Removed the usb_device_reset(), replace with call to usb_reset_device() 
> > directly. Plus it removes the confusing function name and addressed 
> > the checkpatch warning as well by swap string in the dev_warn() call with 
> > __func__ argument, instead of explicitly calling the function name in 
> > the string:
> > 
> >         WARNING: Prefer using "%s", __func__ to embedded function names
> >         #417: FILE: main_usb.c:417:
> >         +                        "usb_device_reset fail status=%d\n", status);
> > 
> >         total: 0 errors, 1 warnings, 1058 lines checked
> > 
> > And after fix:
> > 
> >          main_usb.c has no obvious style problems and is ready for submission.
> > 
> > 
> > Signed-off-by: Chewie Lin <linsh@oregonstate.edu>
> 
> Your subject line is odd, don't you think?  Compare it to other patches
> for this driver and please fix it up and resend.
> 
> And there's never a need for a 0/X email for a single patch submission,
> no need to do that again.

And __func__ here is vt6656_probe not usb_reset_device.

usb_reset_device is the function that failed.

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2017-04-18 10:32 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-04-18  8:24 [PATCH 0/1] drivers/staging/vt6656/main_usb.c: usb_device_reset Chewie Lin
2017-04-18  8:24 ` [PATCH 1/1] " Chewie Lin
2017-04-18  8:33   ` Greg KH
2017-04-18 10:32     ` Joe Perches

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).