linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Peter Zijlstra <peterz@infradead.org>
To: "Rafael J. Wysocki" <rjw@rjwysocki.net>
Cc: Linux PM <linux-pm@vger.kernel.org>,
	LKML <linux-kernel@vger.kernel.org>,
	Linux ACPI <linux-acpi@vger.kernel.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	Srinivas Pandruvada <srinivas.pandruvada@linux.intel.com>,
	Jacob Pan <jacob.jun.pan@linux.intel.com>,
	Len Brown <lenb@kernel.org>,
	Daniel Lezcano <daniel.lezcano@linaro.org>
Subject: Re: [PATCH 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_S2IDLE
Date: Mon, 7 Aug 2017 10:49:56 +0200	[thread overview]
Message-ID: <20170807084956.4kxkb2y7yxxi4ivw@hirez.programming.kicks-ass.net> (raw)
In-Reply-To: <3267088.f3JVtvJoiF@aspire.rjw.lan>

On Sat, Aug 05, 2017 at 02:56:43PM +0200, Rafael J. Wysocki wrote:
> From: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
> 
> To make it clear that the symbol in question refers to
> suspend-to-idle, rename it from PM_SUSPEND_FREEZE to
> PM_SUSPEND_S2IDLE.
> 
> Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
> ---
>  drivers/acpi/sleep.c             |    2 -
>  drivers/regulator/of_regulator.c |    2 -
>  include/linux/suspend.h          |    4 +--
>  kernel/power/suspend.c           |   44 +++++++++++++++++++--------------------
>  kernel/power/suspend_test.c      |    4 +--
>  5 files changed, 28 insertions(+), 28 deletions(-)
> 
> Index: linux-pm/include/linux/suspend.h
> ===================================================================
> --- linux-pm.orig/include/linux/suspend.h
> +++ linux-pm/include/linux/suspend.h
> @@ -33,10 +33,10 @@ static inline void pm_restore_console(vo
>  typedef int __bitwise suspend_state_t;
>  
>  #define PM_SUSPEND_ON		((__force suspend_state_t) 0)
> -#define PM_SUSPEND_FREEZE	((__force suspend_state_t) 1)
> +#define PM_SUSPEND_S2IDLE	((__force suspend_state_t) 1)
>  #define PM_SUSPEND_STANDBY	((__force suspend_state_t) 2)
>  #define PM_SUSPEND_MEM		((__force suspend_state_t) 3)

I feel something like PM_SUSPEND_IDLE is more consistent with the
existing PM_SUSPEND_MEM. Also the proposed PM_SUSPEND_S2IDLE has
'SUSPEND' in it twice, so at the very least it should be
PM_SUSPEND_2IDLE :-)


> -#define PM_SUSPEND_MIN		PM_SUSPEND_FREEZE
> +#define PM_SUSPEND_MIN		PM_SUSPEND_S2IDLE
>  #define PM_SUSPEND_MAX		((__force suspend_state_t) 4)

  reply	other threads:[~2017-08-07  8:50 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-08-05 12:55 [PATCH 0/4] PM: Replace "freeze" with "s2idle" in item names related to suspend-to-idle Rafael J. Wysocki
2017-08-05 12:56 ` [PATCH 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_S2IDLE Rafael J. Wysocki
2017-08-07  8:49   ` Peter Zijlstra [this message]
2017-08-07 11:57     ` Rafael J. Wysocki
2017-08-07 12:00       ` Rafael J. Wysocki
2017-08-05 12:58 ` [PATCH 2/4] PM / s2idle: Rename freeze_state enum and related items Rafael J. Wysocki
2017-08-05 12:59 ` [PATCH 3/4] PM / s2idle: Rename ->enter_freeze to ->enter_s2idle Rafael J. Wysocki
2017-08-05 13:00 ` [PATCH 4/4] PM / s2idle: Rename platform operations structure Rafael J. Wysocki
2017-08-09 22:11 ` [PATCH v2 0/4] PM: Replace "freeze" with "s2idle" in item names related to suspend-to-idle Rafael J. Wysocki
2017-08-09 22:13   ` [PATCH v2 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_TO_IDLE Rafael J. Wysocki
2017-08-09 22:13   ` [PATCH v2 2/4] PM / s2idle: Rename freeze_state enum and related items Rafael J. Wysocki
2017-08-09 22:14   ` [PATCH v2 3/4] PM / s2idle: Rename ->enter_freeze to ->enter_s2idle Rafael J. Wysocki
2017-08-09 22:15   ` [PATCH v2 4/4] PM / s2idle: Rename platform operations structure Rafael J. Wysocki

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170807084956.4kxkb2y7yxxi4ivw@hirez.programming.kicks-ass.net \
    --to=peterz@infradead.org \
    --cc=daniel.lezcano@linaro.org \
    --cc=jacob.jun.pan@linux.intel.com \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=rjw@rjwysocki.net \
    --cc=srinivas.pandruvada@linux.intel.com \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).