linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [RFC V7 0/2] OPP: Allow OPP table to be used for power-domains
@ 2017-10-31 12:47 Viresh Kumar
  2017-10-31 12:47 ` [RFC V7 1/2] " Viresh Kumar
                   ` (2 more replies)
  0 siblings, 3 replies; 25+ messages in thread
From: Viresh Kumar @ 2017-10-31 12:47 UTC (permalink / raw)
  To: ulf.hansson, Kevin Hilman
  Cc: Viresh Kumar, Rafael Wysocki, linux-pm, Stephen Boyd,
	Nishanth Menon, Vincent Guittot, robh+dt, rnayak, sudeep.holla,
	devicetree, linux-kernel, Viresh Kumar

Hi,

Now that the performance state of PM domains are supported by the kernel
(merged in linux-next), I am trying once again to define the bindings
which we dropped until the code is merged first.

This is targeted for 4.16 kernel and I am sending it now to get early
reviews.

The bindings in this series have changed a bit since the time it was
last sent for review [1].

I have taken care of most of the feedback given last time.

Summary:

Power-domains can also have their active states and this patchset
enhances the OPP binding to define those.

The power domains can use the OPP bindings mostly as is. Though there
are some changes required to support special cases:

- Allow "operating-points-v2" to contain multiple phandles for power
  domain providers providing multiple domains.

- A new property "power-domain-opp" is added for devices to specify the
  minimum required OPP of the master domain for the functioning of the
  device. We can add this property directly to device's node if the
  device has a fixed minimum OPP requirement from the master power
  domain. Or we can add this property to each OPP node of the device, if
  different OPP nodes have different minimum OPP requirement from the
  master power domain.

- Allow some of the OPP properties to accept magic values (firmware
  dependent) as the OS doesn't know the real freq/voltage values.

--
viresh

[1] https://marc.info/?l=linux-kernel&m=149320428621874&w=2

Viresh Kumar (2):
  OPP: Allow OPP table to be used for power-domains
  OPP: Allow "opp-hz" and "opp-microvolt" to contain magic values

 Documentation/devicetree/bindings/opp/opp.txt      | 18 +++++++
 .../devicetree/bindings/power/power_domain.txt     | 62 ++++++++++++++++++++++
 2 files changed, 80 insertions(+)

-- 
2.15.0.rc1.236.g92ea95045093

^ permalink raw reply	[flat|nested] 25+ messages in thread

end of thread, other threads:[~2017-12-28  4:32 UTC | newest]

Thread overview: 25+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-10-31 12:47 [RFC V7 0/2] OPP: Allow OPP table to be used for power-domains Viresh Kumar
2017-10-31 12:47 ` [RFC V7 1/2] " Viresh Kumar
2017-11-28 15:50   ` Ulf Hansson
2017-11-29 16:46   ` Rob Herring
2017-11-30  4:48     ` Viresh Kumar
2017-10-31 12:47 ` [RFC V7 2/2] OPP: Allow "opp-hz" and "opp-microvolt" to contain magic values Viresh Kumar
2017-10-31 16:02   ` Rob Herring
2017-11-01  2:17     ` Viresh Kumar
2017-11-01 20:39       ` Rob Herring
2017-11-01 21:43         ` Stephen Boyd
2017-11-02  4:51           ` Viresh Kumar
2017-11-02  7:15             ` Stephen Boyd
2017-11-02  9:00               ` Viresh Kumar
2017-11-28 16:38                 ` Ulf Hansson
2017-11-30  0:50                   ` Stephen Boyd
2017-11-30  6:59                     ` Viresh Kumar
2017-12-14  7:30                       ` Viresh Kumar
2017-12-26 20:23                       ` Rob Herring
2017-12-27  4:45                         ` Viresh Kumar
2017-12-27 21:36                           ` Rob Herring
2017-12-28  4:32                             ` Viresh Kumar
2017-11-02  4:49         ` Viresh Kumar
2017-11-28 16:14   ` Ulf Hansson
2017-11-29  4:14 ` [RFC V7 0/2] OPP: Allow OPP table to be used for power-domains Viresh Kumar
2017-11-29 16:37   ` Rob Herring

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).